11.4 startup fails

Same problem with 11.4 x64 DVD version (gnome default). System ends with text before showing logon screen allso in failsafe :frowning:

linux login:gdm[1267]: WARNING: GdmDisplay: display lasted 1.088891 seconds
…so on
…so on
…and so on
gdm[1267]: WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors
WARNING: Number of errors: 0, skipped probes 16

command “/sbin/lspci -nnk” gives line VGA:

VGA compatible controller [0300]: ATI Technologies Inc M76XT [Mobility Radeon HD2600 XT] [1002:9583]
subsystem: Fujitsu Technology Solutions Device [1734:1107]

My Hardware: Laptop Fujitsu Siemens Amilo Xi2550, 2.0 Dual Core Intel Centrino, 4GB RAM, ATIRadeon HD 2600

please anny advice would be helpfull, thank you in advance!!!

Its interesting … your HD 2600 gets a LOT further than my HD 3450, which simply freezes immediately after the kernel load and before the boot. I wrote a bug report on the behaviour that I encounter.

What you could do is try the boot code (in the grub menu options line) “nomodeset” (no quotes) and see if that will successfully boot to the radeonhd graphic driver.

If that fails, you could try booting using “safesettings” (under F3 I think in liveCD) or “failsafe” (if installation already complete).

Ultimately, I think the proprietary ATI graphic driver (fglrx) should work well.

Here is some basic openSUSE practical graphic theory: openSUSE Graphic Card Practical Theory Guide for Users scroll down to the ATI section.

That is more ‘theory’ than a how-to-guide. Wrt graphics guide you could also look here: SDB:Configuring graphics cards - openSUSE

Ok, i have tried “nomodeset”, aswell as failsafe (allready installed), nothing works. hope you experienced will solve this quickly!!!

I will go trough your guide, if it has something in store for me. thanky you

P.S.: Everyone should realy consider first using live cd prior full sytem update :slight_smile:

Did you run “yast” (you can run yast in text mode with root permissions if X window not available) and navigate to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. This takes a minute or two to save once changed is submitted.

Also, before you burned the installation CD/DVD did you check the md5sum of the downloaded ISO file against that on the openSUSE web site? Were they the same ? Did you burn to a +R or -R CD/DVD media (not to an RW) at the slowest speed your burner allows? And also, did you use high quality CD/DVD media and not some bargain basement brand?

I just tested 11.4 GM version (64-bit KDE liveCD) on my Dell Studio 1537, and custom built the proprietary ATI driver into memory (since I did not want to install) and I managed to get it to work:
see post#27 here - OpenSuse 11.4 startup problems

… I don’t plan on installing 11.4 on this laptop due to problems with 11.4 and the Intel WiFi 5300AGN wireless. But the ATI graphics, despite the hiccup I encountered, appears to work with the Radeon HD3450 implemented in my Dell Studio 1537 laptop.

So am i stupid or what, i tried another install, yet again clean install just in case with same settings, but… this time i was configuring what software to install (same thing as last time, same choices), then before aproving final installation procedure i clicked system, then VGA driver and selected options and looked around, kliked ok and continued… my system mysteriouslz started X, my 11.4 DVD gnome is Working, same case on desktop with KDE :slight_smile:

you tell me which info u need and you will get it, i am not so experienced yet to figure it out by myself

p.s.: my first machine is a laptop so all hardware was unchanged, same on desktop…

And a nice looking LINUX this is!!!

Hm, interesting indeed i used dvd RW :slight_smile: Verbatim this is and a new one “DVD+RW 4X”
before trying to install again i did have burned it again in nero :slight_smile: could this be something?