11.4: Routing (Default Gateway) or DNS problem?

I did a fresh install of 11.4 x86_64 with KDE 4.6.0 for a client of mine which uses openSUSE because of me. (I’m the only one that does maintenance for the client).
The client has a wireless DSL modem which is connected to the SUSE PC via an ethernet cable. It is also broadcasting a wireless network for the client’s laptop.
Before I formatted and did the install, one of the things I double-checked was the network settings (networkmanager was used). Accessing the internet via any web browser worked fine and so did updates via YaST. I hadn’t set any specific network options and there wasn’t an entry in the wired, wireless or DSL connection tabs of the networkmanager plasmoid.
However, after installing 11.4 and using networkmanager to do the networking, there is a problem: I can access the net via Firefox or Konqueror but not with YaST. I checked and the SUSE mirrors weren’t down. So I created a new wired connection and hard-coded the DNS servers from the ISP thinking that it might have been a DNS problem. This didn’t solve the problem. I also tried disabling IPv6 in the YaST network settings and rebooting but this didn’t affect anything either.
I think this is the most important detail:
I then realized that if I entered IP addresses in the repositories configuration instead of using words, i.e. ‘download.opensuse.org/repositories’ they would resolve and work. (I knew YaST/zypper used words instead of IP addresses, but I didn’t remember that until this point).
I noticed that in 11.4 zypper has switched backends from aria to curl. Does anyone think this could be the problem or have something to do with it?
This is a problem that has cropped up in the configuration of this system with 11.4.
I don’t have the PC with me now so I can’t give the result of any output, but I’m hoping I can be pointed in the general direction as to how to possibly solve this problem.
Reading around the forum looking for a similar problem it seems to be that this might have something to do with the default gateway?

Any Moderator: Please move this thread to the Network/Internet section.
Sorry for the mistake.

Moved as required.

You can see your default gateway with

netstat -r

But when you say you can reach systems by IP adress and not by name, this is not a routing problem, but a name resolving problem.

Whenever I hard code IPs for Name Servers, I also hard code the gateway IP. Try that. (I think you said you coded only the Name Servers).

Thanks for the info/suggestion guys. I’m going to be working on it again today and I’ll put them to use.

Thanks guys! Problem solved. It was the default gateway that needed to be specified. It didn’t go off without a hitch though. I specified the DG in the networkmanager (wired) connection and it worked. However, after I rebooted the problem cropped up again. The DG was absent from the networkmanager connection. So I simply switched to using ifup (via YaST), specified the DNS servers and the DG and it worked fine, even after a reboot.
I appreciate the help.

i am using wireless network(adhoc) to connect to the internet. sometimes pages will open instantly in firefox…but at other times “server not found” error message will be displayed. If i try reloading the page 10-12 times, the page will open. I have tried disabling ipv6 in both firefox and network settings and even manually configuring the default gateway and DNS servers using Knetwork manager in the wireless connection specific settings. I am using dual boot(windows 7 and opensuse 11.4). Everything is ok while using windows even with ipv6, but does not work in opensuse.

Can you guys plz help me with this issue?

output from netstat -r

Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface * U 0 0 0 eth1
default HP-LAPTOP.mshom UG 0 0 0 eth1

Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface * U 0 0 0 eth1
default HP-LAPTOP.mshom UG 0 0 0 eth1

I think You may have run into this bug :
openSUSE 11.4 and IPv6 / glibc bug

In the bug report it’s stated that adding google DNS helps. The problem seems to be that with the latest glibc version it’s impossible to disable ipv6 and there are problems with not ipv6 ready DNS servers.

Best regards,