11.4 RC1 - Konqueror "fish" and "sftp" Protocols Fail to Connect

STILL broken - these were broken in M6 as well.

The “fish” and “sftp” protocols never return - stay “connecting”.
Yet ssh from the command line works fine.

Konqueror does prompt for the userid/password as it should.
The userid/password are saved in the Wallet correctly.

“smb” worked in M6, but it seems not to work in RC1

Sadly, we can’t move from 11.3 until this is fixed.

Well… “smb” IS working - it is just very slow.

“smb://servername/” takes up to 90 seconds to list the shares at “servername”

“smb://servername/share” takes up to 60 seconds to display the files/dirs at “share”.

Sadly, we can’t move from 11.3 until this is fixed.

Please confirm this as a bug 264129 – fish protocol fails to browse/display remote site in Dolphin or Konqueror otherwise it will join the queue of KDE bugs that get complained about – 11.4 M6 Konqueror 'fish" Protocol Fails – but do not get fixed.

On 02/11/2011 10:36 PM, smithlar wrote:
>
> STILL broken - these were broken in M6 as well.
>
> The “fish” and “sftp” protocols never return - stay “connecting”.
> Yet ssh from the command line works fine.
>
> Konqueror does prompt for the userid/password as it should.
> The userid/password are saved in the Wallet correctly.
>
> “smb” worked in M6, but it seems not to work in RC1
>
> Sadly, we can’t move from 11.3 until this is fixed.
>
>

I don’t know about broken fish or KDE, but I know PAM is broken…

When I try fish or sftp on an 11.4 client, using username and password,
my 11.2 server gives this:

error: PAM: Authentication failure for vahis from
a88-112-9-172.elisa-laajakaista.fi

When I make keys and then connect, it works fine.

Vahis

http://waxborg.servepics.com
openSUSE 11.4 RC 1 (x86_64)
2.6.37-20-desktop

Hi Vahis,

Do you have a quick hint on how to do this?

On 02/12/2011 04:36 PM, Knurpht wrote:
>
> Vahis;2289143 Wrote:
>>
>>
>> When I make keys and then connect, it works fine.
>>
>> Vahis
>
> Hi Vahis,
>
> Do you have a quick hint on how to do this?
>
>

One needs to have a user account on the server to do this.
So when a normal 'ssh <myserver> works, then

  1. On the client, as the user who wants to connect:
    ssh-keygen -t rsa -b 2048 -f ~/.ssh/id_rsa

  2. In one line:
    cat ~/.ssh/id_rsa.pub | ssh user@myserver ‘cat - >> ~/.ssh/authorized_keys’

After this the connection does not require password again

There are other, slightly different methods all over the place by
googling passwordless ssh.

I’m used to the lines above :slight_smile:

Vahis

http://waxborg.servepics.com
openSUSE 11.4 RC 1 (x86_64)
2.6.37-20-desktop

On 02/12/2011 04:57 PM, Vahis wrote:
> On 02/12/2011 04:36 PM, Knurpht wrote:
>>
>> Vahis;2289143 Wrote:
>>>
>>>
>>> When I make keys and then connect, it works fine.
>>>
>>> Vahis
>>
>> Hi Vahis,
>>
>> Do you have a quick hint on how to do this?
>>
>>
>
> One needs to have a user account on the server to do this.
> So when a normal 'ssh <myserver> works, then
>
> 1. On the client, as the user who wants to connect:
> ssh-keygen -t rsa -b 2048 -f ~/.ssh/id_rsa
>
> 2. In one line:
> cat ~/.ssh/id_rsa.pub | ssh user@myserver ‘cat - >> ~/.ssh/authorized_keys’
>
> After this the connection does not require password again
>
> There are other, slightly different methods all over the place by
> googling passwordless ssh.
>
> I’m used to the lines above :slight_smile:
>
> Vahis

I forgot to add:
If the connection needs to fully password/passphrase free jus hit enter
when the passphrase is asked for (twice) during key generation.

Vahis

http://waxborg.servepics.com
openSUSE 11.4 RC 1 (x86_64)
2.6.37-20-desktop

Thanks a very lot, Vahis, a big smile on my face. Just did not have the time lately to dive into it, so I used Gnome a lot for moving files from one place to another

Addit: all servers back in reach, another big thanks.

On 02/12/2011 06:36 PM, Knurpht wrote:
>
> Vahis;2289250 Wrote:
>> After this the connection does not require password again
>>
>> Vahis
>> –
>>
>
> Thanks a very lot, Vahis, a big smile on my face. Just did not have the
> time lately to dive into it, so I used Gnome a lot for moving files from
> one place to another
>
> Addit: all servers back in reach, another big thanks.
>
>

Great :slight_smile:

You say “all servers” - that makes me think of the following:

In addition to connecting without passwords the connections can still be
simpler, or with simpler server names, if you like.

Create an ssh config file by executing the commands:

$ touch ~/.ssh/config
$ chmod 600 ~/.ssh/config

Edit the file and enter the following into it (samples):

Host server1
HostName example.dyndns.org
Port 12022

Host server2
HostName 192.168.1.15

The Host option starts a new “section”: all the options that follow
apply to that host till a new “Host” option is seen. The “HostName”
option specifies the “real” host name that ssh tries to connect to
(otherwise the “Host” value is used). The “Port” is obviously the port
that ssh tries to connect to, if you don’t specify a port, the default
port is used.

Connect simply:

$ ssh server1
$ ssh server2

My machines have dynamic addresses, but they also run no-ip and dyndns
clients, so they have “real” host names. The “real” names or the real IP
addresses are more difficult to type and remember than names like
server1 or 2 or whatever short ones you might like.

Vahis

http://waxborg.servepics.com
openSUSE 11.4 RC 1 (x86_64)
2.6.37-20-desktop

Guess what guys… How about a stuck password dialog box?

My problem was it was “loading folders…” forever.

On my system I had an FTP:// session that auto-restored after a boot.
So somewhere behind all the windows was an input dialog waiting for a password.
I never saw it, nor did it show up when I did a plasma show-all-windows action.

So in frustration I restarted the KDE desktop session (logout), the dialog box popped up for about a second as it was shutting down.
Aha! That is a blocking action as subsequent logins can not start until it releases (something).

After logging in again, and closing the dialog, fish worked 100% as expected.
I would call it user error but I never saw the dialog under normal desktop operation.
FYI!