11.4 primary display refresh rate issue on Lenovo Z61M

I tried the 11.4 Live KDE CD on my Lenovo Z61M (equipped with ATI X1400 Mobility Radeon). Initially the display runs better than my actual distro (Mint KDE 9), and I can use the secondary display (a Lenovo 19"). After some minute, the primary screen lose the refresh rate (this is my interpretation), and screen results unreadable. The secondary display remains visible so I moved the Control Center on this and tried to disable the desktop effects, but it didn’t helped. I recovered the screen by switching to a text console (with Ctrl-Alt -F1), and then back. After a few seconds the primary display broke again :frowning:
It seems to use radeon driver.

I actually didn’t installed OpenSuse, what could I try with LiveCD before proceed to install?


I did some test (not a real linux power user :P), and I found that Opensuse starts with radeonhd, instead of radeon. So I forced the radeon driver and the main problem (primary display broken) seems to be solved. Some problem remain, the screen sometime “flashes”, and I had to switch to XRender, which seems to run better than OpenGL for desktop effects. The dual head seems to work, but it seems unstable, sometime the primary display temporarily broke. I’ll try to config X11 as much as it is possibile on a Live, if someone could give me hints I would be grateful.