[11.4] ntfs-3g permissions issues

Greetings !!

I try to fix a problem with friends that moved from Windows to OpenSuSE recently.
The problem is: they have two accounts mouman and pitou.

The old files are located on another partition mounted as “Windows/C” in fstab.

My idea, to avoid cut them from Windows too brutally, was create a symbolic link to the location of their personnal files “My Documents” folder on both accounts.
It worked, dolphin saw the symbolic link that could be opened and browsed without any problem.

BUT when my friend tried to modify a document from this partition she only had the read permissions (read only). She was bothered to make a copy using spreadsheet.

The fstab entry shows

users,gid=users,fmask=133,dmask=022,locale=fr_FR.UTF-8 0 0

The *mask means 0777 minus 0xxx → 133 means 0644 and 022 means 0755

My first idea was changing the fmask to 022 but it doesn’t seems to work.
I tried to chown the “My Documents” folder for both accounts in the windows partitions but it seems that chown doesn’t work (ls -hal displays root:users for each entry they must be mouman:users or pitou:users instead and the permissions were drwxr-xr-x).

I read that ntfs-3g features the “permissions” option to let linux permissions (chown, chmod, …) operate on the ntfs partitions: it doesn’t seems to work.

Each time I did fstab changes I used mount -a command.
It only works with the root account. In fact it always worked with the root account with or without the different changes done in fstab.

How do you think I could fix this problem ?

I want each user to have read/write access to a folder on a NTFS partition pointed by a symbolic link replacing their respective Documents folder.
The symbolic link was created with each user account I wasn’t root when I created the symbolic link.

The actual fstab entry shows

users,gid=users,fmask=022,dmask=022,locale=fr_FR.UTF-8 0 0

thanx in advance…

You want something like this

/windows/C           ntfs-3g    defaults              0 0

Note that by default openSUSE sets Windows up as read only. Also there may be problems writing if the Windows partition was not shut down cleanly. Especial imortant with Win 8 since it uses fast boot (or what eve they call it) and does not by default do a clean shut down

On 2014-01-19 01:06, soundlord wrote:

> The actual fstab entry shows
> Code:
> --------------------
> users,gid=users,fmask=022,dmask=022,locale=fr_FR.UTF-8 0 0
> --------------------

I use this:

> UUID="..." /windows/C  ntfs-3g users,gid=users,fmask=0117,dmask=0007,locale=en_US.UTF-8  0 0

This produces these permissions:

minas-tirith:~ # l /windows/C/Users/
total 81
drwxrwx--- 1 root users 49152 Dec 12 22:56 Carlos/
drwxrwx--- 1 root users  8192 Nov 18 23:11 Cer/
drwxrwx--- 1 root users  4096 Feb 23  2010 Public/
-rw-rw---- 1 root users   174 Jul 14  2009 desktop.ini
minas-tirith:~ # l /windows/C/Users/

Notice that the permissions are different for directories and files (I
use a different “dmasq”).

The user is “root” because it was mounted automatically on boot. Notice
that I can create a file as plain user:

> cer@minas-tirith:~> touch /windows/C/Users/Cer/Documents/testingfromlinux
> cer@minas-tirith:~> l /windows/C/Users/Cer/Documents/testingfromlinux
> -rw-rw---- 1 root users 0 Jan 19 01:49 /windows/C/Users/Cer/Documents/testingfromlinux
> cer@minas-tirith:~>

although the file appears to belong to “root”. So any user that belongs
to the group “users” can read and write to the “/windows/C” filesystem.

If you want users to be able to mount it, you have to add the “user”
option. But that is not enough, you’ll get this error:

> cer@minas-tirith:~> mount /windows/C/
> Unprivileged user can not mount NTFS block devices using the external FUSE
> library. Either mount the volume as root, or rebuild NTFS-3G with integrated
> FUSE support and make it setuid root. Please see more information at
> http://tuxera.com/community/ntfs-3g-faq/#unprivileged
> cer@minas-tirith:~>

I have not done experiments with that. Or not recently.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

I solved the issue with a symbolic link pointing to the folders in that mounted partition with user and group same as the accounts mouman:users and pitou:users.
I never seen incidents like “permissions denied” or “read only” since.