11.4 NFS Established using wifi frustrates subsequent booting

I had NFS set up on laptop using wifi link and all was fine. However when I next tried to boot the process stopped at trying to mount the NFS. Unfortunately the system tries to do this before the wifi connection has been made so the boot process stalls.
Same problem with failsafe boot so I am locked out of my system.
How may I get past this so I can use my laptop again please?

I think people should look into using autofs to mount network shares on demand.

On 01/04/2012 05:36 PM, ken yap wrote:
>
> I think people should look into using autofs to mount network shares on
> demand.

That is what I do and it works great. Unfortunately, that cannot be setup with
YaST and requires using an editor to create the files.

ken yap wrote:
> I think people should look into using autofs to mount network shares on
> demand.

Wouldn’t it be better to simply offer the correct fix, which is to add
_netdev to the NFS mount options (or any other network mounts).

And even better if the YaST people would actually fix it to do this
properly automatically!

This only works if the WiFi is established as part of the boot process by delaying the mount until the network is up and then mounting _netdev devices in the second pass. It’s useless if the WiFi connection is adhoc and initiated by the user after logging in.

ken yap wrote:
> This only works if the WiFi is established as part of the boot process
> by delaying the mount until the network is up and then mounting _netdev
> devices in the second pass. It’s useless if the WiFi connection is adhoc
> and initiated by the user after logging in.

AIUI, _netdev is supposed to work even when the network connection
changes state at any later time, let alone just when it first comes up.
But then I don’t use wireless.

Is this an opensuse bug?

Only if there is a u/mount script hooked to the network up/down events. I’m not convinced that this works properly yet.

Hi guys,
Glad my question has stimulated such an erudite discussion. Unfortunately nobody has given me a reliable solution in terms I understand. As far as I can tell the networkmanager only connects to the wifi ap after booting has completed. (At least that is what used to happen with 11.4. Sadly with 12.1 the connection has to be forced by me because networkmanager does not see the ap until after I have turned off the wireless and then turned it on again.) So what I need to do is delay the mounting of the NFS until after the wifi connection has been completed. So how do I fix my problem please?

On 01/06/2012 05:46 PM, Budgie2 wrote:
>
> Hi guys,
> Glad my question has stimulated such an erudite discussion.
> Unfortunately nobody has given me a reliable solution in terms I
> understand. As far as I can tell the networkmanager only connects to
> the wifi ap after booting has completed. (At least that is what used to
> happen with 11.4. Sadly with 12.1 the connection has to be forced by me
> because networkmanager does not see the ap until after I have turned off
> the wireless and then turned it on again.) So what I need to do is
> delay the mounting of the NFS until after the wifi connection has been
> completed. So how do I fix my problem please?

Use autofs to mount the NFS volumes. There is a description of how to do it in
the forum. Unfortunately, you cannot use YaST to set it up as its version of
autofs uses LDAP.

On Thu, 05 Jan 2012 02:58:25 GMT, Larry Finger <Larry.Finger@lwfinger.net>
wrote:

>On 01/04/2012 05:36 PM, ken yap wrote:
>>
>> I think people should look into using autofs to mount network shares on
>> demand.
>
>That is what I do and it works great. Unfortunately, that cannot be setup with
>YaST and requires using an editor to create the files.

Twon’t bother me none. Where can i find instructions?

?-)

To use autofs for NFS mounts:

  1. As root, edit file /etc/autofs.master and add the following line at the end:

/-		auto.nfs

This scheme uses the so-called “direct” mode.

  1. Create the file /etc/auto.nfs with the following structure:

/<mount_dir>           NFS_host:<directory_to_mount>    <options>
/<mount_dir_2>         NFS_host:<directory_to_mount_2>  <options>
etc.

You can determine the mount directories and host name or IP from the entries in
/etc/fstab. Any options other than “defaults” should be listed.

  1. Remove the mount items from /etc/fstab. I just comment mine out.

  2. Cause the autofs service to start on boot:


ln -sf /etc/init.d/rc5.d/S99autofs /etc/init.d/autofs

If you want autofs to start at run level 3 as well as 5, create a similar link
in /etc/init.d/rc3.d/.

Actually the other way in the ln command:

ln -sf /etc/init.d/autofs /etc/init.d/rc5.d/S99autofs

Actually it’s best done using:

chkconfig --set autofs on

or from YaST, otherwise openSUSE is liable to remove the user created symlinks.

On Tue, 10 Jan 2012 03:42:26 GMT, Larry Finger <Larry.Finger@lwfinger.net>
wrote:

>To use autofs for NFS mounts:
>
>1. As root, edit file /etc/autofs.master and add the following line at the end:
>
>


>/-		auto.nfs
>

This scheme uses the so-called “direct” mode.

  1. Create the file /etc/auto.nfs with the following structure:

>/<mount_dir>           NFS_host:<directory_to_mount>    <options>
>/<mount_dir_2>         NFS_host:<directory_to_mount_2>  <options>
>etc.
>

You can determine the mount directories and host name or IP from the entries in
/etc/fstab. Any options other than “defaults” should be listed.

  1. Remove the mount items from /etc/fstab. I just comment mine out.

  2. Cause the autofs service to start on boot:


>ln -sf /etc/init.d/rc5.d/S99autofs /etc/init.d/autofs
>

>
>If you want autofs to start at run level 3 as well as 5, create a similar link
>in /etc/init.d/rc3.d/.

Thanks a bunch. I like the completeness and i haven’t tried it yet.

?-)

On Tue, 10 Jan 2012 04:06:02 GMT, ken yap
<ken_yap@no-mx.forums.opensuse.org> wrote:

>
>lwfinger;2428553 Wrote:
>> 4. Cause the autofs service to start on boot:
>>
>> >
>Code:
>--------------------
> > >
> > ln -sf /etc/init.d/rc5.d/S99autofs /etc/init.d/autofs
> >
>--------------------
>> >
>>
>> If you want autofs to start at run level 3 as well as 5, create a
>> similar link
>> in /etc/init.d/rc3.d/.
>
>Actually the other way in the ln command:
>
>
>Code:
>--------------------
> ln -sf /etc/init.d/autofs /etc/init.d/rc5.d/S99autofs
>--------------------
>
>
>Actually it’s best done using:
>
>
>Code:
>--------------------
> chkconfig --set autofs on
>--------------------
>
>
>or from YaST, otherwise openSUSE is liable to remove the user created
>symlinks.

Thanks for the added info. you may have well prevented me having
problems.

?-))