11.4 Milestone2 X window failed to start from KDE liveCD

Am I the only one to encounter failures in the 32-bit 11.4 Milestone2 KDE liveCD to boot direct to X ?

I booted my 32-bit Athlon-2800 with nVidia 8400GS PCI card to the 32-bit 11.4 Milestone2 KDE liveCD and it brought me to a login screen, with the option of user “linux” as the user. But selecting “linux” and trying various passwords (ie <enter> or other possibilities) failed to do a login. I killed the login, and went to run level 3 and logged in to run level 3 as user linux (sucessfully) but ‘startx’ failed. That happened both without ‘nomodeset’ and with ‘nomodeset’ as a boot code.

I then booted my wife’s Fujitsu-Siemens Amilo 7400M laptop with the ‘killer’ Intel 855GM graphics. It booted to X, but there was no mouse cursor. None. The keyboard only partially worked, although every window I opened with the keyboard, was very quickly covered by the plasma on KDE4. Konsoles were only updated after repeated selection (via key navigation) and totally not useable. I could temporary get the plasma hidden windows back, but with seconds it was covered again. In essence, the Intel driver was not useable with this laptop and the 2.6.36 kernel.

I rebooted and tried the ‘nomodeset’ boot code. That took me to a login screen, and I had the same problem with this laptop’s Intel 855GM (with ‘nomodeset’) that I had with the desktop with the nVidia 8400GS. ie impossible to start X.

I don’t know if this problem was systemic, or if I was just lucky. :\ … I do not see any mention (yet) in the annoying bugs. openSUSE:Most annoying bugs 11.4 dev - openSUSE

So it was a zero out of two for Milestone4 thus far. Not one would run X window.

I may try a few of our other PCs at home.

I had a similar problem with the 64-bit KDE disk. I can log in to other desktop environments, just not KDE.

Hmm … ok, this weekend I’ll download the Gnome liveCD and see how it works. :slight_smile:

I was thinking the same thing, or downloading the delta DVD.

Installed 32 bit M2 kde this AM
To be honest it worked perfectly, and so far not one issue.

Installed from DVD ? liveCD ? If liveCD did you first boot to liveCD desktop, or install direct? What hardware ? On your Lap#2 with Intel 965GM ?

Lap 2
Live cd
Went to Live desktop

Hmmm … so KDE with 965GM works, but KDE with 855GM (intel and FBDEV driver) or KDE with 8400GS (noveau or nv driver) fails.

This laptop seems to work with everything I throw at it

Didn’t have too much luck here.

From the DVD I tried an install (on top of 11.3 updated to 11.4 m1) but couldn’t get kde 4 to start (although kde 3 using failsafe worked).

Tried a fresh install of m2 but again couldn’t get kde 4 to start and I then tried an install of m2 on top of a fresh install of 11.3 again without any joy.

I tried the 32-bit openSUSE-11.3 Milestone2 KDE4 liveCD on my athlon-1100 w/nVidia FX5200 and it froze in attempting to boot KDE with nouveau, nv, and vesa driver. I even booted to run level 3 and typed startx and it eventually froze. I tried a FailSafe boot. Same freeze. The KDE live CD does not work on 3 PCs. ( … and I believe this to be a good CD, run level 3 works, CD burned to high quality media @ low speed with good CD drive and md5sum passed before burning).

Specifically, thus far with 32-bit openSUSE-11.4 Milestone2 KDE4 liveCD, I’ve managed to get it to fail (and not once succeed) with the following PCs:

  • Fujtisu-Siemens Amilo 7400M, w/Intel-1.5 GHz CPU, w/1G.2B RAM and Intel 855GM graphics (failed with and without nomodeset)
  • 32-bit Athlon-2800, w/2GB RAM, and nVidia 8400GS (PCI card), failed with and without nomodeset
  • 32-bit Athlon-1100, w/1GB RAM, and nVidia FX5200 (AGP card), failed with and without nomodeset

BUT … I note the 32-bit openSUSE-11.4 milestone2 Gnome liveCD both the Athlon-2800 and Athlon-1100 above works well (albeit the Athlon-1100 w/ nVidia FX5200 was not stable with nouveau driver but was stable with nv driver).

Ergo, Gnome liveCD is more functional in 11.4 milestone2 than the KDE liveCD.

I have not yet tried the Gnome liveCD on the Fujitsu-Siemens Amilo 7400 w/Intel 855GM graphics (which is a Linux killer).

I tried the 32-bit openSUSE-11.4 milestone2 Gnome liveCD in my ‘Linux killer’ Fujitsu-Siemens Amilo 7400 w/Intel 855GM graphics. When booting normally the Gnome desktop comes up (which is better than the KDE4 desktop which does not come up properly) but like the KDE4 desktop, there is no mouse pointer/cursor. I noted the Intel driver was loaded at a proper 1024x768 resolution.

I then rebooted with the ‘nomodeset’ boot code, and this time the Gnome desktop came up with the FBDEV graphic driver at 800x600. But it was stable. The wireless worked nicely.

Clearly again (despite the difficulties with the Intel driver (that the 855GM is known to have with every kernel since the 2.6.27 kernel), the Gnome liveCD in openSUSE-11.4 milestone2 works MUCH better than the KDE4 liveCD.

I’ve similar results to report for the 64-bit version of the Gnome live disk via Virtualbox. The desktop comes up without a hitch, and I’m installing it to my virtual machine as I type.

the Gnome liveCD in openSUSE-11.4 milestone2 works MUCH better than the KDE4 liveCD.
I didn’t try Gnome, I did that with M1

Still no bugs to report in my M2 kde4 - working flawlessly :wink:

I tested LIVE KDE and GNOME (32bit both) and KDE version works fine except crippled networkmanager in KDE. GNOME crashed from livecd when loading desktop and I saw some problems in Xorg.0.log file with opensource radeon driver (bad drawing etc.). I pressed CTRL+ALT+BACKSPACE twice and logged like livecd user and gnome worked. I could connect to wifi without problems.

I had a bit more luck with the 32-bit openSUSE-11.4 milestone2 KDE liveCD on some legacy Radeon hardware. I booted that openSUSE-11.4 milestone2 KDE4 liveCD on my wife’s Sempron-2600 (w/1GB RAM) and an ATI Radeon 9200 PRO graphics AGP card. The boot without nomodeset boot code hung, in pretty much exactly the same place as the previous boots on both Intel and nVidia hardware. I then rebooted with the boot code ‘nomodeset’ and X came up with a BLACK back ground, but one could see windows and see the task bar/lower-panel. This ‘nomodeset’ behaviour is similar to what I observed on openSUSE-11.3, and if one disables ‘special desktop effects’ then a proper background will appear (and the black goes away).

I then rebooted, and specified a TEXT mode and also included the ‘nomodeset’ boot code. I logged on as user ‘linux’ and then switched to root permissions with ‘su’ and ran ‘mc’ to edit the file /etc/X11/xorg.conf.d/50-device.conf, changing it to:

Section "Device"
  Identifier "Default Device"

  Driver "radeon"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

  #oldcpu added following 2 lines
  Option "BusType" "PCI"
  Option "AGPSize" "64"

EndSection

This is a fix I discovered on openSUSE-11.3 that works with this hardware which I reported here: Suse 11.3: No KDE/X11 start on ATI Radeon RV280 5960

Then I typed ‘exit’ to get rid of root permissions, and ran startx. After KDE4 came up I enabled desktop effects and they worked (cube rotation, etc … ) albeit there were some minor artifacts. I note the performance after X was running with special desktop effects in KDE4 was superior in 11.4 M2 than 11.3 GM … suggesting some upstream fixes may have been applied to the Radeon driver or to Xorg.

I then rebooted the PC, and this time booted with the 32-bit openSUSE-11.4 Milestone2 Gnome liveCD. It booted direct to X ok, without the need to use the ‘nomodeset’ boot code. Special desktop effects did not work (similar behaviour to openSUSE-11.3). I then rebooted with the boot code ‘nomodeset’ and obtained a poor screen (could not see lower panel/task bar) again similar to openSUSE-11.3 with Gnome on this PC. I then rebooted to TEXT mode with the ‘nomodeset’ boot code, applied the 50-device.conf fix, and ran startx. X came up ok this time. However I could not enable special desktop effects.

Probably a draw here between the Gnome and KDE4 implementation on this liveCD. I think the openSUSE-11.4 Milestone2 KDE4 liveCD does need work here. It should have worked without having to resort to the ‘nomodeset’ boot code, and the fact it hung in the exact same place as I observed on old nVidia and Intel hardware suggests to me there is a bug in KDE4.

What ATI hardware ?

motherboard IGP HD 4200

I am testing KDE4 live cd in virtualbox and doesn’t work. I cannot login, login failed. When I press CRTL+ALT+F1 I can login on konsole as linux user. After pressing CTRL+ALT+F10 I see kdm error message:


kmd[2281]: X server for display :0 terminated unexpectedly

I guess kdm is crashing thus user can’t login to desktop.

Last night I attempted to install 32-bit openSUSE-11.4 Milestone4 DVD version LXDE on this PC. I knew from experience it was necessary to specify ‘nomodeset’ as a boot code, but even then the install failed at the end, with a frozen display when X was trying to load LXDE. I did a hard reboot, and LXDE came up with a black background. In essence, not usable. MORE WORK is needed here.

So this morning on same PC, I attempted to install 32-bit openSUSE-11.4 Milestone4 DVD version Gnome on this PC. Again I knew from experience it was necessary to specify ‘nomodeset’ as a boot code, and once again, the install failed at the end, with a frozen display when X was trying to load Gnome. I did a hard reboot, but as opposed to LXDE (and KDE) which failed or came up with bad implementations, the Gnome desktop came up properly.

It came up at a substandard resolution of 1024x768 with the “nv” driver. xrandr indicated that 1024x768 as the top resolution (although I happen to know it is 1920x1200). So I then installed the proprietary nvidia beta driver v.173.14.28 (the v.173.14.27 won’t work with the Xorg in openSUSE-11.4) ‘the hardway’ (which is not hard) and I obtained 1600x1200 resolution, which is not bad.

Sound was broken thou. :’( Thats no surprise, as this is Gnome and sound has NEVER worked well for me in Gnome. The test sound worked, but any effort to play any sort of multimedia resulted in totally corrupted audio. I looked for fixes to configure pulse audio, but I could find none applicable to apply. In the end I sent the command

setup-pulseaudio --disable

and changed the setting in Packman packaged xine to use “OSS” and I obtained some decent sound and video.

But thats unsatisfactory for me.

I confess while I REALLY like the Gnome desktop interface,** the sound implementation is so bad I will never use Gnome operationally**. I do not have the patience to mess around with what I see as a truly inadequate / non-user friendly implementation of sound on any hardware that I have in our apartment. >:(

… Anyway, despite the hopeful and nice to read glowing reports of others on milestone-2 of 11.4, thus far my experiences have been the opposite. For the hardware that I own, openSUSE-11.4 M2 a big NO on 3 of 4 PCs, and on the 4th is very problematical.

Fortunately there are many more milestone releases to go, to change this situation for the better! :slight_smile: I am still hopeful and optimistic for openSUSE-11.4.