11.4 mic not working

After upgrading to 11.4 I can’t get my mic to work. In 11.3 it “just worked”.
Originally I had 2 problems - no sound in Flash videos and mic not working. After uninstalling PulseAudio, Flash is working, but still no luck with my mic. I’ve tried all the possible options in KMix and alsamixes and it’s still like dead. I’m not sure how to proceed with this now so any input will be appreciated. :dont-know:
The system is OpenSuse 11.4, KDE 4.6, 64 bit.

Do you have capture tab in alsamixer and/or kmix? Also, what application are you using to test your mic?

Yes, I have that tab.
I use skype test call, arecord+aplay and krecord.
My sound card is HDA Intel VT1708S

Open Personal Settings->Multimedia. Under Capture see if your mic is the prefered one. If not change the order.

I only have one card (Intel) in the Capture section.

11.4 uses pulse audio to a greater extent than previous openSUSE versions.

My experience is that one needs to install the additional package ‘pavucontrol’ (which is in the regular OSS repository) and then run ‘pavucontrol’ which gives more control over both the input and output audio devices. Give that (pavucontrol) a try and see if it helps.

Yes, I noticed PulseAudio, but with it I had 2 problems - no sound in Flash video and dead mic. And I did try to play with all kinds of settings, including pavucontrol, to no success. Now that I got rid of PA, at least one of those problems is solved… Still can’t use the mic though. If this is not solved some time soon I’ll have to start looking at other distros, which I really wouldn’t like to resort to after using OpenSuse for almost 7 years, but I have to use skype on this computer…

I understand you removed pulse to get audio working in flash/in-your-browser, but IMHO that was not the correct approach. Whether it contributed to your current mic problem, I can’t say, but it would not surprise me if it has complicated this. OpenSUSE-11.4 has been tested by most users with pulse enabled, and NOT with pulse disabled/removed.

Out of curiousity, what is the output (providing the website/url) when you run the diagnostic script:


I’d be glad to be running PulseAudio if it worked. But everything was fine for me with Alsa in 11.3 so I assumed that it would work in 11.4 as well which to my great surprize is not the case.

alsa-info.sh output http://www.alsa-project.org/db/?f=5325285251e9f6482e9e01efb091da369051d9ff

I note a VIA VT1708S. I think other users with this hardware audio codec reported problems. Did you check for any bugs written on openSUSE-11.4 for this hardware audio codec? Sorry I can’t do that search for you - we have visitors at the place and my time is more limited than normal.

Is your mic an integrated mic ? Is it an external mic? If external, are you plugging it in to a rear jack, front jack side jack ? How many mic jacks does your PC have?

Its difficult to make sense of the mixer settings unless one knows those details.

Lets look at the mixer settings:

**!!Amixer output

!!-------Mixer controls for card 0 [Intel]

**Card hw:0 'Intel'/'HDA Intel at 0xf3ff8000 irq 47'**
  Mixer name	: 'VIA VT1708S'
**Simple mixer control 'Front Mic',0
**  Front Left: Playback 31 [100%] [12.00dB] [on]
  Front Right: Playback 31 [100%] [12.00dB] [on]
**Simple mixer control 'Front Mic Boost',0
**  Front Left: Capture 1 **[33%]** [10.25dB]
  Front Right: Capture 1 [33%] [10.25dB]
**Simple mixer control 'Mic Boost',0
**  Front Left: Capture 1 **[33%]** [10.25dB]
  Front Right: Capture 1 **[33%]** [10.25dB]
**Simple mixer control 'Capture',0
**  Front Left: Capture 31 [100%] [30.00dB] [on]
  Front Right: Capture 31 [100%] [30.00dB] [on]
**Simple mixer control 'Capture',1**
  Front Left: Capture 31 [100%] [30.00dB] [on]
  Front Right: Capture 31 [100%] [30.00dB] [on]
**Simple mixer control 'Digital',0**
  Front Left: Capture 0 **[0%]** -30.00dB]
  Front Right: Capture 0 **[0%]** -30.00dB]
**Simple mixer control 'Input Source',0**
  Items: 'Stereo Mixer' 'Rear Mic' 'Front Mic' 'Line'
  Item0: **'Front Mic'**
**Simple mixer control 'Rear Mic',0**
  Front Left: Playback 31 [100%] [12.00dB] [on]
  Front Right: Playback 31 [100%] [12.00dB] [on]
**Simple mixer control 'Smart 5.1',0**
  Capabilities: pswitch pswitch-joined penum
  Playback channels: Mono
  Mono: Playback [off]

The boost is set at 33% and you note the mic does not work. ??? Why so low ? If it were me I would move it up higher to ensure the mic boost is not a factor.

You have the front mic selected. Is there more than one ? Is that the one you are trying to use?

Note integrated mics tend to be digital mics, and hence if this is an integrated mic, then it is clearly muted.

I note the 5.1 settings are switched OFF. I don’t know the effect of switching them ON.

I haven’t found any bugs for 11.4. I appreciate your time.

The mic is from a very basic headset, not USB. Connected to front jack.
I have a rear jack too. That’s all I have. It’s a desktop so no integrated mic.

I just remember one of those boosts giving me a bit of noise in the past when at 100% level so I lowered it, but I have tried with 100% now too - same result.

In the capture drop down list I have: Stereo mixes, Front Mic, Rear Mic and Line. I’ve tried them all.

I googled a lot and found someone mentioning having problems with this sound card and they recommended turning off 5.1 so I tried that too. No luck :slight_smile: I don’t think it should matter though.

OK. I decided to give PulseAudio one more chance. Got Flash working this time by switching Internal Audio to Analog Stereo Duplex. But No luck with the mic.

IMHO whether you succeed or fail , you should write a bug report on openSUSE-11.4. There is guidance here: openSUSE:Submitting bug reports - openSUSE use your openSUSE forum username and password when logging on to bugzilla. Attach to the bug report the text file /tmp/alsa-info.txt that you get by running:

/usr/sbin/alsa-info.sh --no-upload

and raise the bug report against component sound.

There is a chance the SuSE-GmbH sound packager (who will answer your bug report) has already discovered this problem and created a fix, and if so you may find the fix updating your alsa version per the guidance in this wiki page I wrote (which needs some updating): SDB:Alsa-update - openSUSE

thanks man you made my day. i had so much trouble with that mic but your post saved me a lot of time

You need

Depending on your sound card try the following.


Make some devices default

#set-default-source input
#set-default-sink output
set-default-source alsa_input.pci-0000_00_1b.0.analog-stereo
set-default-sink alsa_output.pci-0000_00_1b.0.analog-stereo

load-module module-alsa-sink device=hw:0
load-module module-alsa-source device=hw:0


PulseAudio plugin configuration

Virtual device pulse for mixer and PCM

pcm.pulse {
type pulse

ctl.pulse {
type pulse


pcm.!default {
type plug
slave.pcm {
type pulse

ctl.!default {
type pulse