11.4 M2: Nothing provides "libc.so.6 ....." message

Running install of 11.4 Milestone 2 from DVD, an error is noted under “Software” regarding dependencies, and manual intervention required.

Each message is:

Nothing provides libc.so.6 needed by grub-0.97-173.4.x86_64

with action(s) of “Do not install” or “break” grub-0.97-173.4.x86_64, for the following"


I aborted the install at this point. The install was a “new install”, without formatting the “/home” partition.

Did you run the media check?

I had this dependency problem also. I downloaded the dvd three different times with the same result from each. All three passed the media check.

A bug report has already been made.

I ran it before I attempted the install, checked out correct. Ran again, after the failure, again correct. Then, I ran it on another PC, also correct.

I will burn a liveCD, and try that approach.

The 11.4 Milestone 2 Gnone liveCD does NOT present the OP problem(s) with GRUB dependencies. Like the corresponding DVD, it does manifest some slow and/or erratic behavior when utilizing the touchpad, with the DVD behaving poorer in that area.


Got the same problem, did all the checks, downloaded twice…? I am just thinking of workaround

Got a bit further

libc.so.6 links to libc.2.11.2.so both are in /lib64 next to each other. So my second guess is that there is something wrong with libc.2.11.2.so

Size of 11.3 libc.2.11.2.so not equal 11.4MS2 libc.2.11.2.so

I’ll keep on searching

Is there a different way to start 11.4 circumventing grub ?

In other words 11.3 and 11.4MS2 are both installed on my laptop. What option do I have to start 11.4MS2 since it appears to be a grub problem.

Thanks Otto_oz

Has there been any movement on this or is 11.4M2 64bit DVD image dead in the water?
The only alternatives I see to grub are :

ELILO (not on my hardware)
LILO (listed but not supported)
No boot loader install

I really would like to install 11.4M2, any suggestions would be greatly appreciated.

As it turns out, once the liveCD completes its installation, ensuing updates once again trigger the OP problem (above 11.4 M2: Nothing provides “libc.so.6 …”).

At that point, both the DVD-install and the liveCD converge on this problem. I have also experienced serious delay problems with the touchpad and keyboard. The most serious problem is the apparent absence of support for the Intel GMA HD, which, according to Intel Linux Graphics: Documentation is the device used for

**Supported Hardware**

The Linux graphics drivers from Intel support the following Intel® chipsets:

Short name	Full name

HD 	        Intel® HD Graphics (used in Intel® 2010 Core i7/i5/i3 Processor Series)
GMA3150 	Intel® Graphics Media Accelerator 3150 (used in Intel® AtomTM Processor N450/D410/D450)

For me, the 11.4 Milestone 2 is a non-player. I will retry again with MS3.

Do you have a links to this bug report, so I can check on status/work around
The problem also appears in M6 DVD install.

Greetings, Tim

Hi gents,

I did the following to get M6 installed from DVD:

In the begin stage of the installer, one can select add-on media. Select this and proceed. Do the network config and add url Index of /factory-snapshot/repo/oss ass repository. This will allow the installer to resolve the dependency automatic.


Hi again,

Found bug: 668573

Seems to be resolved now for newer DVD snapshots.


Thanks for the information muhlemmer, though this thread was for M2, I also had the same problem for M6 as you. I did not resolve the issue as you did, but allowed an older copy of openSUSE on a separate hard disk on the same computer to boot from to use openSUSE 11.4 M6 and used its (openSUSE 11.2) grub instead. This worked just fine, but no good way to tell someone how to do what I did while your solutions sounds easy to do. Thanks for sharing this information with us.

Thank You,