11.4 - Lenovo Edge 15'' - Power managment faliure under KDE

This is a persistent issue that was also problematic under 11.3 but since it got worse under a fresh install of 11.4 (and I have some new information) I’m starting a new thread with a more informative title.

So: The KDE Power management applet does not work.

  • No detection of AC power connection/disconnection.
  • battery status is inconsistent (Sometimes report’s the right information sometimes get stuck on 100%)
  • Screen brightness and volume hot key don’t work (although changing the brightness/volume from the KDE applets works well)
  • Lid closing is not detected.

I think that the problem is with the communication between udev (That if I understand correctly sends the information to KDE) and the kernel.


acpi -V

always gets the correct information about the battery status, AC power, screen brightness etc.

However if I run

upower -d

I get something like this:

Device: /org/freedesktop/UPower/devices/line_power_ACAD
  native-path:          /sys/devices/LNXSYSTM:00/device:00/ACPI0003:00/power_supply/ACAD
  power supply:         yes
  updated:              Tue Mar 15 18:25:56 2011 (21346 seconds ago)
  has history:          no
  has statistics:       no
    online:             yes

Device: /org/freedesktop/UPower/devices/battery_BAT1
  native-path:          /sys/devices/LNXSYSTM:00/device:00/PNP0C0A:00/power_supply/BAT1
  vendor:               Panasonic
  model:                42T4753
  serial:               517
  power supply:         yes
  updated:              Wed Mar 16 00:21:34 2011 (8 seconds ago)
  has history:          yes
  has statistics:       yes
    present:             yes
    rechargeable:        yes
    state:               charging
    energy:              44.23 Wh
    energy-empty:        0 Wh
    energy-full:         45.59 Wh
    energy-full-design:  47.52 Wh
    energy-rate:         10.057 W
    voltage:             12.572 V
    time to full:        8.1 minutes
    percentage:          97.0169%
    capacity:            95.9386%
    technology:          lithium-ion
  History (charge):
    1300227694  97.017  charging
    1300227663  96.841  charging
    1300227632  96.666  charging
    1300227601  96.490  charging
  History (rate):
    1300227694  10.057  charging
    1300227663  10.397  charging
    1300227632  10.736  charging
    1300227601  11.061  charging

  daemon-version:  0.9.8
  can-suspend:     yes
  can-hibernate    yes
  on-battery:      no
  on-low-battery:  no
  lid-is-closed:   no
  lid-is-present:  yes
  is-docked:       no

So you see that the AC adapter status is not being updated at all (only at boot).
In addition if I run

udevadm trigger

the status is updated (correctly).

So (again if I got it right) the kernel gets all the information it needs but udev does not.

Any suggestions?

Thanks for your help.

For backlight adjustments, you can use “xbacklight” command (terminal - normal user) e.g:

>xbacklight --help
usage: xbacklight [options]
  where options are:
  -display <display> or -d <display>
  -set <percentage> or = <percentage>
  -inc <percentage> or + <percentage>
  -dec <percentage> or - <percentage>
  -time <fade time in milliseconds>
  -steps <number of steps in fade>

Probably won’t persist across a reboot/logout.

Let me tell you something crazy: Everything stated working. Power management, Fn key the works.
The Kernel sends events to acpi and udev in time and everything works.

I’m sure that it will stop working sometimes soon.

My guess is that the bug is something stupid like some lock file that is not being deleted when you shut down or restart the computer.

I’m afraid to turn of my computer.

Di you guys think there is a way I can find out what has changed and what is happening right now so that I can compare to when it will be not as good in the future?