11.4: kmix steals memory and cpu bandwidth

By coincidence I discovered some time ago in system monitor that CPU load was high without any application running. I found that kmix was using 25percent of total CPU bandwidth (=100percent of one of the 4 cores). At the same time the kmix icon in the panel was unresponsive.
Killing kmix brought system load down to normal again. The kmix icon disappeared from the panel but sound still worked normally. Also, memory dropped back down to the usual 1 GiB (from about 2 GiB while kmix was running.
The above occurs regularly. Not immediately after logging into KDE but after some time. This may perhaps be associated with watching videos in Firefox on news sites, but I am not certain.
I do not notice any untoward effects under the condition but assume that the wasted memory and CPU bandwidth do have a detrimental effect on speed in memory and/or CPU intensive processes.
Has anyone observed similar behavior? Is there anything I can do to prevent this?
Any insights will be welcome.

Lets see what repos you have

zypper lr -d

Here they are:

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | Education | Education | Yes | Yes | 99 | rpm-md | Index of /repositories/Education/openSUSE_11.4 |
2 | ftp.uni-erlangen.de-suse | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/mirrors/packman/suse/openSUSE_11.4/ |
3 | google-earth | google-earth | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64 |
4 | openSUSE-11.4-11.4-0 | openSUSE-11.4-11.4-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-PLDS_DVD+_-RW_DH-16AAS_CN0H344R550819C94193 |
5 | openSUSE:11.4:Contrib | openSUSE:11.4:Contrib | Yes | Yes | 99 | rpm-md | Index of /repositories/openSUSE:/11.4:/Contrib/standard |
6 | repo-debug | openSUSE-11.4-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.4/repo/oss |
7 | repo-debug-update | openSUSE-11.4-Update-Debug | No | Yes | 99 | NONE | Index of /debug/update/11.4 |
8 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes | 99 | NONE | Index of /distribution/11.4/repo/non-oss |
9 | repo-oss | openSUSE-11.4-Oss | Yes | Yes | 99 | NONE | Index of /distribution/11.4/repo/oss |
10 | repo-source | openSUSE-11.4-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.4/repo/oss |
11 | repo-update | openSUSE-11.4-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.4 |


Those look OK

Please try creating a new user account and see if it experiences the same behaviour

I already have a guest account. When I logged into that I could not reproduce the phenomenon.

Back in my own account the cpu- and memory theft occurs as soon as I open a video in firefox.

Delete the following hidden files in your home


logout and back in
Does that fix it

Done. Problem persists.
kmix is started automatically upon login and the kmix icon in the panel responds correctly. However, the volume of master control is now set at zero. Nevertheless, the “KDE Welcome Jingle” came at the usual full volume.
Without changing the setting of the master volume slider I tried to play a .ogg file with vlc and found that, in spite of the kmix slider still being at zero, the volume of the playback was normal, and it responded correctly to changing the volume control in the vlc window. As soon as I had started playing the file the system monitor showed cpu usage 100 percent for one of the four cores, and the same memory waste as reported yesterday. Also, the vlc icon in the panel is now unresponsive again.
In this situation I can kill kmix - without detrimental effect on the playback; its icon disappears from the panel. If I start kmix again with “[alt-f2] kmix”) cpu load immediately jumps up again and memory usage gradually rises to the high value, but the kmix icon does NOT reappear in the panel. All the while the .ogg file plays back faultlessly. After the file has finished playing back the memory and cpu values remain at their high levels.

oh, and one more observation:
After deleting (actually: renaming these two files to “ex_kmixctrlrc” and “ex_kmixrc” respectively), logging out and back in (actually: rebooting) and running the tests described in my previous postthese two files were NOT recreated in the directory.


You also need to delete the content of ~/.kde4/share/apps/kmix/profiles. Then it should work nicely.

Yep, Riderplus. Followed your advice and all seems to be okay now.

Thanks also to caf4926 for his efforts.


Thanks for this. Can you give some insight into what the deleted files do?

They are just basic desktop config for the mixer
They get recreated in the basic form - so removing contamination