11.4 KDE sound problem

Sound is not working. Clean install new home. Fully patched and multi-media stuff installed. It works in test in yast but nothing else has sound. There is a loud click when KDE starts. Also there is a delay before I can do anything. Tried changing the backends no luck. Also tried disable of phonon in Yast but have nor tried to remove it yet. Perhaps I should.

sound device nVidia Corporation CK804 AC’97 Audio Controller (rev a2)

I know it seems unlikely and you maybe did it

su -
rcalsasound restart

Have you had sound working before on this hardware with openSUSE-11.4 ?

If rcalsasound restart does not work, then you could try a couple of things …

Let me explain first. When you test sound in YaST you are testing with root permissions. So you are saying sound works with root permissions but not without, and also possibly working with the root mixer/pulse setup but not without. That suggests to me a couple of things:

  1. the mixer or pulse audio settings are different for root than they are for a regular user, or
  2. the regular user does not have the permission to use the audio device (and possibly needs to be added to group ‘audio’)

Reference the 1st item, since openSUSE-11.4 KDE, Gnome and LXDE desktops use pulse audio (I don’t know about XFCE) I recommend you install the application pulse audio volume control ‘pavucontrol’ and then when executing a multimedia application for the first time, at the same time it is running, run the application ‘pavucontrol’ and use that to tune your audio.

If that does not work, then reference the 2nd item you could add your regular user to group audio and restart and test your sound.

And if that does not work then I would need more information (ie the quoted request for information in our multimedia stickie: Welcome to multimedia sub-area

Well I’ll try that. I’m running from the 11.2 partition now so need to reboot. But this is a fresh install ie out of the box setup the sound has never worked. I installed a couple of months back but ran into these problems and have not gotten back to it. I’m not currently mounting my normal home yet until I can get 11.4 stable. I’ll check the groups. I’d expect to be a member of audio by default but we will see. There were some early reports of the on start freeze and the removal of phonon or was it the removal of pulse. There are so many layers anymore and it is certainly not clear how they relate to one another.

If the PC is relatively new, then I am finding Pulse Audio to be an improvement to GNU/Linux Audio ! (this is from me - a user who refused for years to use Pulse Audio).

If the PC is relatively old then Pulse Audio does impose an overhead, and one needs to ask if the ‘relatively’ user friendly advanced features are worth the extra overhead. On a new/fast PC to me there is no question - USE PULSE ! :slight_smile:

In my case, I found installing ‘pavucontrol’ (pulse audio volume control) essential to get the best audio experience in my openSUSE-11.4 (although I also note that view of mine is not without controversy as others claim it both is NOT and should NOT be necessary).

Some missing info with PulseAudio enabled in Yast: What does KDE [System] Settings > Multimedia > Phonon show? How many devices, and results of sound tests? Do you see the Speaker Setup tab, settings and speaker tests? Same for KMix re devices, and how many tabs?

rcalsasound restart

gives pop/click on shutdown and again on restart no errors

Was member of audio but there were two groups with pulse in name tried those no go

KDE [System] Settings > Multimedia > Phonon shows only pulseaudio no sound any where

There are 4 tabs in kmix. Playback Devices and capture shows only one slider Internal Audio analog stereo. Playback streams event sounds and capture streams nothing
This is not the newest machine AMD 3200+ with 2 GIG GeForce 6800 XT about 5 years old. Runs 11.2 like a champ. Ran 10.1 and 10.2 before without problems.

Got it working

Yast unchecked use pulse deleted (stopped) then restarted. Pulse just does not like this sound chip.