11.4 KDE has a few small problems

Hello all,

I’ve got openSUSE 11.4 64-bit installed on my workstation comprised of the following parts:

MSI 870A-G54
AMD 1055T 6-core
4GB ram
Intel SSD 40GB
Nvidia Quadro 600

Performance is good, almost everything works perfectly except it can’t seem to shut down.

It starts to shut down, but it gets to the screen with the white loading bar under the suse logo, and it only gets about 5% in, and it just stops and I have to force a power down with the power button.

I can boot/restart just fine, but I guess there’s something wrong with the shutdown script. I googled around to try to see how to do a verbose shutdown but I haven’t had any luck finding it for 11.4.

Also, Tuxracer won’t open anymore (which i’d used to verify that opengl was working on my video card…and also to collect fish at high speeds). I’ve tried removing it and reinstalling it but no luck, and it just worked the other day.

I’m also not sure if the latest nvidia driver from the nvidia repository is specifically a quadro driver or if it’s a unified driver - I just don’t want the system to think I’m using a GeForce if I paid for a Quadro. Is there any easy way to get the system to report what video card it’s using?

Thanks for your help in advance.

With one of my computers, shutdown works fine but reboot always hangs.

In your case, when you next reboot, do a failsafe boot. Then, from the console, login as root. See if you can shutdown with “shutdown -h now”.

If that works, then your suspicion of the video might be correct. If that doesn’t work, then it is more likely to be an acpi problem or a BIOS problem, or an incompatibility with the kernel and something in your hardware/BIOS.

The driver for your device seems to be the same as this guide will give
nVidia Driver via Repo in 11.3 & 11.4 - Guide

Hit Esc. once you select shutdown and you should see verbose

I tried booting with failsafe, and then from terminal I did “shutdown -h now”

the line it halts on is:

/etc/init.d/rc: line 339: 6524 Killed $link start

then after a few minutes it says:

Master Resource Control: runlevel 0 has been reached

I can’t make heads or tails of either of those, it seems like the system should be off shortly after it hits run level 0.

Any ideas? I’m gounna tinker with my bios settings.

weird…I can’t edit my last post, sorry for the double post.

I think I got the issue sorted out by disabling IOAPIC in the bios. I wonder why that fixed the shutdown issue?

I’m glad you got it sorted out.

Keep in mind, Tux racer continues to NOT work, and I’m deeply distraught over the issue.
Any information concerning this issue would be greatly appreciated.

Also, why did my fix work? I am not understanding.

With APIC off it may just be that it’s taking some problematic hardware out of the picture during boot and shutdown

I am having the same problem, but not on an intel machine. Mine is an AMD thuban 6 core processor, everything functioned perfectly on 11.3 however now with 11.4 I am getting the same hang on shutdown as you. Nothing I have done will allow it to shut down from the GUI. I can force a shutdown as root with shutdown now -h -p.

It isn’t a show stopper for me as my machine runs 24/7, but it is annoying enough that I have been googling for days. I have yet to come up with a solution and this thread is the first I have seen where someone is having the same problem.

I have the Gnome desktop.
I had the shutdown problem on my AMD 6 core box since 11.4 release day, also about 50% of the time a new start would require a reboot as clicking on a desktop icon would do nothing, tried reinstalling a few times but it didn’t help then yesterday I did a new install and now everything is working perfect.
Been using the proprietary nVidia driver installed the hard way all along by the way.
I am convinced that the install yesterday downloaded some fix.

My machine runs fine, no issues booting or running, everything works and behaves as I would expect. The only issue I have is the shutdown problem.

to clear up any confusion, I have an AMD 6-core system, NOT an intel.

So it seems the problem is entirely central to AMD 6-cores. It seems to me that a bug needs to be issued to the developers or sent up the chain somehow.

I fixed it by turning off IOAPIC in my bios. it works fine now, but if IOAPIC is an important thing…it should probably be on, it should just…work…when it’s turned on.

What do we do?

Well I don’t have IOAPIC setting in my Bios. Googling it only came up with intel related information so I figured it was an Intel thing.

However I just installed the new kernel from the stable repo Index of /repositories/Kernel:/stable/standard

My shut down problem was resolved with that kernel, and everything is working perfectly

Cool, it sounds like we have a fix. Unless someone else wants to, I’ll probably post a walkthrough of how to fix this issue.

go to the Kickstart menu

go to System

go to Administrator Settings

give it your password if it asks

go to Software Repositories

go to Add

go to HTTP

Click Next

under Repository Name, enter something like “Kernel:Standard”

under URL of the Repository, enter:
Index of /repositories/Kernel:/stable/standard

Click Next

I lost track of the rest, but it should be self explanatory…clicking “ok”/“next” until it’s happy

Keep in mind this only adds the repository to your system, it doesn’t install any substantial software.

Good luck