11.4 Installation ISO corrupt?


I seem to be stuck on the installation of the 11.4 version 32 bit edition. I’ve downloaded the ISO either straight from the direct link, through a mirror or by bittorrent. In all these cases, the computed MD5 matches the one displayed on the site. I’m trying to install it under a freshly prepared Virtual PC VM, directly with the ISO attached, but verifying the media always gives a “Checksum wrong. This DVD is broken.” If I ignore it, it will start moaning later on on package checksum mismatches.

So, what’s the deal here? I stopped believing in corrupted downloads after the third download. Is the Virtual PC/Virtual Server environment not supported or is the available ISO actually bad?

Thanks for your help.

Is this what you are working with

5f6d6d67c3e256b2513311f4ed650515 openSUSE-11.4-DVD-i586.iso

How are you checking the md5?

Yep, that’s the ISO and that’s the MD5 I get using the md5.exe tool. I’ve tried it through the Virtual PC on my local Windows 7 machine and also in Virtual Server 2005 R2 SP1 but with no luck. All these are kind of pointing to some sort of incompatibility with the VM when reading the ISO. Even though that sounds a bit crazy to me since it attaches it with no problems.

Well I do not think that Microsoft will try to make running Linux easy. This is a report of the MS announcement:

I think that you have to not use the default VM settings. Try searching for an article by someone who has installed any Linux distro in Virtual-PC. You may have to get the Linux or SUSE “guest additions” for MS Hyper-V.

I would advise trying a dual boot installation, then installing VirtualBox in openSuSE, and mounting your MS Windows partition in a VBox VM. Check out the VirtualBox forums.

I have never used windows for running VM’s

But if the md5sum is correct and you are mounting the .iso, then there shouldn’t be a problem

I can tell you, there are no problems with the actual media .iso’s on downloads.opensuse

Might be worth trying Virtual Box too, just for sake of sanity

Caf, the windows infrastructure is quite wide-spread in this world, for both corporate and user areas. For sure you’re gonna find people having Windows as their main work OS, and I’m one of them.

Alright, thanks for pointing me in the right direction. I’ve installed VirtualBox and attached the ISO. In there the installer is not complaining about mismatched MD5s and I managed to get it installed without a hitch.

As eng-int suggested, digging a little bit deeper revealed that 11.3 version was possible to install in Virtual PC, under Windows 7, according to this article . I’ve tried those boot options that were described in that article, even though I wasn’t experiencing any of the issues that were previously reported (e.g. mouse problems, UI not showing, etc.). But still no luck. Same error messages… So the conclusion, from where I’m sitting, is that there are some breaking changes in the install of OpenSUSE 11.4 that are stopping it from being installed under VirtualPC or Virtual Server. It would be nice for someone with more technical skills to have a look, but the VirtualBox idea works for me so thank you all for the support.

Is Virtual PC some windows crud? I suggest the problem lies not with 11.4 but with Virtual PC.

Yes. I appreciate some people find it necessary to use windows and I’ll not hold it against you

On 09/29/2011 04:06 PM, MoonStorm wrote:
> So the conclusion, from where I’m sitting, is that
> there are some breaking changes in the install of OpenSUSE 11.4 that are
> stopping it from being installed under VirtualPC or Virtual Server.

on the contrary, it is not 11.4 which is broken:

  1. first 11.4 works perfectly here on real machine.

  2. it works perfectly on lots of machines.

  3. it works fine on VBox

  4. it is VirtualPC and Virtual Server which are unable to adequately
    replicate a real machine in which 11.4 can run

sorry you are forced to use deficient software…try it the other way
around: run openSUSE 11.4 as your host, and then run Win7 inside
it…then quick make a system image…then, when you are compromised,
rooted or otherwise infected you can just shut down the VM and restart
the known clean image, and be on your way in no time…

openSUSE®, the “German Automobiles” of operating systems