11.4 Gnome - unable to boot to desktop

I ran my updates today when I saw they were available. No problems, and I continued on for a few hours. I rebooted to XP and then on booting to go back to my primary (11.4), Gnome does not start.

During boot I see the following error


starting vmtoolsd FATAL: error inserting vmw_balloon (/lib/modules/2.6.37.6-20-desktop/kernel/drivers/misc/vmw_balloon.ko): no such device
...
Failed services in runlevel 5: vmtoolsd

I previously had vboxadd in the failed services list, but had used YaST to remove VirtualBox.

If I try to start Gnome after logging in, i get the following errors:


# /usr/sbin/gdm start

** (gdm:3812): Warning **: failed to aquire org.gnome.DisplayManager
** (gdm:3812): Warning **: could not aquire name; bailing out

I had received the same error while VirtualBox was still installed. I am using OpenSUSE 11.4 x64 w/ Gnome and a Nvidia video card. For the last year and a half about, I have had no issues with Gnome. Can anyone please help me get back to my desktop?

can you boot to level 3?
Boot to Level 3, then Yast and More… - Blogs - openSUSE Forums

Yes, I can get to level 3 and log in.

Become su -
and do

zypper ve

Try and tell us what it reports. If everything is OK it’ll be simple to report…

Thank you Caf4926. No problems here. Zypper downloaded metadata, refreshed caches, and finished saying “Dependencies of all installed packages are satisfied”.

So, I’d look at checking this. From the same level 3 and as su -

zypper ref
zypper up

tell us if anything happens

There were some updates for multimedia related things like LMMS and Gstreamer. I ran zypper up and after tried rebooting. Still at the CLI.

I came across an old thread from a mail list about vmw_balloon.ko missing and there was mention that the file may be misnamed. I had followed the error path I got during boot (/lib/modules/2.6.37.6-0.20-desktop/kernel/drivers/misc/vmw_balloon.ko), only there are no file names with balloon in them.

I also noticed that there were 3 different folders in /lib/modules/ and one was created yesterday, when this began happening. I know there is something with VirtualBox that when there are kernel updates, something must be recompiled or something for VirtualBox to work again, along with the latest guest addons being updated.

Is it possible this could be related to something with VirtualBox? Even though I had removed it through YaST?

According to the name of the module, it could be related to vmware. VirtualBox doesn’t have such a module AFAIK.

On 2012-07-26 10:26, Wandering Voice wrote:
>
> There were some updates for multimedia related things like LMMS and
> Gstreamer. I ran zypper up and after tried rebooting. Still at the CLI.
> -
> I came across an old thread from a mail list about vmw_balloon.ko
> missing and there was mention that the file may be misnamed. I had
> followed the error path I got during boot
> (/lib/modules/2.6.37.6-0.20-desktop/kernel/drivers/misc/vmw_balloon.ko),
> only there are no file names with balloon in them.

The file is in my installation:


cer@Telcontar:~> rpm -qf /lib/modules/2.6.37.6-0.20-desktop/kernel/drivers/misc/vmw_balloon.ko
kernel-desktop-2.6.37.6-0.20.1.x86_64

> Is it possible this could be related to something with VirtualBox? Even
> though I had removed it through YaST?

Check what do you have installed related to vmware or virtualbox. Like “rpm -qa | grep vmw”.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)