11.4 freezes during automatic configuration

im reinstalling 11.4 on my laptop and I can’t seem to get past the automatic configuration. It installed perfect earlier, and I’m not sure its freezing this time.


Did you run the media check???

No errors, it just freezes at 42 % every time. I ran the media check, and it found no problems.

First of all save your files.

What is “the automatic configuration” ?

Did you try different installation settings this time ?

Did you try the safe settings this time ?

Can you tell us what model/make graphic card your laptop has ? How about the model of the laptop ?

Have you completely reformatted the old / (root) partition ?

I tried different settings, formatted the drive, different disk, etc. It worked earlier that day, but when I went to reinstall it wouldn’t work

Its a toshiba, cpu-amd e350, gpu-amd 6310

I couldnt find it on toshibas site but heres the model.

Toshiba Satellite 15.6" AMD E350 Laptop (C650D-008) - Black : 15" Laptops - Future Shop

I understand, but we need to know if you tried some SPECIFIC settings, not just any different settings. Did you try the “safe settings” during the install ? (that sends both the command ‘nomodeset’ and ‘x11failsafe’ which will load the FBDEV instead of the radeon or radeonhd driver).

Is there any chance between the installs that you changed a BIOS setting?

Anyway, I see its a Toshiba Satellite C650D-008 (E350) with an Radeon HD 6310 graphics. On my PC when I type “man radeon” (to see what graphic cards the ‘radeon’ open source graphic driver supports) I note “PALM Radeon HD 6310/6250” which tells me the graphics should be supported by the ‘radeon’ graphic driver. When I type ‘man radeonhd’ I see no entry corresponding to the Radeon HD 6310 which suggests to me the different ‘radeonhd’ graphic driver does not support the Radeon HD 6310.

Normally openSUSE should boot to the ‘radeon’ graphic driver by default, but some of us discovered a bug that either the kernel or udev causes a problem (with the nominal settings) such that the PC never gets to the loading of X window with nominal settings for some Radeon HD hardware. By specifying the boot code ‘nomodeset’ we are able to get by this problem, but ‘nomodeset’ on openSUSE also causes the loading of the ‘radeonhd’ graphic driver which does not support the HD 6310. Hence my recommendation to try ‘safesettings’ which will load the ‘FBDEV’ graphic driver via the ‘x11failsafe’ boot code. I think on the installation CD/DVD, the menu selection F3 in the initial grub splash/boot-manager selection screen will show you the ‘safesettings’ that you can try.

A question about your initial burning of the installation CD/DVD (which you note worked previous). Did you burn it at the slowest speed your burner allows to a +R or -R CD/DVD (and not to an RW) and to a high quality CD/DVD and not some bargain basement special ? My experience after burning literally hundreds of CD/DVDs to test openSUSE (and some other) Linux distributions is if one does not do so, then the CD/DVD has a higher probability to degrade with time.

Also, I note on this linlap page for the Toshia C655D (a similar, but not same laptop) that disabling ACPI was necessary to load Linux. That page even goes further to state that if using a 2.6.35 kernel, “acpi=copy_dsdt” must be added to the kernel boot parameters. openSUSE-11.3 has the 2.6.34 and openSUSE-11.4 has the 2.6.37 kernel, so I do not know if that is relevant to your case. It also notes that when the laptop boot fails an ACPI-related stack trace is displayed.

When your boot fails/freezes, what do you see on the computer screen ? What do you see just before the fail ?

I get through the install with no problems, but after the reboot is where im having problems. It freezes halfway through automatic configuration. I tried what you suggested, safe setting, no acpi, but still had the same result.

Make certain you check your installation CD/DVD. ie conduct an md5sum of the downloaded .iso file, and compare that to the md5sum of the iso file posted on the openSUSE download page. Also burn to a +R or -R (not RW) CD/DVD at the slowest speed your burner allows. Ensure you burn to a high quality CD/DVD media and not some bargain basement quality CD/DVD.

Also, if you succeeded in an install then there is no ‘safesetting’ selection upon reboot, but rather it is ‘failsafe’. (Safesetting is the selection for the initial install, while ‘failsafe’ is the setting upon a reboot). Your terminology has me puzzling as to what you actually tried.

If the media check freezes then there is something wrong with the media, the ISO or the hardware. The media must pass the check to make a install.