11.4 could not start ksnserver

Hello all,

I have seen other posts with a similar subject and has tried some of the solutions posted around the forum or documentation, but that has not been successful.

The computer I am using is a laptop:

Compaq Presario CQ60 Model CQ60-419WM (yes, the one Wal-Mart had for $300)
Architecture: x86_64
Processor AMD Sempron SI-42
Video Card: NVIDIA GeForce 8200M G
Video Processor GeForce 8200M G
Wireless Network Adaptor: Atheros AR5006X (according to Windows, but Linux thinks it is AR5001).

I have Windows XP in a separate partition of this computer and most of the information above was obtained using the program siw.

I recently updated to 11.4 from 11.3, using a CD I burn. I got the download from openSUSE.com using the network option. I believe the kernel is (at least that is what it prints after openSUSE 11.4 when it loads). I checked the check sum for that download and it matched, and also checked the installation media before installing. The best I get right now is a console window. At some point, if I did not choose the failsafe options I was getting the infamous message:

Could not start ksnserver. Check your installation, and I would not even get a console (I have seen ksmserver on the web, I am sure mine said ksnserver, I am assuming it is the same). Now, after blacklisting nouveau, I can get a console.

I am assuming I need to locate a good NVIDIA driver somewhere and then make sure it gets loaded. I recall doing something similar for 11.3, but apparently that driver got wiped out during the upgrade.

I can run yast from the console in a keyboard based interface, but it runs a bit cranky and gets stuck, so I am more inclined to editing the configuration files by hand.

In 11.3 the display worked fine (after I installed a driver I found back then), except that I could never use a second monitor.

I would appreciate any suggestions. OL.

Replying to my own post, I found a driver in NVIDIA.com that looks promising, although it does not list 11.4. Will post an update after I find the time to download it. Still open to suggestions though. OL.