11.4 can.t find printer.

Have printer Brother HL-1230 . Working proerly on all previous version, now Yast can.t find printer. Of course, cable connected and Printer is On. If need more info, let me know, please.
P.S. It.s connected via Serial port, not USB.

Device DMA IRQ I/O Ports


0000:00:1d.0 ff80-ff9f
0000:00:1d.1 ff60-ff7f
0000:00:1d.2 ff40-ff5f
0000:00:1f.0 0800-087f 0880-08bf
0000:00:1f.1 0170-0177 01f0-01f7 0376-0376 03f6-03f6 ffa0-ffaf
0000:00:1f.3 dc80-dc9f
0000:00:1f.5 d800-d8ff dc40-dc7f
0000:02:0c.0 ecc0-ecff
acpi 9
ACPI 0800-0803 0804-0805 0808-080b 0810-0815 0828-082f
ata_piix 14 15 0170-0177 01f0-01f7 0376-0376 03f6-03f6 ffa0-ffaf
cascade 4
dma 0080-008f
dma1 0000-001f
dma2 00c0-00df
e1000 ecc0-ecff
ehci_hcd:usb1 23
eth0 18
floppy 2 6 03f2-03f2 03f4-03f5 03f7-03f7
fpu 00f0-00ff
i801_smbus dc80-dc9f
i8042 1 12
Intel d800-d8ff dc40-dc7f
Intel 82801DB-ICH4 17
keyboard 0060-0060 0064-0064
nvidia 16
parport0 7 0378-037a 0778-077a
PCI 0cf8-0cff e000-efff
pic1 0020-0021
pic2 00a0-00a1
pnp 0c00-0c7f
rtc0 8 0070-007f
serial 03f8-03ff
timer 0
timer0 0040-0043
timer1 0050-0053
uhci_hcd ff40-ff5f ff60-ff7f ff80-ff9f
uhci_hcd:usb2 16
uhci_hcd:usb3 19
uhci_hcd:usb4 18
vesafb 03c0-03df

Did you download the rpm from the brother download site.
I have a brother multifunction network printer (MFC5890CN) and I always use the
rpm driver from their site and always work without any dependency issues.

Find the driver for your printer in their site, it might work with your printer also.

It.s not helping :frowning: . Still saying that no connections.

Sorry, it.s connected via Parallel port, not serial. My bad.

bump. Ireally want to find solution… .

  1. Make sure the parport, parport_pc, and lp drivers are loaded.

For reference, I get

lsmod |grep parport
parport_pc             33475  1 
parport                34052  3 lp,ppdev,parport_pc

Are these loaded on your system?

If lp not loaded for example, you can type (with root privileges)

modprobe -v parport
  1. Now, you didn’t explain how you tried to configure CUPS. Did you try configuring with the CUPS web interface?


There is an option there to ‘Add Printer’ and select ‘LPT#1’ (parallel) printer…


I did what you recommend.
I get this result:

hafi@wallee:~> lsmod |grep parport
parport_pc 33763 0
parport 34550 2 ppdev,parport_pc

so the module parport is not linked to module lp.

It also looks like the module lp is not available, at all.

hafi@wallee:~> lsmod |grep lp
drm_kms_helper 32687 1 nouveau
drm 191593 4 nouveau,ttm,drm_kms_helper

so no lp module is available!


How can I start module lp??

Did you try this?

su -
modprobe -v lp

If this works, there is a way to make sure it is loaded at boot (via YaST). Report back.

After trying all modprobes, it.s finally found printer. Thanks. Just what i need to enable in Runlevel?

P.S. autofs also wasn.t enabled by default.
Found also finally printer driver, because it.s disappeared in this Suse version.

To load the lp module at boot:

YaST > System > /etc/sysconfig Editor. Navigate to System > Kernel > MODULES_LOADED_ON_BOOT. Add the lp module. Click on ‘OK’ when done.

To enable autofs:

YaST > System > System Services (Runlevel). Naviagte to autofs (in list). Click ‘Enabe’ then ‘OK’.

Now you should be good to go. :slight_smile:

Thanks a lot! autofs i enabled myself. IT.s more like bug. Probably because of it, i mounted Memory card manually.
Good thing is that system don.t failing to start because of missing media. I mounted memory card, which is now removed, but system woke up anyway. Don.t know, what happening if hard drive have errors. With 11.1 it.s didn.t woke up and i needed to fix errors manually.

Hey guys, I’ve got a similar problem

In 11.3 I used an Epson Stylus Color 600 which worked just fine.

Now I’m quite disappointed that this so called ‘best version ever’ (11.4) refuses to recognize this printer.

The modules parport, parport_pc, and lp are all loaded. My printer is on and connected, but OpenSuse claims that there is nothing.

This issue contributes to my impression that OpenSUSE got worse from 11.3 to 11.4…

Hi codestar

To give yourself the best chance of receiving help, please start a new thread, with a descriptive title (maybe including your printer model). I’ll help you if I can.