11.4 Beta - Audio CDs don't work

Howdy,

Weird bug on 11.4 Beta:
Data CDs and DVDs work fine, but audio CDs don’t.

When I insert an audio CD, I get the message:
Unable to mount audio disc.
Cannot find drive /dev/sr0.

Dmesg shows this kind of thing:
2070.270047] ISO 9660 Extensions: Microsoft Joliet Level 3
2070.307464] ISOFS: changing to secondary root
2206.566335] sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
2206.566342] sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current]
2206.566348] ILI
2206.566350] sr 4:0:0:0: [sr0] Add. Sense: Illegal mode for this track
2206.566358] sr 4:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 02 00
2206.566369] end_request: I/O error, dev sr0, sector 0
2206.566373] quiet_error: 7 callbacks suppressed
2206.566376] Buffer I/O error on device sr0, logical block 0
2206.569541] sr 4:0:0:0: [sr0] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
2206.569547] sr 4:0:0:0: [sr0] Sense Key : Illegal Request [current]
2206.569552] ILI
2206.569554] sr 4:0:0:0: [sr0] Add. Sense: Illegal mode for this track
2206.569561] sr 4:0:0:0: [sr0] CDB: Read(10): 28 00 00 00 00 00 00 00 02 00
2206.569571] end_request: I/O error, dev sr0, sector 0
2206.569575] Buffer I/O error on device sr0, logical block 0

Any ideas on how to fix this?

Cheers,

H.

There is no openSUSE by the name 11.4 beta. There are 11.4 milestones, from #1 until #6. Presumably you are referring to one of those ?

I note this does not work on your PC based on your post. I just put an audio CD into my recent 32-bit openSUSE-11.4 Milestone-6 LXDE install. The popup did not show an audio player (only showed the pcmanfm file manager and brasero cd burning program). But I then launched smplayer [that I custom rebuilt from a packman src file] and was easily able to play the audio CD.

So it does work in 11.4 M6 LXDE with software appropriately installed/configured.

I am running 2.6.37-rc5-12-desktop on a Toshiba laptop. I only get this problem with audio CDs, which is why I haven’t noticed it till I bought a new CD and wanted to rip it today.

I don’t normally install different kernels other than the ‘stock’ kernel, so I can’t really comment on the error. I assume you have confirmed that ‘audio cd’ to be a good CD.

I note 11.4 M6 has the 2.6.27-20-default kernel on my PC with LXDE destkop (which will play an audio CD).

@oldcpu

I think that kernel-2.6.37-rc5-12 was from milestone 5. We do not know what audio software is being used – ms5 included KDE-4.5.85 which had “issues”.

Good point. I still have 11.4 M5 on my athlon-2800 (which I am about to remove in a few minutes, to replace with M6).

I inserted an audio CD into this PC while 11.4 M5 (with the 2.6.37-rc5-12 default kernel is still installed) and kaffeine was presented by KDE as an option to play the audio CD, which I did (play) for a while. Sound was good (for a while)! After about 5 to 8 minutes, the CD would stop playing in Kaffeine, … so there is possibly some sort of bug.

So audio CDs partly (but not adequately) work with KDE-4.5.85 (4.6.Beta2) on a 32-bit openSUSE-11.4 M5 install (from the DVD). PC details:

  • 32-bit AMD Athlon-2800
    w/2GB RAM (Asus A7N8X Deluxe motherboard) w/ PCI nVidia GeForce 8400GS graphics [age ~6 years]

I’m also not going to stick at M5 to problems on this as I want to test M6 on this PC. Sorry. But I will let an audio CD play on 11.4 M6 smplayer LXDE desktop to see if it stops after 5 to 8 minutes.