11.4 64 bit sound and KMix

Hi I’m running a fresh install of 11.4 64 bit with KDE. Everything else seems to work, but there is a problem with sound. I have a Xonar DS card that is recognised by the system and which works when I test it under the sound section of Yast.

I have the Packman repository and Libdvdcss repository listed in Yast.

However, no sound from any application/cd/dvd/internet or on boot.

I’ve noticed that, in KMix, if I go into the mixer there is settings option -> audio setup. Under this there is a speaker option which offers the choice of the source of sound to the speakers - from my sound card or from the internal Intel sound - which does not work, hence my sound card. When I choose my sound card the test L & R speaker sounds work fine - but it won’t hold the setting after I have clicked “apply” and left the audio setup. It then reverts to the internal sound chip and, lo and behold, no sound is now produced.

Any suggestions?

Install the package called pavucontrol. See if that gives you any better control and configuration possibilities.

If not, you could work your way through this guide: SDB:Audio troubleshooting. Post back here with any queries.

Also, if you haven’t already, checkout the stickies at the head of this forum, particularly this one: Welcome to multimedia sub-area. It has some useful commands for collecting your audio info when posting back here. :slight_smile:

That gets you to Phonon - KDE Control Module. I should have mentioned that on Device Preference tab just make sure your sound card is the preferred device. If not adjust position using Prefer/Defer buttons.

I found a simple but great workaround to bring back all of the channels on Kmix.

Add the following to .bashrc

export KMIX_PULSEAUDIO_DISABLE=1

Now click on Kmix and notice the difference.

Remember to have fun!

Romanator

OK - the “export” command didn’t seem to make any difference. However, getting to the audio setup (instead of via Kmix) via configure desktop -. Hardware -> Multimedia -> Phonon and changing the speaker setting from internal sound to sound card seemed to magically switch on the sound - even though the speaker setup seems still not to “stick” to the sound card, but reverts to the internal sound card which, as far as I know, doesn’t work. No idea what’s going on, but I’ve got sound now so I’m happy. Thanks for everyone’s comments.

Pulse audio makes it very easy to control multiple sound devices … and I wonder how far you followed up consused’s suggestion to take a look at pavucontrol.

For example, on my ancient sandbox PC which has 2 separate sound devices (motherboard sound and a basic sound card in a PCI slot) pulse audio provides excellent device control .

Here is a screen shot of the configuration tab display showing the two devices
http://thumbnails50.imagebam.com/14555/743f5c145542710.jpg](ImageBam)
[click on image for larger view]

Here is a screen shot of the output devices where it is important to ensure the devices are not muted. Note I have SHOW all output devices selected.
http://thumbnails36.imagebam.com/14555/f6fbad145542711.jpg](ImageBam)
[click on image for larger view]

Here is a screen shot of the playback tab where I am playing a video with the application ‘ffplay’. You can see I am about to chose the sound card in which I want the audio to come out. Note I have SHOW all streams selected.
http://thumbnails53.imagebam.com/14555/679ee6145542714.jpg](ImageBam)
[click on image for larger view]

Thats all. Its that simple.