11.4 64 bit First boot, can ping google, cannot surf

I just installed 11.4 64 bit off the DVD. I installed the Gnome desktop. I can ping internet sites but cannot get anywhere in Firefox. I disabled firewall at install summary right before it starts installing the packages. This is right out of the gate on first boot.

hello, try to disable with yast ipv6

no luck. how strange for such a basic task to fail right off the install.

What method did you employ to disable ipv6 ? My guess is the method you employed is no good. Of course if you would have explained the method, I would not have to guess that.

To disable ipv6 in openSUSE-11.4 you MUST use the boot code:

ipv6.disable=1

There are many methods for disabling ipv6 in EARLIER openSUSE versions that do NOT work for 11.4.

for me it was enough to go in Yast/Network Settings/Global Options and to switch off Enable IPv6 check box. Then after full restart everything worked OK.

I had the same issue with Xfce, installed from netinstall image. I think there is a serious bug in openSUSE’s NetworkManager. I had to connect to my wireless network manually.

Check out Serious networking problems with a fresh openSUSE install

I think I have the same problem here. I installed 11.4 64-bit on my laptop everything was working at home. Now I’m in a hotel room with free wireless access, working fine with 11.1, but not on 11.4.

dig and nslookup are working fine even ping does (with names!!! and IPs), but applications get cannot resolve address for x.y.z.
If I use the address I got by nslookup for ssh it work.

I did disabled IPv6 (but I did know that was not IPv6 related) - no change.
Again it is working fine with a old 11.1 installation on the same machine - I writing this with it.

It is working on a other location, with similar setup and same address range (standard 192.168.1.0/24 NAT setup) the difference is, the hotel use a unencrypted WLAN.

I also disabled nscd - not change.

So it seems that it depends on the network environment, but since it works with 11.1 it should do with 11.4 as well.

Did you try with other browsers than firefox (Opera, Chrome)?
If they work then there is posibility to disable using ipv6 in firefox: SDB:Disable IPv6 for Firefox - openSUSE

HI,
All of my installations had the same problem.
Open a terminal in root and type:

/sbin/dhclient eth0

or replace eth0 by wlan0 if wireless network

And all my opensuse 11.4 do not connect at boot: there is a bug for sure (need “rcnetwork restart” at each boot)

It sounds as if you have a DNS problem. Please post the output of


cat /etc/resolv.conf
/sbin/route -n

You might also try adding the line “nameserver 8.8.8.8” to resolv.conf.

I’m having the same issues. Posted in another thread on this forum.

curl is broken

While home, I can’t get YaST repositories to update their catalogs. But they function at work. I uninstalled a broken Beta version of Firefox that came with the DVD. Reinstalled Firefox version 4.0.1 from the online repositories while at work. It still is broken. Won’t get to the Internet or bookmark any URLs.

Some are saying I have a DNS issue in my home network. Perhaps so … but everything else (Windows & Linux machines) works fine. So why is 11.4 having multiple issues?

For more than 2 years, the Dell Latitude D830 laptop I use had openSUSE 10.3 x86_64 on it. Pretty much worked flawlessly. And I miss KDE 3.5 Konquorer rocks.

I sure want to see 11.4 x86_64 work better. Otherwise I might have to look at other distros.

There was an error in the repository initialization.
'Updates-for-openSUSE-11.4-11.4-0': |] Valid metadata not found at
specified URL(s)
History:
- Unknown error reading from 'http://download.opensuse.org/update/11.4/'
- SKIP request: User-requested skipping of a file
- Download (curl) error for
'http://download.opensuse.org/update/11.4/repodata/repomd.xml':
Error code: Connection failed
Error message: Couldn't resolve host 'download.opensuse.org'

Download (curl) error for
'http://download.opensuse.org/update/11.4/repodata/repomd.xml':
Error code: Connection failed
Error message: Couldn't resolve host 'download.opensuse.org'

Maybe I need to download the DVD again from a different repository & perform a reinstall. Appreciate feedback.