11.4/32b : no ondemand governor on pentium4

On an asus p4C800, i have a, very old, pentium 4 3.2 GHz (HT, prescott). On which i installed an opensuse 11.4 (after some network quirks and some grub tricks)…

First i saw that the p4_clockmod module was not compiled for the kernel.
It took me one night to compile the modules, and it borked my whole installation, which i spent my day to remake, but that’s another story.

After loading all the appropriate modules (speedstep-lib, cpufreq-something, etc…), i run this command :

cpufreq-set -g ondemand

But , the governor remains viciously performance according to cpufreq-info .

Strangely, runing this command :

cpufreq-set -g powersave

changes the governor to powersave. Same for userspace and performance.
Only conservative governor also refuses to load.

How can i solve this ?

CPU Speed control exists now in YaST. Why not do the following, open:

YaST / Software / Software Management, search on Power and install yast2-power-management. Once done, restart YaST.


YaST / System / System Services (Runlevel), select Expert Mode Bullet at the top left:


Find and highlight pm-profiler and then select the button on the bottom right and Enable the pm-profile Service and answer yes to the added services requested.


Select the button on the bottom left and Start the pm-profiler Servrce. You should get a good start with a 0 error return code.

Now select the finish button on the bottom right and allow your selections to be saved.


YaST / System / Power Management. You can select from three choices with Power Saving doing what I think you are looking for.

Thank You,

jdmcdaniel3 > that doesn’t work . I mean, cpu frequency does not dynamically adapt to workload, with the install and click Yast power management.
Anyway, thanks.

Anyone knows how to make the ondemand governor work on such a machine ?

If you look in the throttling file so you can check the cpu capabilities?

cat /proc/acpi/processor/CPU0/throttling

malcolmlewis > it says it is not supported . That’s really strange ! I have this machine since almost eight years and cpu throttling has always been supported as far as i can remember.
How can i solve this ?

whats the output of

lsmod | grep acpi

Further file a bug -> bugzilla.novell.com

There has been a lot of changes in both kernel and opensuse regarding
cpuscaling (among them, depreacating of hal that used to load the right
modules on boot before )



show an “ondemand”-profile being available?

Zaitor > lsmod | grep acpi gives no output .

gropiuskalle > cpufreq-info mentions that the ondemand governor is available. Strange !

BTW i have to force the modprobe of P4-clockmod. And i have to manually load other cpufreq-something and speedstep-lib modules .

Does anyone have a clue for that ?

Maybe is there a userland script to adapt cpu frequency to workload with the userspace governor ?

Or do people have a better idea ?

Christophe_deR Does anyone have a clue for that ?

Maybe is there a userland script to adapt cpu frequency to workload with the userspace governor ?

Or do people have a better idea ?
It is kind of interesting to me that you own one of only two CPU’s I have ever burnt up and I have worked with a lot of CPU’s. That baby just got so hot it burnt up a regulator on the motherboard. I really don’t know for sure what went on, but I still have it in a picture frame with 11 other older CPU I keep for posterity purposes. So, I wonder just how bad you want to get control of your speed for this very old CPU? Is it bad enough to compile your own kernel perhaps using, the latest stable version you can download? I found the following link which matches up to some configurations you can make in your kernel configurations before compiling it. Here is the link:

Linux Kernel Configuration - CPU

If you are still game, then first go here and download kernel


Next, in preparation to compiling a kernel, do the following:

Open YaST / Software / Software Management - Select the View Button on the top left and pick Patterns. Now, you will see several Patterns listed and you want to select:


[X] Base Development
[X] Linux Kernel Development
[X] C/C++ Development

Then Press the Accept button on the bottom right and allow these applications to install.

Next, you need to download my bash script SAKC from here in message #17:

S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.00

Now, lets see if any of this proves helpful.

Thank You,