11.3M3 LiveCD KDEx86 Nvidia blank screen on Inspiron 530

I tried Milestone 3 on my Dell Inspiron 530N with a NVIDIA GeForce 8300GS to boot into LiveCD.

I tried several options (failsafe, no dmca, 800x600, …) but alwas the same result: when the system switches to the login screen the screens goes black (or shows the 4 basic colors with no dmca).

ALL openSuSE versions (at least since 10.0) have been running on this PC very well.(Just now I’m using 11.2 with Nvidia - driver.

I really don’t know how to fix - no x11org.conf anymore, no SaX, …
I saved all relevant files from /var/log (e.g. Xorg.0.log) in case anybody is interested.

OpenSUSE seems to run pretty fine - otherwise (going into another terminal doesn’t show any problems)

BTW problem was identical with Milestone2.

Does anybody has the same problem - or does anybody know a solution / workaround


You are aware of the fact that this is a Milestone release? And of the fact that Milestone releases are considered not stable?

Did you manage to install the NVIDIA driver? The official ones don’t support kernel 2.6.33 yet, NVIDIA just released new beta’s on their FTP site: ftp://download.nvidia.com/XFree86/Linux-x86_64/195.36.15/NVIDIA-Linux-x86_64-195.36.15-pkg2.run

Installing this one ‘the hard way’ might be the solution to the blank screen problem.

I’ve used the proprietary nVidia driver on milestone3 (lxde desktop) so I know it works.

Note if you boot to run level 3 (full screen text mode) and login, there is the tool “yast” that you can run with root permissions. This gives you access to a menu driven package manager, if you do not like using the command line zypper. That is useful for downloading packages such as sax2 (which are not on the liveCD).

Also, while I have not tried it, I suspect the old method with:

Xorg -configure

may work.


thanks for your answer.

No, I even didn’t try to start isntallation of NVIDIA driver.
I only wanted to get standard KDE desktop up and running - based on the noveau - driver.

I also switched to run level 1 and 5 back again (from the console) but no changes.

I know by heart this PC (the original DELL Ubuntu 7.04 LINUX Desktop) is always a little picky concerning graphics - and 11.3M3 runs very well on other (non-NVIDIA) PCs!



I will try the Xorg -configure - but I’m not sure if it will work: for me everything regarding X11 seems to have changed with 11.3.

Yast didn’t help to configure X - it gave me no option for this.
Your info regarding SaX2 is is good. I was wondering why it wasn’t there - but I thought it was another part of the “old” X11. I will give it a try - and first install it via zypper or yast. Network runs fine.



thanks for your replys.

I tried many things but didn’t proceed anyhow.

I tried runlevel 3 and Xorg -configure:
Screen goes blank with one small underscore in the upper-left corner. No terminal (ctrl-alt F2 etc) available, no access - only power off helps anymore.

I installed and started sax2. No chance, too. I tried sax2 -r -m 0=nv or even 0=vesa.
I get only messages on the screen - which I even can’t capture vusing “>…” or “2>…”

Is there anybody out there having another idea how to get graphics up and running?


Try using a digital camera to capture the on screen errors and post the pix on a site such as ImageBam - Fast, Free Image Hosting and Photo Sharing

… if we can not see the errors, then realistically we can NOT really propose much.

Note, there are also /var/log/Xorg.0.log files that you can post on PasteBin.be

and there is a dmesg file, that you can type as a regular user:

dmesg > dmesg.txt

and also post the dmesg on PasteBin.be

You can copy the files to a USB stick in order to have access to them when you boot to a more functioning OS.

Do you know how to copy to a USB stick from a terminal, or do you need to be taught how to do that?

Is nouveau in the Milestone’s kernel? Is it maybe blacklisted?

High OldCPU

you will find my Xorg.0.log in pastebin.be as #24012 (no protection key).

If other files would help (messages, boot.msg, boot.kiwi, …) - they are available, too.

BTW I always NFS to NAS - much more convenient than usb stick.

As far as I’ve learned Nouveau is the default with 11.3.


That log file suggests to me the opensource ‘nv’ driver is being loaded and not the ‘noveau’ driver, because I see many " (II) NV(0) " entries. I do NOT think they will give the ‘noveau’ driver the same name as the old opensource ‘nv’ driver, although I have no ‘noveau’ driver experience, so I suppose I could be wrong. Still, that approach would surprise me if so.

A silly question - how confident are you that your installation media is good? Did you do an md5sum check of the downloaded iso file against the md5sum on the download website? Did you burn to a +R or -R and NOT to an RW ? Did you burn to the slowest speed your burner would allow ? Just doing a media check in my experience is not adequate. One also needs to choose good media and burn to the slowest speed. Faster burn speeds will often cause problems.

I also note this:

#(EE) Failed to load module "nvidia" (module does not exist, 0)
#(II) LoadModule: "nouveau"
#(WW) Warning, couldn't open module nouveau
#(II) UnloadModule: "nouveau"
#(EE) Failed to load module "nouveau" (module does not exist, 0)
#(II) LoadModule: "nv"
#(II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so 

which also suggests the nouveau is not being loaded.


I think a bad burn isn’t the problem:

a) I have burned so many images and never had a problem (I know - no good argument but an indication)

b) I also burned 32-bit version and I have exactly the same problem.

I also have burned many (hundreds) of images in the past. I have learned that when one uses an RW, or burns at a high speed it only causes a problem occasionally. Did you burn to an RW ? Did you burn to a speed other than the slowest?

Same question.

Some code I note from that log:

#(II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
#(II) Module nv: vendor="X.Org Foundation"
#        compiled for 1.7.5, module version = 2.1.16
#        Module class: X.Org Video Driver
#        ABI class: X.Org Video Driver, version 6.0 
#GeForce 8500 GT, GeForce 8400 GS, GeForce 8300 GS, GeForce 8400 GS,
#(II) NV(0): Monitor name: DELL E228WFP 
#(II) Dell Dell USB Keyboard: Configuring as keyboard
#(II) config/hal: Adding input device USB Optical Mouse  

Its possible its struggling with your monitor … I don’t know enough about this to be certain.

… I note at the end of that log file:

#(II) NV(0): EDID vendor "DEL", prod id 53269
#(II) NV(0): Probing for EDID on I2C bus 1...
#(II) NV(0):   ... none found
#(--) NV(0): Trying load detection on VGA0 ... nothing.
#(II) Dell Dell USB Keyboard: Device reopened after 1 attempts.
#(II) USB Optical Mouse: Device reopened after 1 attempts. 

You may need to download sax2 and try to configure the ‘nv’ driver yourself with

sax2 -r -m 0=nv 

I always burn at a quite slow speed (16x or even 8x) - but I think the probability to get twice the identical problem with 32 and 64 LiveCD is quite small.

I had tested both

sax2 -r -m 0=nv and
sax2 -r -m 0=nouveau

both showed identical results.

I even tried
sax2 -r -m 0=vesa

with identical results.

Yes it is a NVidia 8300GS and a DELL E228WFP 22" (it is still original Hardware - as Dell’s Ubuntu-desktup running Ubuntu 7.04)

Out of curiousity, did you try the ‘fbdev’ driver?

Am I correct that there is only 1 graphic hardware device on this PC (ie chip-0) and no second graphic device which could mean chip-1 ? One can tell what graphic devices sax2 will see by typing:

sax2 -p

Thanks for your patience

Yes, you question is correct.

But there is only one graphic hardware device and
I tried sax -p and it indeed found only 1 device.

Surfing on the "*** Trying load detection on VGA0 … nothing*** " error, I did stumble across a couple of cases with nVidia hardware that suggested a power supply problem (supply was old and not putting out enough power)… although if you have this working with openSUSE-11.2 then that is likely not the case.

You could write a bug report against this: Submitting Bug Reports - openSUSE use your forum username and your forum password when logging on to the bugzilla bug reporting site. Note the SuSE-GmbH staff who will address the bug report will likely refuse to read a forum thread, … so you will likely need to include all the salient details in the bug report.

to try the fbdev driver:

sax2 -r -m 0=fbdev

… performance will be pathetic, but it may (or may not) help point to the problem.

fbdev delivered exactly the same not too satisfying result.

Sorry it took a little time (reboot from livecd, isntall sax, test take pictures, …

There are three pictures

in imagebam.com:
ImageBam - Fast, Free Image Hosting and Photo Sharing
ImageBam - Fast, Free Image Hosting and Photo Sharing
ImageBam - Fast, Free Image Hosting and Photo Sharing

Do they help?


Do they help ? Not really. What does

sax2 -p 


I note the puzzling error:

Sax: try to call sax2 -p and select a single device