11.3M3: Boot from RAID/LVM fails

Hello!

I upgraded my installation to openSUSE factory (11.3/M3) with zypper dup. Everything seemed fine until I tried to restart.
Grub appeared with the new kernel entries. I selected the normal startup entry and the splash screen showed up. When nothing did happen for about one minute, I hit escape to see what is going on. The following message was displayed over and over again:

 Reading all physical volumes. This may take a while.
   Volume group "vg00" not found ...
   Volume group "vg00" not found ...

vg00 is located on md1 (raid5) and contains /, swap and /home. My /boot filesystem (ext3) is located on md0.

I booted into the rescue system and checked that lvm2 and mdadm were installed. I can assemble the raid array in the rescue system. The volume group is mountable.

Because I could not find out what is wrong I first tried to update my installation with a 11.3 M3 DVD. When this did not help I formatted / and /boot with the installation tool and performed a fresh install. But I still get the same error.

I assume the raid arrays don’t get assembled. But I have no clue how to check this assumption.

What can I do to solve the problem or at least find the cause?

Thank you, goodbye.

Hi,

I just installed opensuse 11.2 64 bit on a machine, that I want to use as kvm base for some virtual machines. So I decided to mirror the whole hypervisor system in software in three mds(/boot, / and the rest, using lvm). The installation went well with no problem seen, but after a reboot, the system stops in grub, saying
root (hd0,0)
filesystem type unknown, partition type 0xfb
kernel …
initrd …
Cannot mount partition
Is there a way to boot from a mirrored /boot and /?
Will this be working in 11.3?
Thanks in advance

Dieter