11.3 x86-64 & vt1828s - No sound from mic or line in

I have just built a new system with an Asus p7p55d-e M/B. The on board sound support is a via vt1828s. I get sound from Flash, CD, DVD but not from analog mic or analog line in

The sound card is detected as 5 series/ 3400 series chipset HDA. I am not sure that this is the correct choice. Support for the VT1828 was added in kernel 2.2.33 and alsa 1.0.22. OpenSUSE 11.3 is up level from this and so the device should be supported.

I started YAST and selected add a sound card and searched for VT1828 and it is not in the list. The list does not contain any of the via chipsets that were added at the same time.

Does anyone know if the 5 series / 3400 series includes support for the VT1828? If it does, what do I have to do to get the analog input working? If it does not, which kernel module contains the support for the VT1828?

I also have a Logitech C310 webcam and get no sound from that. I do not know if this is a related problem. I am leaving the webcam sound problem until I fix the VT1828 problem.

I am using KMIX to as the mixer and I did deselect mute and set the volume to max. According to the multimedia system configuration, the general preferred capture device is HDA Intel (VT1828s analog).

I have found hundreds of things via google that indicate that it should work and some distributions seem to have had it working and then killed it with an upgrade. I have not found anything that tells me how to make it work.

I have been checking kernel modules, codecs etc. and the VT1828S has been recognized an the appropriate modules appear to have been loaded but I can’t record from the mic or line in. It is a new machine and there is always a possibility of a problem with the hardware. I downloaded the ubuntu 10.10 CD, booted from that and the sound worked without a problem. I have been comparing the ubuntu lsmod with the openSUSE lsmod. The openSUSE VT1828S codec is larger and I assume newer. The most visible difference is that ubuntu does not use ALSA OSS while openSUSE does. There is also another difference ubuntu is 32 bit & openSUSE 64 bit

The sound H/W is ALSA & Kernel supported. The VT1282S support was introduced with 2.6.33. The hardware works. There are no sound problems with ubuntu 10.10. What do I need to do to get the mic & line in working?

Check obvious first. Go into your volume control-mixer and make sure that the capture control is not muted and has volume set non 0. Note you may need to add the control from mixer settings

I would like to try and help, but I am not familiar with the details of this sound card, so to help me understand better so that I can provide some suggestions, I would need you to provide more information on your hardware and software audio setup. The information needed is documented in our multimedia stickie:

And I’ll quote the relevant section for you: Welcome to multimedia sub-area

… please post in this … sub-forum, providing in your post the following information:


and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/alsa-info.sh --no-upload

and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.

… some clarification on running the script “alsa-info.sh” … when you run:


you should get something like this (if it asks for an update, select NO):

followed by this (select the SHARE/UPLOAD option):

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :

followed by this (where in RED is the URL).

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/alsa-info.sh --no-upload

which will create the file /tmp/alsa-info.txt.  Copy that file and paste it on [Pastebin.com](http://pastebin.com) and press submit. That will give you a URL address. Please post that URL here.

**Also provide** the following:

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or newer
    , in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

For testing a mic, I recommend you use a terminal with this command:

  arecord -vv -fdat foo.wav

“foo.wav” is an arbitrary name I made up. Instead you could call it whatapain.wav or whichwaythewindblows.wav or anything …

Thanks for the reply,

The URLs are



I had already tried arecord then aplay and get nothing. I was about to write that there only seems to be a problem with line in and mic and that I could play DVD and CD without problems as well as Flash videos. Audio CD do not play with either kscd or amarok but they do with Kafine. I believe that Kafine uses Xine and Xine has the pulse plugin from pacman. I don’t know what Flash and firefox use. I did turn off mute and put CD volume to 100%

Pastbin will expire in a month. After having spent days trying to work out which hardware was compatible with openSUSE 11.3, ordering all the components, building the system, rebuilding the system software and installing, so far, the majority of the additional applications, I still have problems. I shall go to the cave and find a nice bottle of local red wine for tonight.

Ok, I note this, … a 64-bit openSUSE-11.3 with the nominal 1.0.22 and 1.0.23 alsa with the kernel. Your PC’s hardware audio codec is a VIA VT1828S.

Simple mixer control ‘Capture’,0
Front Left: Capture 23 [74%] [18.00dB] [on]
Front Right: Capture 23 [74%] [18.00dB] [on]
Simple mixer control ‘Capture’,1
Front Left: Capture 26 [84%] [22.50dB] [on]
Front Right: Capture 26 [84%] [22.50dB] [on
[b]Simple mixer control ‘Digital’,0
Front Left: Capture 1 [1%] -29.50dB]
Front Right: Capture 1 [1%] -29.50dB]
Simple mixer control ‘Input Source’,0
Items: ‘Stereo Mixer’ ‘Mic’ ‘Front Mic’ ‘Line’ ‘CD’
Item0: ‘Front Mic’
Simple mixer control ‘Input Source’,1
Items: ‘Stereo Mixer’ ‘Mic’ ‘Front Mic’ ‘Line’ ‘CD’
Item0: 'Mic’You have Input-Source-0 set to the “Front-Mic” (74% capture) and you have Input-Source-1 set to the “Mic” (84% capture). If it was me I would move them up to 100% (which WILL get distortion) and then once a very poor quality record/capture is established (with one’s voice) I would back off to a lower % level.

I note that the ‘Digital Capture’ is set to 1%, so if this happens to be a digital mic (and I don’t know what type of mic is in use) it won’t capture anything.

I note this from the arecord part of the script:


**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: VT1828S Analog [VT1828S Analog]
  Subdevices: 2/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1

What happens if you talk into the mic and try to record some 10 seconds of audio with:

arecord -f cd -D hw:0,0 -d 10 test.wav1


arecord -f dat -D hw:0,0 -d 10 test.wav2 

do you have any voice sound recorded ?

Reference installed alsa apps:

Those rpms look ok.

I assume you are using an externel mic because you built the system yourself, and you know this external mic to be good.

If worst comes to worst, there are updated alsa sound drivers/rpms available (on a special developer’s repository) that I can point you to, if need be.

I was wrong about asarok. It will play audio CD. I assumed that if you selected the menu item play with amarok then amarok woud start to play the CD. It does not, you then have to select the tracks to play. No inupt level control affects the volume. Only the output controls (front in my case with a headset) affects the volume. I think that with previous versions of openSUSE I could adjust both the input and output levels.

I am assuming that the mic is analog as it is part of a logitech headset with a 3.5mm plug. The headset has been used for SIP calls under Windows XP and was the headset used for testing recording under ubuntu 10.10. There is only one mic and that is the one attached to the headset. I do not know if this maps to mic or front mic or maybe something entirely different.

I get the impression from searching the internet that the VT1282S support introduced with 2.6.33 worked. There are many posts, mainly for ubuntu with an ealier kernel complaing that the VT1288S was not supported and in particular there was no recording. This appears to have be initially fixed by a backport and after that there were virtually no complaints. I ran the ubuntu live cd 10.10 and the recording worked without a problem. This makes me think that the problem is not a basic ALSA problem but more likely a problem with pulse or the interface between pulse and alsa. Looking at the current status on the pulse audio web site does not fill me with confidence. The VT1828S is in the newer ASUS motherboards and support was added to the kernel about a year ago. Unless the support has been backported, the openSUSE 11.2 kernel does not support the VT1828S hardware but I can see no complaints from opensuse users about the lack of support

I had already tried turning on the digital input. With the volume at 100% I get a little digital noise but nothing from the mic.

I have tried the 2 arecord tests you requested, with 100% volume and I got no recording.

I am going to have another look at the ubuntu configuration

If you think this pulse, then you could reboot to run level 3 (ie do NOT go to the gui) and login to the full screen text mode as a regular user. And then try the arecord from there.

I suggest this because I do not believe pulse is loaded at that stage (as I could be wrong).

Its always possible this is a bug in openSUSE-11.3’s alsa implementation. In which case you could try an update. I wrote a guide here how to update using an alsa developer’s rpms built for openSUSE: SDB:Alsa-update - openSUSE (note I need to update the kernel version numbers there in that wiki).

In your case that means updating your versions of alsa-utils, alsa-oss, alsa-plugins-32bit, alsa-oss-32bit, alsa-plugins, alsa, and libasound2. Please check your alsa packages versions after you ‘think’ you updated. If the versions have not changed, then you failed to update. Please note the images in that alsa update wiki. I put them there specifically so users would not get confused about their update versions.

You may also need to install alsa-driver-kmp-desktop.

A reboot afterward will be needed.

I think I might have got things the wrong way round. I looks as if ubuntu uses more of pulse than openSUSE and has the .22 release not the .21 that is in openSUSE. The alsa level looks more or less the same, .23 + or - some bits at the end.

I had another look at ubuntu. The kernel is 2.6.35 but support went into .33. When trying to record on ubuntu, sound preferences says analog mic 1. All works without a problem. I ran amixer and the output of amixer seems not to be related to what is actually happening. Both mic & front mic are 0% and off. The sound preferences dialog indicates that it is using analog stereo input and output. Both systems seem to be running more or less the same level of ALSA and ALSA & the kernel support the VT1828S. The systems do seem to be configured differently with more use of PULSE in ubuntu. I would guess at a configuration problem, either a general one in that analog recording just does not work or possibly the second sound card ( Geforce 240 graphics HDMI ) has confused the configuration process.

I have had too much red wine I shall go to bed

Bonne soirée

Note the SuSE-GmbH packager for sound is also one of the main alsa developers. The repository that goes with the alsa updates (wrt the links in the alsa update wiki, the link of which I provided) are maintained by him. He has the most cutting edge alsa updates there, and the alsa-driver-kmp-<kernel> rpms replace a number of the sound kernel modules on one’s openSUSE. Hence I do believe you should try that update.

I have an old Toshiba laptop with openSUSE 11.2 X86-64 installed and I tested that with the headset and mic used on the 11.3 system. I got this to work. It has a conexant sound chip. The audio was comming in on the default digital channel and I assume that there is an A/D converter in there. I booted the openSUSE 11.3 X86-64 live CD. Did an lsmod and the conexant codec was loaded and did the test with arecord. I did get a recording but there is quite a bit of background noise, the recording sounded as if the signal was being clipped and the volume was so low I could hardly hear it. The Kmix interface has changed again so I am not 100% sure that I did exactly the same thing on 11.3 as I did on 11.2.

The new system was built with a complete repartition and format of one disk, followed by the install, then a restore of a dar dump of some partitions. The other disks were moved from the old machine to the new machine. This move included the home file system. Just in case there was a problem with KDE and its aversion to handling old parameter files, I tried the test on a new ID, that also failed to record.

I shall try the old 11.1 system with the openSUSE live CD. This system has been overwritten with Windows 7 Home Premium so I can’t test it with openSUSE 11.1. It has yet a different chipset

I will consider trying the alsa upgrade. However ALSA 1.0.23 is the current version of ALSA and 1.0.23 is in both Opensuse 11.3 and ubuntu 10.10. Assuming that niether openSUSE nor Ubuntu have changed the ALSA code, the problem is not with the ALSA code. If there was a problem with the ALSA code I would expect to see complaints posted on the internet as can be seen during September 2009. I believe that the VT1828 support was added by someone from openSUSE arround the end of september 2009. One reason that I rebuilt the system rather than upgrading it was that the 11.1 system contained many changes from the default 11.1 software and I was concerned that an upgrade and hardware change would take more effort than a rebuild. I would have kept the 11.1 system but the support for the core i5 760 and the VT1828 appear to require the kernel in 11.3.

You will have to trust me in this … the version of 1.0.23 that you have with Ubuntu and openSUSE is OLD and not as current as the cutting edge one packaged by the openSUSE packager who is also an alsa developer.

I do trust you but I also like to try to understand the problem, if I can, before I resort to upgrading software that could possibly cause other problems or use the windows support solution of reinstalling the OS.

I tried the test on the 3rd system. This one has a realtek chipset. I was able to record. The recording level was too low but much better than on the laptop. On the 2 old systems the recording seemed to be via the default digital input and the mic controls seemed to have no effect.

This appears to be a general problem with recording levels in openSUSE 11.3. My old laptop is now 4 years old and sound recording works with 11.2 but not 11.3. I shall leave my laptop at 11.2 and use that for any sound recording. I think that I shall report this as a bug. At least for the moment, I shall resist your attempts to get me to upgrade ALSA and wait and see what comes out of the bug report. There seems to be some issues around kmix and pulsaudio.

Thank you for all your assistance

I have found the problem at least for the VT1828S. See Bug 639592. You have to turn off smart 5.1 to get recording to work. Inputs apparently get reassigned to outputs when smart 5.1 is enabled. Unfortunately the smart 5.1 control does not even appear by default in the Kmix display and has to be added from the configure channels menu.

Indeed, that bug https://bugzilla.novell.com/show_bug.cgi?id=639592 and the solution is pretty obscure for anyone who does not have that hardware.