11.3 won't boot without CD Macbook pro

One my macbook pro I have previously had 11.1 and Kubuntu Lucid working (mostly) fine*.

I tried 11.3 - the install went fine but now the machine will not boot from the HD. The only way
I can get it to boot is via the CD. The best diagnosis I can make is that the installation screwed
up the partition table such that I cannot make refit gptsync. Simple put the GPT/EFI partition
table (which is required to boot the mac) is out of sync with the MBR partition table (required
by grub to boot suse 11.3). I have tried various disk tools from OSX, refit and linux (parted) and
none makes any difference (parted is ignorant of the problem, OSX disk tool doesn’t know about
linux partitions, bootcamp won’t touch the disk and refit says “analysis inconclusive, won’t touch this disk”).

It looks like I am screwed and will have to reformat the disk before reverting to lucid.

Does anyone have any ideas? I have searched extensively and found many reports of similar problems in 11.2 but no solutions.

SA

  • 11.1 - no screen dimming, no sound, no wireless, no fn keys, poor trackpad, screen ok under kde 3

lucid - mostly everything worked except for an infuriating “krandr” type problem when using an external screen for presentation (krandr etc were turned off but the screen kept trying to resize during movies). sound ok, screen dimming ok, fn keys ok, trackpad ok, wireless ok. Transition
kernel too old for comedi

11.3 - no screen dimming, no fn keys, no wireless and won’t boot, runs hot, short battery life.

Usually the default boot device is determined by the BIOS. Try setting it to boot from hard disk in the BIOS.

It is a mac - not a PC the “BIOS” doesn’t come into it.

The mac is set up using refit - this handles the efi boot process and, if linux is selected, it hands control to grub but… grub only understand mbr partitions and the disk is gpt. So refit provides both (and a tool to sync them gptsync). The problem is the SUSE installer screwed this up so bad that I cannot get the EFI and MBR partition tables sync’d so grub can’t find the system to boot and reports “no bootable disk” unless the SUSE dvd is in place when it boots off the DVD

OK, have a look at this site:
http://polishlinux.org/reviews/macbook-and-linux-beauty-and-the-beast/
It seems to say you need to reformat the hdd, though.

There used to be an sdb article on mac installs, but I can’t find it after the new site layout.

whych - yep done all of this stuff plus a whole lot more (I’ve had linux on various macs for years). The simple conclusion is the problem lies with suse (11.2 and 11.3 seem affected) and there seems to be no fix.

After two days of arsing around with this I reverted to a clean install of kubuntu lucid. Not only was it somewhat slicker and faster than the suse install but it fixed the disks and everything works first time (I can dim the screen, the net just worked, the volume worked etc etc).While I’ll miss yast I think it is preferable to have a machine that boots and where the basic things work without a fuss.

My remaining problem (how to stop the external screen blinking when movies run) is probably a generic kde4 problem which may well have affected suse anyway so I may not be missing out on anything and I certainly seem to have gained a lot.

This is discouraging, I have been messing around with a new 11.3 install on my 2.1 MacBook Pro with the same trouble. I’ve had good experiences with Ubuntu on my Macs, too. Maybe I should toss in the towel on the SUSE install…