11.3 - Unable to reach outside local network with networkmanager. Ifup works.

Hi,

I did a fresh installation of 11.3 yesterday (tried both KDE live and DVD versions, the latter is on the computer atm). Install was uneventful with the exception of the wireless network.

Using networkmanager (either with the plasmoid or knetworkmanager applet frontends) connects fine to the local network but is unable to reach outside the gateway. I.e. I am unable to reach the Internet. Shifting to ifup (configured in Yast) fixes this. My guess, although I am by no means knowledgeable in this area, is that somehow networkmanager is unaware of the gateway address. Since this is a laptop which I use in many different wireless networks using networkmanager is highly preferred over ifup.

I did not have this problem with 11.1 or 11.2.

I would be grateful for any suggestions that could lead to a solution. (Googling has not been helpful.)

Sidenote: the mobile broadband, Swedish Tele2, also ceased to connect after upgrade from 11.2 to 11.3. I will see if an upgrade of modemmanager may help.

cheers,

/micke

Lenovo X61s
OS: Linux 2.6.34-12-default i686
System: openSUSE 11.3 (i586)
KDE: 4.4.4 (KDE 4.4.4) “release 2”

Use the command “sudo rm /etc/resolv.conf” and remake the connection. Sometimes,
DHCP gets confused and thinks you made a local modification and will not
overwrite it.

Thanks for the advice, but no luck. Same behavior - with networkmanager, pinging an IP outside the local network results in “connect: Network is unreachable”. There is no problem using ifup. (Pinging within the local network works fine with either.)

/micke

Please post the output of


cat /etc/resolv.conf
/usr/sbin/iwconfig
/sbin/ifconfig


micke@mw-X61s:~> cat /etc/resolv.conf
### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search lan
nameserver 192.168.0.254

micke@mw-X61s:~> /usr/sbin/iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"Widersten"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:17:3F:EC:17:A9   
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=44/70  Signal level=-66 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

pan0      no wireless extensions.

micke@mw-X61s:~> /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1D:72:82:BF:7B  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Memory:f8200000-f8220000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:354 errors:0 dropped:0 overruns:0 frame:0
          TX packets:354 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:25416 (24.8 Kb)  TX bytes:25416 (24.8 Kb)

pan0      Link encap:Ethernet  HWaddr D6:79:C7:73:78:86  
          inet6 addr: fe80::d479:c7ff:fe73:7886/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:936 (936.0 b)

wlan0     Link encap:Ethernet  HWaddr 00:1D:E0:94:90:A7  
          inet addr:192.168.0.68  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21d:e0ff:fe94:90a7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:58971 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38497 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:61026581 (58.1 Mb)  TX bytes:7840073 (7.4 Mb)

This was the output when using ifup. If you think there may be a difference with networkmanager I can go offline and post those in a while.

Thanks for your help in the matter.

/micke

There is nothing in there to indicate any error.

I did some more tests:

(1) at init 3 you get the same behavior. To me that indicates that it is not the KDE frontend(s) that are at fault but networkmanager itself, or its configuration.

Are there any repositories for 11.3 that supply older/more recent versions of NM that could be tried?

(2) Shifting from ifup to NM in YAST and restarting the network crashes the KNM applet at the stage of “Write Firewall Settings”. Restarting the KNM applet works fine and you get connected to the local network (but not to the outside world).
This happens sometimes. If not, (3) is observed.

(3) Shifting from ifup to NM in YAST and restarting the network gives the error message “No Network Running” at the stage of “Activate Network Services”.

I am lost.

/micke

I am having the exact same issue. I was connected to the wireless for quite a while yesterday, but I am having no luck today. I had no issues with the wireless in 11.2.

I think I have found a clue. /sbin/route -n gives the following responses:

using ifup:


micke@mw-X61s:~> /sbin/route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 wlan0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.0.254   0.0.0.0         UG    0      0        0 wlan0

Here the gateway is properly given as 192.168.0.254

The same output when managed by NM:


micke@mw-X61s:~> /sbin/route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo

Here the wlan0 gateway is lost.

How do I tell NM the correct gateway address.

/micke

I have the same problem… the default gateway is not set via dhcp. i tried both wireless and wired connections to my internet router. the result is the same. everything works fine except setting the default gateway.

thanks in advnce for any help…

promm

A quick solution just to get it work: issue the command

route add default gw xxx.xxx.xxx.xxx (insert the ip-address of the default gateway)

as root.

should work automagically though…

prommi

Yep, that works. But it is really only useful when I know the gateway IP and sort of removes the whole idea of NM facilitating movement between different wlans.

Thanks anyway.

/micke

In my first post in this thread I indicated that my mobile broadband had also failed after the upgrade from 11.2 to 11.3. It didn’t… I had mistyped the APN. It actually works quite nicely.

/micke

bugzilla:

https://bugzilla.novell.com/show_bug.cgi?id=623409

seems to be the same problem.

Thanks for the info. It certainly appears to be the same symptoms. I will follow the progress of this bug with keen interest. The 3rd comment points towards possible problems with the dhclient.

/micke

I just want to point out to anyone suffering from bug 623409 that it may have been solved now. I tested the latest patches and the correct route is now set upon connection also by NM. The bug has not yet been RESOLVED=FIXED so there may still be issues but at least for me things are now hunky dory.

/micke

Lenovo X61s openSUSE 11.3 32 bit
KDE 4.4.95

Hi,

Not a solution but a work around. You can set the connection to a static IP. Right click on the network manager icon, select edit connections, select the connection that doesn’t work and click on edit. Click continue until you got the screen to set up the static IP and fill in the form after activating static IP.

As far as I know network manager should work without problems if the static IP is switched off. It also should make a correct DHCP handshake and ask for all informations that are needed. As ifup works on your system your DHCP server works correctly. Also the failure is seen on two machines. Bug report?

Bye

Erik

If ifup is working correctly, why not just install WICD, see if that works properly and then ditch NM.