11.3 RC1 kde4 default - Missing powersave features

Did a default install kde4 desktop from the x86 DVD
Seems to be missing suspend etc…
When on battery etc… is greyed out

No suspend option in the profile setting ‘when laptop lid is closed’

I noticed that on RC1 KDE installed from liveCD, but as I’m on a desktop that seemed ok. Normally I get that stuff not greyed even on a desktop pc.

I decided to add in gnome as well and it all came to life. Guess I’ll have to start again from scratch to double check this, but I suspect a bug here. Before I installed gnome I checked the packaging and it seemed correct for kde.

It all seems to be working on my laptop .

Advent 8112; intel T5250, 965GM 2GiB. openSuSE-11.3-rc1 x86_64 DVD

KDE-4.4.3 system settings > Advanced > Power Management.

Interesting - Thanks

On KDE, before adding Gnome, did you install the “hal” package for the HAL daemon as mentioned in the other thread on USB mounting (in this forum)?

Had the same issue, installing the hal package enabled powersaving on my dell laptop.

No, looks like that’s the answer then.

I have now added LXDE and it’s rockin’ too.

That’s interesting because I also have installed the hal package, and the battery stuff is still greyed out, as it should be on a desktop pc.

I’ll have the ‘Laptop’ pattern installed of course.
I’m too tired to dig in to it now. Must crash, been up and at it since 2.30am

I see the greyed out settings on a desktop, but not on the laptop (both 11.3-rc1 64bit upgraded from 11.2 via 11.3-ms5 and 11.3-ms7 using DVD iso).

It did not change things on the desktop when I installed the
The desktop shows “Batteries 0”, whereas the laptop “Batteries 1”