11.3 Nvidia FX5500 driver problem (173.14.25)

I tried to install the nvidia driver using the hard way, but I get an error when I try to use the driver and X doesn’t start:

    37.911] (EE) NVIDIA(0): This video driver ABI is not supported.
    37.911] (EE) NVIDIA(0): Use the -ignoreABI option to override this check.
Fatal server error:
    38.149] AddScreen/ScreenInit failed for driver 0

I tried putting this in my xorg.conf, but I still get the same error:

Section "ServerFlags"
 Option "IgnoreABI" "1" 

I uninstalled the driver and I use the nouveau driver now, but it’s really slow.

System info:

uname -a

Linux linux 2.6.34-12-default #1 SMP 2010-06-29 02:39:08 +0200 i686 i686 i386 GNU/Linux

lspci | grep VGA

01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500] (rev a1)

Intel P4 Prescott 3GHz HT, Asus P4P800 motherboard.

Does anyone know how to solve this?

Do you get this error when you install the driver the hard way or does the install go OK? Does this error only occur when you try to run startx? The option -ignoreABI looks like a run time option you might add to the driver installation line, but I have never see this error. Have you read the very fine article by oldcpu at:"

SDB:Configuring graphics cards - openSUSE

When I install the latest video driver during openSUSE installation, I am doing the following items:

  1. During the install, when you have the option to change your booting setup, I add nomodeset to the kernel load command for the normal load/start of openSUSE. This kernel startup option is already present for the Failsafe selection for openSUSE.
  2. During the first start of openSUSE, I download the latest nVidia Video driver to the downloads folder.
  3. I change/save the System/Kernel option NO_KMS_IN_INITRD from “No” to “Yes” in the /etc/sysconfig Editor in Yast.
  4. I do an update of openSUSE on the first run of openSUSE and then a restart/reboot.
  5. In grub OS selection I add the command line option “3” to the openSUSE start line so that I just go to the run level three terminal prompt.
  6. I login in as root and change to the /home/user/Downloads folder.
  7. I run/install the NVIDIA video driver using “sh ./NVIDIA-Linux-x86_64-256.35.run” and answer all questions as appropriate for my system.
  8. Type in reboot at terminal prompt to restart the system with new video driver.

Thank You,

The -ignoreABI option is for the ‘startx’ command. Like this:

startx-- -ignoreABI

So you boot into runlevel 3, then you start X with the above command. It doesn’t go in xorg.conf, and it’s for the nvidia driver, not nouveau.

The -ignoreABI option is for the ‘startx’ command. Like this:

startx -- -ignoreABI

So you boot into runlevel 3, then you start X with the above command. It doesn’t go in xorg.conf, and it’s for the nvidia driver, not nouveau.

Indeed this is what I have been doing since around Milestone5 or so.

One boots to run level 3 and types in run level 3:

startx -- -ignoreABI

I put a ‘3’ in my /boot/grub/menu.lst so that I don’t forget to boot to run level 3.

Note you may need to add your regular user to group ‘audio’ in order to restore sound (restart to test this), when you have this driver problem.

You also may (when you have this driver problem) need to shutdown with a terminal by typing:

su -c 'shutdown -h now'

This is caused by the legacy nvidia driver and nVidia are puportedly working on a fix:
New Xorg 1.8 and nvidia-173.xx support. - nV News Forums

Edit: Don’t forget to follow jdmcdaniel3’s advice re: yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. And you may also wish to black list nouveau driver in /etc/modprobe.d/50-blacklist.conf … guidance for all this is here: http://wiki.opensuse.org/SDB:Configuring_graphics_cards

Thanks for your help. “startx – -ignoreABI” did the trick.
Is there any way I could automate this? My girlfriend uses this computer from time to time, so it would be nice if it would start in X and with auto login.

A new pre-release driver for ‘legacy’ Nvidia cards was just released 173.14.75 (legacy prerelease) for Linux x86/x86_64 released - nV News Forums . I just tried in on 11.3 and it works fine, no need for the ignoreABI workaround.

Thanks! The new driver works.
Problem solved. :slight_smile: