11.3-M7 installs ok, won't boot

I’ve downloaded and installed the latest 11.3-M7 KDE 32bit using a live cd, it installs ok with no errors at all, the post-install config runs ok but after it reboots I don’t get a login screen.
There’s just a blank screen with some garbage on the lower right corner, I can’t ctrl+alt+f1 either, the system appears to be frozen.
When I press reset I get a terminal window on a blank screen after rebooting (no failsafe, normal boot) and I can run some gui programs (like yast2) from there but no desktop, no window manager, nothing!
I guess it may be a nouveau related problem since my gfx card is a nVIDIA 8800 GS.

Any help?
Thanks in advance!

System specs:
Mobo: Asus M4a785TD-M EVO
Proc: Athlon II x2 245
RAM: 2gb DDR3 1333
Video: nVIDIA 8800 GS 384 RAM

PS: I used to have ubuntu installed (7.04~10.04), it’s my first time trying openSUSE.

11.3 milestone-7 intial look on various PCs - openSUSE Forums

Building/installing nVidia Proprietary Video Driver in MS7 - openSUSE Forums

Still can’t boot to desktop even after blacklisting and uninstalling the nouveau driver. Since I can run gui programs from this terminal interface I’m downloading the nvidia .run driver at the moment to try installing it.

Remember the pre-requisites like: make, gcc, kernel-source

Blacklisted nouveau driver. Didn’t work, same problem.
Uninstalled nouveau driver. Same problem.
Downloaded and successfuly installed nvidia .run driver. Same problem, lower resolution.

Any sugestions?

You say you don’t get a login screen, so I can assume you don’t have auto login enabled?
Was this a clean /home partition ?

I assume you have been booting to level 3 to install the nVidia driver

Auto login was enabled during install.
Nope, not a clean /home, I used to have Ubuntu 10.04 32bit (Gnome) installed before installing openSUSE.
I boot into failsafe in order to install the driver, it installed fine but I still get thrown to this terminal screen, no DE =/
(now on a lower resolution than before installing the nvidia drivers)

PS.: Installing kernel-source created a new entry on my bootloader to a “kernel 2.6.34-8”, installed nvidia on this kernel too and still get the same problem.

Re-install and format everything.
Otherwise we are dealing with an unknown quantity,

Thanks for the help but that’s not an option since my home folder is full of personal files. I’m sticking to Ubuntu then.

The weird thing is that I can run nvidia-settings just fine (it reports the driver is installed ok), kwin --replace gives me windows border and everything seems to be working fine except it’s all a blank screen and a terminal window =/

You could try level 3 boot
login as user then do

mv .kde4 .kde4-old

Just in case there is a old .kde4 in there. It may help.

then try again

I just had the same idea but went ahead and cleaned up all dot files and folders from my home partition and now I’m re-installing openSUSE for what I hope to be the last time.

Processor: 2x AMD Athlon™ II X2 245 Processor
Main Memory: 2 GB
Format partition /dev/sda1 (14.01 GB) for / with ext4
Use /dev/sda5 as swap
Set mount point of /dev/sda6 to /home
Boot Loader Type: GRUB
Status Location: /dev/sda1 ("/")
Change Location:
Boot from MBR is disabled (enable)
Boot from “/” partition is enabled (disable)

  • openSUSE 11.3 (default)
  • Failsafe – openSUSE 11.3
    Keyboard Layout
    Portuguese (Brazil)
    Time Zone
    Brazil / Sao Paulo - Hardware Clock Set To Local Time 2010-06-10 - 01:55:52
    Default Runlevel
    5: Full multiuser with network and display manager

That’s official: openSUSE hates me! =(

You give in way too easily

I bet it’s not a beta release you are using in Ubuntu, which is what M7 is really!

You’re right, it isn’t but I’ve been using this version since the Beta2 release and I’ve never encountered any problems.
Anyway, thanks for all the help, maybe I’ll give openSUSE a try when the final version is out.