11.3 M5 x64 - How I Got Here (and a non-nV display bug)

I finally managed to get 11.3 M5 x64 in place (by upgrading from 11.2 x64, which took two hours and over 1100 packages); however, there is one rather frustrating display issue (a reversion, actually) - neither the radeon or radeonhd FOSS driver will work with my AMD HD3450 PCIe graphics card, whether modesetting is enabled in the kernel or not. (The driver notes say to turn KMS off in the kernel; however, the default is to leave it on.) I’ve been forced to drop back to the vesa driver for decent performance; however, I can’t use the upper range of my monitor’s resolutions (nothing past 1400x1050 is available to my Acer H233H FP display, despite the DVI-D connection).

Is the Linux Catalyst driver even an option? (Because of the kernel’s newness, I have my doubts!)

My guess is the way you installed (as an update as opposed to a fresh intsall) caused the problem.

I booted my Dell Studio 1537 laptop with a Radeon HD3450 graphic hardware to the 11.3 M5 live CD and the radeon driver worked superbly by default. No tuning needed. No tweaking needed. It just worked. I double checked the /var/log/Xorg.0.log created by the liveCD (while running) and confirmed the radeon driver was being used.

As every one knows, M5 has installation issues.

Rather than waste time on M5, I recommend you wait a few days and try M6. The revised date for M6 to be released is now 29-April. Roadmap - openSUSE

oldcpu, I did it that way because I could not get M5 x64 to install any other way (no liveCD would boot, and no DVD or even NET DVD would install). The liveCD (KDE) would invariably crash, and NET install would bork on the usb-storage driver (and it certainly didn’t help that both keyboard and mouse are USB). I tried different burn speeds, different burn software, and even tried burning in another distribution (or in Windows) as well as different media. I am hoping that M6 is a better representative.

Indeed M5 had major installation problems. I suspect the difficulties I had were also the same you encountered. I succeeded in the end but it was not easy. I documented my efforts here: openSUSE Forums - View Single Post - Milestone 5 ISOs available for download

… I also am more hopefull that M6 will be better. Clearly there are problems with M6 , which is why its release has been delayed from 22-Apr to 29-Apr. Hopefully the delay will help solve what ever blocking problems exist in M6.