11.3 KDE Login Time Is Slow

Anybody else experiencing slow login times with 11.3 KDE? It’s taking 40 seconds from the login screen to the desktop.

It’s a clean 64-bit11.3 KDE install.

I tried creating a new user and had the same problem.

It’s marginally faster than 11.2 on my 32-bit bottom of the market system at 25-30 secs.

I should mention that it took under 10 seconds in 11.2.

I have the same problem with OpenSuse11.3 x86_64. The .xsession-errors file contains:

kded(3837): Communication problem with  "kded" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." " 

My 11.3’s KDE login time is almost the same as the 11.2’s KDE… But gnome login is pretty slow than the one I’ve seen on 11.2…

I had the same error message. It went away after I disabled Powerdevil (Configure Desktop > Service Manager). Now my login time is under 5 seconds.

That fixed it here too. Thanks.

Let’s get some info to figure this out.
What are your systems specs?
Check your log messages.

I remember when KDE3 had this issue. It was due to DCOPserver. Check KWin as well.

I checked further with #opensuse-kde as they are the openSUSE KDE developers, and they pointed me to a bug filed in bugzilla. https://bugzilla.novell.com/show_bug.cgi?id=624989 Looking at the logs provided in that bug report, it seems to be a dbus connect. What is recommended is going to Personal Settings>Advanced User Settings>Service Manager and disable kded service modules.

Again, with out your logs and such, it’s impossible to nail this down any better.

After pressing enter on the KDM screen, the screen can stay black for a period that feels like about a minute, then the normal process commences. I’ve yet to investigate. It’s a bit of a pity because boots using upstart are much faster, but I’m losing the gain on login. I’m not sure there is always a delay.