11.3 KDE 45 to 11.4 RC1

Hi,

I am running 11.3 with KD45. To upgrade to 11.4 RC1, I have added the factory oss and non-oss repos.

When I disable the following repos 11.3 oss, 11.3 non-oss KDE45 and KDE45 Extras I get the following issues when I try to run zypper dup:

20 Problems:
Problem: libxine1-codecs-1.1.19-2.pm.48.16.i586 requires libcdio.so.10, but this requirement cannot be provided
Problem: vlc-noX-1.1.7-1.pm.3.4.i586 requires libdirectfb-1.2.so.9, but this requirement cannot be provided
Problem: vlc-noX-1.1.7-1.pm.3.4.i586 requires libdirectfb-1.2.so.9, but this requirement cannot be provided
Problem: wxWidgets-gl-2.8.10.1-2.pm.20.17.i586 requires wxWidgets = 2.8.10.1, but this requirement cannot be provided
Problem: libwebkit-1_0-2-1.2.6-0.2.1.i586 requires libicui18n.so.42, but this requirement cannot be provided
Problem: vlc-noX-1.1.7-1.pm.3.4.i586 requires libxml2.so.2(LIBXML2_2.4.30), but this requirement cannot be provided
Problem: llvm-clang-2.7-1.pm.1.9.i586 requires python(abi) = 2.6, but this requirement cannot be provided
Problem: libMagick++3-6.6.1.0-4.1.1.i586 requires ImageMagick = 6.6.1.0, but this requirement cannot be provided
Problem: libwebkit-1_0-2-1.2.6-0.2.1.i586 requires libicui18n.so.42, but this requirement cannot be provided
Problem: libxml2-python-2.7.7-3.7.i586 requires python(abi) = 2.6, but this requirement cannot be provided
Problem: libxml2-python-2.7.7-3.7.i586 requires python = 2.6, but this requirement cannot be provided
Problem: libxml2-python-2.7.7-3.7.i586 requires python = 2.6, but this requirement cannot be provided
Problem: libxml2-python-2.7.7-3.7.i586 requires python(abi) = 2.6, but this requirement cannot be provided
Problem: libxml2-python-2.7.7-3.7.i586 requires python = 2.6, but this requirement cannot be provided
Problem: libxml2-python-2.7.7-3.7.i586 requires python = 2.6, but this requirement cannot be provided
Problem: python-qt4-4.8-2.16.i586 requires python = 2.6, but this requirement cannot be provided
Problem: libxml2-python-2.7.7-3.7.i586 requires python = 2.6, but this requirement cannot be provided
Problem: libxml2-python-2.7.7-3.7.i586 requires python = 2.6, but this requirement cannot be provided
Problem: libxml2-python-2.7.7-3.7.i586 requires python = 2.6, but this requirement cannot be provided
Problem: libxml2-python-2.7.7-3.7.i586 requires python = 2.6, but this requirement cannot be provided

Enabling KD45 and KDE45 Extras does not help.

Only if I enable 11.3 oss and non-oss, no problems are found by zypper dup. Will this be a correct way to upgrade? Any other idea?

Thanks,

heg

I don’t recommend you proceed with your plan
Your issue is related to some packman packages.

You didn’t mention if you have a packman repo enabled and whether for 11.3 or factory? Are we supposed to assume your 11.3 system is 32bit?

Indeed is a 32 bit system and I have packman Index of /suse/11.3 enabled. Should I disabled or changed to a different one?

On 02/12/2011 02:36 PM, hegheg wrote:
>
> Hi,
>
> I am running 11.3 with KD45. To upgrade to 11.4 RC1, I have added the
> factory oss and non-oss repos.
>
> When I disable the following repos 11.3 oss, 11.3 non-oss KDE45 and
> KDE45 Extras I get the following issues when I try to run zypper dup:

Change packman to packman factory

Vahis

http://waxborg.servepics.com
openSUSE 11.4 RC 1 (x86_64)
2.6.37-20-desktop

IIRC there was a Factory version of packman repo, but it may only be a subset containing enough packages to facilitate testing. Also check for an 11.4 version, but maybe it’s too early for that.

In the past I have done it by disabling all repos except the new (11.4) Oss and Non-oss, and zypper dup took care of all vendor changes. You should end up with a system nearer to a fresh install of RC1 (if that’s what you are aiming for, including risks). Then add a packman repo (Factory or 11.4) and manually update package by package, so you understand what happens at each step, given an incomplete packman repo. Alternatively for packman repo, you could try the “switch packages” feature in Yast and work through any problems.

Either way don’t expect everything to go according to plan - it’s pre-release. :slight_smile:

It worked. Thanks