11.3: how to get good fonts in Gnome?

I have used a patched Cairo in 11.2 from Packman and the fonts were excellent. Now I upgraded to 11.3 and installed freetype from subpixel repo. While I have good fonts in Qt now, in Gnome still they are bad. There is no patched Cairo in Packman for 11.3 Installing the patched Cairo for 11.2 from Packman and from Ubuntu-patch project did not help :frowning:

there is a way to take all fonts of M$windows in kde .Just u have to point the location in .certainly there has to be a similar way

Of course MS fonts would not help, but I solved my problem.

In addition to patched Cairo one should place this file http://www.infinality.net/files/local.conf into /etc/fonts

Hi, where did you get the patched Cairo from? Thanks!

http://software.opensuse.org/ymp/home:anshuljain:ubuntu_patch_11.3/openSUSE_11.3/cairo.ymp

The cairo mentioned by Ansus above is from my repo :slight_smile: I’ve created an set of instructions on how to get better fonts using the patched cairo, freetype and fontconfig rpms in this post :- Subpixel Hinting Packages (Ubuntu Lucid Patches) are now available for 11.3

Hi, thanks to both of you!

What about for KDE? Is this the best repo for subpixel hinting?
Index of /subpixel/openSUSE_11.3/i586/

Yes, patched freetype is needed for both KDE and Gnome.

I’ve created an set of instructions on how to get better fonts using the patched cairo, freetype and fontconfig rpms in this post

I did not follow your instructions, just copied http://www.infinality.net/files/local.conf into /etc/fonts and have good fonts.

Lack of proper font rendering is silly in this wonderful distribution. Not being a linux novice I still find it difficult to follow some of the instructions. What are the main steps: 1. patched Cairo 2. special file in etc and 2. free2 fonts? Am I right. yours Marek

Thanks for this, this worked perfectly for me to get my GTK apps (including firefox) to enable subpixel-hinting.

To summarise for people looking to get this working:

  1. Follow the instructions from here for installing the packages plus KDE: SubpixelHinting - openSUSE Community Wiki
  2. Then put the local.conf file linked above in /etc/fonts and logout then log back in and you should be set for both GTK and QT apps

Is that in some way related with KDE apps not being able to render jmk bitmap fonts correctly (should say ‘at all’) ? I have this problem for the first time, only in openSUSE 11.3 (not other releases, not other distros) and only in konsole (not in gnome/xfce or other xterms).