11.3 Compiz won't start

Compiz installed from Index of /repositories/X11:/XGL/openSUSE_11.3 for opensuse 11.3 - kde - 64 bit

When I start compiz via simple ccsm nothing happens. When I start fusion-icon from console I get following output:

user@linux:~> fusion-icon 
 * Detected Session: kde
 * Searching for installed applications...
 * NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
 * Using the GTK Interface
 * Starting Compiz
Traceback (most recent call last):
  File "/usr/bin/fusion-icon", line 58, in <module>
  File "/usr/lib/python2.6/site-packages/FusionIcon/interface.py", line 89, in choose_interface
  File "/usr/lib/python2.6/site-packages/FusionIcon/interface.py", line 35, in import_interface
    __import__('FusionIcon.interface_%s' %interface)
  File "/usr/lib/python2.6/site-packages/FusionIcon/interface_gtk/__init__.py", line 3, in <module>
    import main
  File "/usr/lib/python2.6/site-packages/FusionIcon/interface_gtk/main.py", line 213, in <module>
  File "/usr/lib/python2.6/site-packages/FusionIcon/start.py", line 34, in init
  File "/usr/lib/python2.6/site-packages/FusionIcon/util.py", line 154, in start
    run(self[self.old].killcmd, 'call')
  File "/usr/lib/python2.6/site-packages/FusionIcon/execute.py", line 41, in run
    exitcode = subprocess.call(command, stderr=subprocess.PIPE)
  File "/usr/lib64/python2.6/subprocess.py", line 480, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib64/python2.6/subprocess.py", line 633, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.6/subprocess.py", line 1139, in _execute_child
    raise child_exception
OSError: [Errno 2] Bestand of map bestaat niet

any ideas what is wrong?

Please don’t advice me to use kwin desktop effects. I really want compiz.

Ok it seems that I can get compiz itself to work by executing compiz --replace and emerald --replace in a terminal.

But I can’t get the fusion-icon to work. Any idea’s?

And it also seems that compiz configuration doesn’t work. If I change some settings in ccsm like minimize effect, it does not apply…

It seems to work when I set following command as auto start.

compiz --replace --sm-disable --ignore-desktop-hints ccp

After that commando is done, I can also start fusion-icon from a terminal! But how can I get fusion-icon to start at kde startup? Why doesn’t it work then??

Have you tried editing the /etc/X11/xorg.conf?
If it contains a this section:

Section “Extensions”
Option “Composite” “off”

edit it to

Section “Extensions”
Option “Composite” “enable”

then restart and it should work. When installing the nvidia driver this section is added to the file for some reason.

Be careful when editing xorg.conf though, first make a backup :wink:

good luck

Have you turned off Desktop Effects?

Can’t help you with fusion-icon but I’ve tried compiz on 11.3_64 and it’s working.
If you already have configuration files, copy them to /home/user/.config/compiz/
Then just open systemsettings (KDE personal settings) and setup default applications.


Cool! I didn’t know you could do that. I am starting compiz by putting the fusion icon in Autostart. That works fine, too.

A bit offtopic, compiz-kde4-0.8.6-49.1.x86_64.rpm is missing in /X11:/Compiz/openSUSE_11.2/

This package can be found in /X11:/Compiz/openSUSE_11.3/ and without it, compiz will pull compiz-gnome.
Then compiz-gnome will pull a dozen other packages and create a mess.

Just tested this one on 11.2 kde 4.5 and it works. No idea why it’s missing from 11.2 repo.

hello, friends…
i’m trying to get fusion-icon to run on startup, too.
however, i dont know where to go to have it run through Autostart, as JJMT said…
could anyone educate me on this, or whatever will have my settings setup…?

Configure Desktop -> Startup and Shutdown -> Autostart -> Add Program.