11.3 boot fail after install ATI driver 10.8

Hi I’m Benz and I’m new to Suse (just moved from mint).

So … right now I’m having an issue after I installed ATI Catalyst 10.8 for my GPU HD 5770.
Every time I try to boot, it sends me to init3 (I mean text screen).
But when I check and try to switch to init5, it tells me that I’m on init5 already.
And I’m still stuck on the text screen. However, safemode is still working (yeah I’m on it right now - -").

I installed ATI driver by using this instuction — openSUSE Lizards » ATI HD57xxx fglrx drivers under 11.3

Feel free to ask more information that you need for helping me out, Thanks.

Thanks for the the link to those very complete instructions.

Could you post output from

 tail -n 30 /var/log/Xorg.0.log

Do any of the comments to the ATI HD57xxx flgrx instructions solve your problem?

I hadn’t read any of those comments before, but I’m reading them now.
It seems like some of them having the same problem with me as well.
Anyway, this is output I got

Banz-PC:~ #  tail -n 30 /var/log/Xorg.0.log
    17.171] (**) Logitech USB Receiver: always reports core events
    17.171] (**) Logitech USB Receiver: Device: "/dev/input/event1"
    17.176] (II) Logitech USB Receiver: Found 12 mouse buttons
    17.176] (II) Logitech USB Receiver: Found scroll wheel(s)
    17.176] (II) Logitech USB Receiver: Found relative axes
    17.176] (II) Logitech USB Receiver: Found x and y relative axes
    17.176] (II) Logitech USB Receiver: Found absolute axes
    17.176] (II) Logitech USB Receiver: Found keys
    17.176] (II) Logitech USB Receiver: Configuring as mouse
    17.176] (II) Logitech USB Receiver: Configuring as keyboard
    17.176] (**) Logitech USB Receiver: YAxisMapping: buttons 4 and 5
    17.176] (**) Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    17.176] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD)
    17.176] (**) Option "xkb_rules" "evdev"
    17.176] (**) Option "xkb_model" "evdev"
    17.176] (**) Option "xkb_layout" "us"
    17.176] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
    17.176] (**) Logitech USB Receiver: (accel) acceleration profile 0
    17.176] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
    17.176] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
    17.176] (II) Logitech USB Receiver: initialized for relative axes.
    17.176] (WW) Logitech USB Receiver: ignoring absolute axes.
    17.176] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse0)
    17.176] (**) Logitech USB Receiver: Applying InputClass "LocalKeyboard"
    17.176] (EE) No input driver/identifier specified (ignoring)
    17.178] (II) config/udev: Adding input device PC Speaker (/dev/input/event4)
    17.179] (EE) No input driver/identifier specified (ignoring)
    17.185] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    47.388] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-A9ACCDF38EB1446AC7992CE0B930842F0AD908B1.xkm
    47.651] (II) XKB: reuse xkmfile /var/lib/xkb/compiled/server-32802FE951013E1795FA564C242CB7AC57CA9C23.xkm
Banz-PC:~ # 

You don’t need to follow that hard way to install the ATI proprietary drivers anymore. Just run the ATI Installer script.

Execute aticonfig --initial to be sure there’s not an old xorg configuration. Also make sure that the radeon module is not running in parallel by executing mkinitrd as root.

17.185] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)

I believe vesafb is causing the problem.

Not what I expected. Is this output /var/log/Xorg.0.log from a failed startx or normal boot to init 5, or is this from output from a failsafe boot?

For normal/startx I aqree with Please_try_again about the FEDEV probably related to the mouse driver in /etc/X11/Xorg.conf or Kernel Mode Settings.

KMS can be turned off by adding “nomodeset” to your /boot/grub/menu.lst
for your default boot. The correct form is probably shown in the failsafe mode. That would explain why Failsafe works but normal boot doesn’t.

Not sure about changing /etc/X11/xorg.conf for the mouse driver.

Never mind guys, I did a fresh installation of 11.3 last night. This time I won’t install ati driver using hard way, but just use a pre-build package from the link I mentioned since the beginning … The problem should happen again though.

Many thanks to all of you for trying to help.

Did you try through the ATI repo?

Add it and install two packages for the fglrx module:
ati-fglrxG02-kmp-desktop (“desktop” is my kernel version).

Hello, I’d like to join this topic if possible, I’ve got exacly the same problem as Banz described. I made several attempts to install that driver:

  1. I went to ATI homepage and downloaded their Ati-driver-*.run file, installed it, and next reboot was in text console,

  2. I added recent ATI repo with their drivers from http://www2.ati.com/suse/11.3/
    just as faco84 stated, and they also didnt work, i was again dropped to text console,

I saw something in Ati readme.pdf avaible on thier download page, saying that you need to install 32bit driver first for 64bit driver to work, but im unsure what they mean
i didnt see any 32bit driver in their repos.

I also tried some tips and tricks i found around google, but found nothing that would solve that issue, I had to restore original xorg.conf in best case scenario.

I also found one note here: SDB:ATI drivers - openSUSE ; stating that if default driver works fine, there is no need to update, however i dont know if this driver makes full use of GPU
and I’m not sure if it provides 3D acceleration support,

Ah, and almost forgot, my specs are:
Ati Radeon 4890 1GB
kernel version is x86_64
KDE 4.4.4 release 2
Everything else is default installation

Any help is most welcome,
Cheers :slight_smile:

I had the same problem myself a few weeks ago, ie it ended up I could only run KDE if I booted into “safe” mode.

Every suggested remedy I tried resulted in something or other breaking.

I ended up resorting to the same “solution”, ie re-install 11.3 and live with the choppy video.

Anyway, the last thing I want is a solution that gets blown away every time the SuSE online update results in a new kernel.

Sorry for the late reply but the default driver should work, but unlike nVidia I don’t think you’ll get 3D support but did at one time.