[11.2 x64] Unable to mount any data CDs


I just installed 11.2, clean install due to wrong partition type (Extended instead of primary).

With 11.1 I could read and write data DVDs and CDs. Since 11.2 install unable to read or write data CDs.

mount /dev/sr0
mount: can't find /dev/sr0 in /etc/fstab or /etc/mtab

/dev/mapper/isw_dddcgaicei_Volume0_part3 / ext3 rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
udev /dev tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/mapper/isw_dddcgaicei_Volume0_part1 /boot ext3 rw,acl,user_xattr 0 0
/dev/mapper/isw_dddcgaicei_Volume0_part4 /home ext3 rw,acl,user_xattr 0 0
fusectl /sys/fs/fuse/connections fusectl rw 0 0
securityfs /sys/kernel/security securityfs rw 0 0
rpc_pipefs /var/lib/nfs/rpc_pipefs rpc_pipefs rw 0 0

/dev/mapper/isw_dddcgaicei_Volume0_part2 swap                 swap       defaults              0 0
/dev/mapper/isw_dddcgaicei_Volume0_part3 /                    ext3       acl,user_xattr        1 1
/dev/mapper/isw_dddcgaicei_Volume0_part1 /boot                ext3       acl,user_xattr        1 2
/dev/mapper/isw_dddcgaicei_Volume0_part4 /home                ext3       acl,user_xattr        1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
#/dev/disk/by-id/ata-ST3120023A_3KA0PCKG-part2 /backup              ext3       defaults              1 2

/usr/sbin/hwinfo --cdrom
30: SCSI 500.0: 10602 CD-ROM (DVD)
  [Created at block.247]
  UDI: /org/freedesktop/Hal/devices/storage_model_DVDRAM_GH20NS10
  Unique ID: KD9E.NYm9QTAFVy1
  Parent ID: w7Y8.IdSiIM3kQc3
  SysFS ID: /class/block/sr0
  SysFS BusID: 5:0:0:0
  SysFS Device Link: /devices/pci0000:00/0000:00:1f.2/host5/target5:0:0/5:0:0:0
  Hardware Class: cdrom
  Model: "HL-DT-ST DVDRAM GH20NS10"
  Vendor: "HL-DT-ST"
  Device: "DVDRAM GH20NS10"
  Revision: "EL01"
  Driver: "ahci", "sr"
  Driver Modules: "ahci"
  Device File: /dev/sr0 (/dev/sg2)
  Device Files: /dev/sr0, /dev/block/11:0, /dev/scd0, /dev/disk/by-path/pci-0000:00:1f.2-scsi-5:0:0:0, /dev/cdrom, /dev/cdrw, /dev/dvd, /dev/dvdrw
  Device Number: block 11:0 (char 21:2)
  Drive status: no medium
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #23 (RAID bus controller)
  Drive Speed: 48

I am unable to install additional non-OpenSuse software until I can read my CDs.

PS: I not interested at all in audio CDs and video DVDs.

Quick way. Please use a user with enough rights.

mkdir /mnt/cdrom
mount /dev/cdrom /mnt/cdrom
cd /mnt/cdrom

I would expect you know to see your CDROM contents :wink:

Thanx for the info, though that still does not work.

mount /dev/cdrom /mnt/cdrom
mount: /dev/sr0: unknown device

Also one has to be root to be able to use mount command.

With 11.1 64bit, automounting as a normal user worked. What changed between 11.1 and 11.2?

I retested it, and i get exactly the same error message whenever my CD is physically not inside the drive. I assume this is not the case :wink:
Is it possible that your CD is somehow ruined? Have you tried to give it a go with another CD?

I tested many CDs even including OpenSUSE 11.2 CDs and DVDs. Now all OpenSUSE 11.2 packages are now installing from online sources.

OpenSUSE 11.2 DVD worked on installation, now can’t even read it. User automount does not work nor root mount command.

Installation of 11.2 was done on a clean hardware raid 1 system, as was done before for 11.1.

Looks like the drive is at it’s end.

Last 3 questions:

1)Can you still boot from your OpenSUSE 11.2 DVD?
2)Is the drive doing something when you try to mount it? (leds and such)
3)Anything logged in /var/log/messages and dmesg after a mount attempt?

  1. DVD still boots, then goes over to HDD RAID.
  2. nothing happens. Only activity is when DVD tray is closed to scan the media type, then nothing happens once LED stops burning. Should automount and display list of options, yet not happening since 11.2 was installed.
  3. tail of /var/log/messages and dmesg still remains the same as before inserting the CD or DVD, or using mount command.

After 11.2 has been installed I can boot with any bootable DVD or CD of OpenSUSE from 9.0 to 11.2. So there is no problem with the DVD writer. The problem exists after 11.2 64 bit has been installed, not before or during 11.2 64 bit installation.

I decided to take a dare.

I unplugged the SATA cable to DVD writer while lshal -m was running, and reconnected the cable. Immediately device was detected.

HI there, I’ve been dealing with the same problem, Recently installed OS 11.2 and data CD’s are not detected, DVDs and Audio CDs work well.

With the commands you gave I actually see the contents of the
data cd, but then what?
Will I have always to make it in this way?

Thanks for your time.

This is not normal. Data-CD’s should be autodetected as well. What you might do is upgrading to KDE4 4.3

Question: if you insert a Data-CD and open Dolphin, does it show in the “Places”?

NO, when I insert a dataCD I don’t see it in places.

Ok, what I need to do to upgrade KDE 4.4.3? (or please, direct me to a post or guide to follow in order to do that.)


HI there again.

Continuing this thread, one weird thing happened to me today: I was listening some audiocd’s with kscd, then I put a data CD and it was detected also it was shown in dolphin “Places”, then I opened the cd tray again, put another data cd but in this time nothing happened, no notification of new recently plugged devices.

hi there, it’s my first post here.

i’m also affected by the problem and also figured out that the CD is automounted when i start my computer with the CD inside. i hate this bug. i haven’t spotted any serious bugs in openSUSE so far and i’m really impressed but this one is really painful. what’s more there’s no response to this problem in bugzilla. if somebody could come up with a solution, i’d be really grateful because i can’t find any myself. the only solution seems to be using Gnome - it is free of this bug (which is a good clue i think).

btw, i’m using a 32-bit system so it seems not to be related with x64 only

you’re right, I FORGOT TO MENTION THIS BEFORE, actually I’m using a 32 bit 11.2 too…

Even I updated to KDE 4.3.4, and the problem persist. May be I’ll try a new installation.

Annoying don’t you think?

I’m out of answers and questions

indeed. i also tried updating to KDE 4.3.4 in the hope that the problem has already been resolved but unfortunately it hasn’t.

what’s even more frustrating is the fact that they set the priority to LOW. i think it’s a bit crazy - this bug is really painful.

please, add you voice in the bug report and maybe they’ll finally do something about it:


everyone reading this thread, please, do the same. we’re really suffering;)

I’ll do that.

if I can’t make it work (cdrom), I think i’m gonna try go back to 11.1 for a while…or try another distro.


I will add my votes to the request for a bug fix. This is my second 11.2 install and I have the problem on both machines.

On one it will read cd’s and dvd’s from windows, but not k3b. For me it is going to be a serious problem.