11.2 won't load dvorak

After installing 11.2 and selecting dvorak keyboard during the install process was surprised to see that was still in qwerty.
When then selected dvorak at session login, still wouldn’t switch to dvorak.
When checked loadkeys and other places in config files and system settings, all said dvorak – but still could only get qwerty.
If anyone has idea of just what the problem is, would greatly appreciate the suggestion.
Appreciatively, Bil VERCH

On Fri, 14 May 2010 19:46:01 +0000, silvergreen wrote:

> After installing 11.2 and selecting dvorak keyboard during the install
> process was surprised to see that was still in qwerty. When then
> selected dvorak at session login, still wouldn’t switch to dvorak.
> When checked loadkeys and other places in config files and system
> settings, all said dvorak – but still could only get qwerty. If anyone
> has idea of just what the problem is, would greatly appreciate the
> suggestion.
> Appreciatively, Bil VERCH

Which desktop environment are you using? I’m on GNOME and have my
keyboard set to switch between the two (and one of these days, I will
start using dvorak more).

Jim


Jim Henderson
openSUSE Forums Administrator

Dear Jim, Thanks for taking time to reply. Am using KDE, and was also surprised to see that in YAST control panel, the option of “Keyboard” has been removed, so couldn’t use that to try either.
Appreciatively, Bil VERCH

Sounds like a bug worth reporting.

On Mon, 17 May 2010 23:26:01 +0000, silvergreen wrote:

> Dear Jim, Thanks for taking time to reply. Am using KDE, and was also
> surprised to see that in YAST control panel, the option of “Keyboard”
> has been removed, so couldn’t use that to try either. Appreciatively,

No problem - I’d agree with gogalthorp, sounds like a bug that should be
reported.

Jim


Jim Henderson
openSUSE Forums Administrator

It’s kind of late but I’ve figured out how to get this to work on my computer… I’m putting this here mainly for the other people who have this problem and land here from a google search. Anyway…

I looked in /var/log/Xorg.0.log which contained the line:


(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.

I proceeded to add


Option "AllowEmptyInput" "false"

to my xorg.conf seeing as the section in xorg.conf that talked about my dvorak keyboard did indeed use the driver ‘kbd’.

To my dismay, upon restarting X, every keystroke I typed resulted in two dvorak letters appearing on the screen. Each key press was registered twice. On a whim I added


Option "AutoAddDevices" "false"

to xorg.conf as well to prevent X from detecting a keyboard and then adding the same one again from xorg.conf. To my surprise and glee, it worked and all’s well.