11.2 update error: failed to download from repositories

The red updater icon alerted me to about a dozen patches, which started to install, then halted with an error: Download failure from download.opensuse.org/distribution/11.2/repo/non-oss. When I try to update repositories, the same error recurs for that repo and also for …/oss and download.opensuse.org/update/11.2/,

If I attempt to “register for support to get update repository,” clicking on Configure Now and Next produces the same three error messages: “Failed to download”, one for each repository. The screen then returns to Registration, with another error message “an error occurred while connecting to the server”. Clicking on the Detail button show exactly “ERROR:”

This AMD desktop machine with this install of 11.2 has updated many times in the last few weeks. Has something changed? The update servers do respond to a ping, so they are up and apparently I have connectivity.

I had something strange happen too today regarding the repositories. I waited a litte while, and refreshed the respositories and tried again and it worked. I’m not 100% sure a ping confirms all is okay (I could be totally in left field here), especially with the use of metalink. What if the download.opensuse.org/repositories/… is up, but there’s a problem with the metalink definitions or the mirrors. What does the user (that’s us) see?

Waited. Rebooted. Still unable to refresh repositories or down load from them.

Slightly different message:
"Download failed:
Failed to download /content from Index of /distribution/11.2/repo/non-oss

  • [AbstractCommand.cc:195] URI=http://download.opensuse.org/distribution/11.2/repo/non-oss/content"

Also, zypper up produces the same error message for the repositories, which it disabled, but in the end listed 122 packages up upgrade. Somewhat hesitantly, I said yes.

Does make sense to anyone?

Zypper updated lots of packages, but “Failed to Download” from Index of /update/11.2 and other repositories, so I aborted after a while.

Not such a good idea: a warning displayed that running programs depend on removed items; zypper ps produced over 50.

11.1 is looking better. I had to go back to 11.1 on my notebook (the above is on the desktop machine) because 11.2 failed.

I’m open to ideas.

Post output of

zypper lr -d

maybe you have mixed up repos

zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | repo-debug | openSUSE-11.2-Debug | No | No | 99 | yast2 | Index of /debug/distribution/11.2/repo/oss |
2 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
3 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
4 | repo-source | openSUSE-11.2-Source | No | No | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
5 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |

I’ve had the same problem a couple of times with 11.2,
last time today. I’ll try again tomorrow.


Same problem here.

Installed yesterday a new machine with 11.2, afterwards online update runs into problems.

The first package, which doesn’t update is libpoppler. I also tried to download it via normal webbrowser, which failed too. After loading about 45% the browser reported a size mismatch and presented only a corrupted file.

So I suspect, that the repositories of 11.2 are corrupt now. Somebody should have a look at them…

In the moment I have only text mode access to the machine, since the KDE update was broken too and KDE doesn’t startup now.


Repos are not corrupt. There’s been some downtime, a message about this was posted in ‘Announcements’.

Ah, ok. I jusr tried again, I can now download the rpm with a webbrowser, but online update still fails (with AbstractCommand.cc:195 URI=… Failed to download.

Still mysterious to me…


Ok, just some observations, maybe someone has an idea.

  • when I download a rpm from the repositories with a webbrowser via Save Link As it works
  • when I use a download manager it doesn’t, the download stops and then aborts some time
  • same happens with zypper (aborts some rpms)

To me it seems that it is an issue with the usage of download managers (maybe multiple connections?).

So the question is: is it possible to configure zypper only to use a normal single connection, i.e. not using a download manager? In quick search in the documentation of zypper I haven’t found anything related to that.

Because manully downloading the rpms and installing them by hand is quite time intensive…


Hey Michael, Have you been able to find a solution the AbstractCommand:195 error ? I’m having the same problem and I can’t seem to find a solution…

After earlier problems with 11.2, I replaced the 8 year old MB with a new Asus and an AMD Athlon II dual core CPU, 4 GB of RAM. New HD. First install of openSuse 11.2 completed, but have not been able to update repositories. Can’t register, either–errors about not being able to download from repos. For that matter, Firefox won’t connect to any WWW server outside of the LAN. I’ve reset the WAN router (Verizon FIOS service).
From a terminal on the 11.2 machine I can ping download.opensuse.org, yahoo.com, and the DNS servers. But the Updater Applet says “repo not available: failed to download…” It appears some programs can’t resolve download.opensuse.org.
I’ve gone through the configs of Network Settings in 11.2 to make them match a working 11.1 install on another machine. I’ve looked at the fire wall settings, Checked the router settings.
The machine with 11.1 operates normally on the same LAN.
What am I missing?