11.2 Unable to startx

On a clean install system boots as far as init 5, then drops to CLI, I can login to root or user, startx give a message saying its not installed, as does sax2.

yast2 runs and have fully updated system, have tried a system repair, changed kde4 to kdm, but still same issue.

I can reproduce the error on current system update from 11.1 (can’t get nvidia to load, have tried easy and hard way) if I change to vmlinuz-desktop from vmlinuz-default.

any suggestion on were to go from here, I would like to get clean install working and stable. hopefully with nvidia loading, so I can clear current system.

nvidia device type?

The Graphics Card is a: GeForce 8800 GTS (XFX)

Main Processor: AMD Athlon™ 64 X2 Dual Core Processor 6000+

Main Board : ASUS M2N-SLI

So you are saying the repo way doesn’t work and the manual way doesn’t work?
And when you tried to do sax2 it errors out?

Were there errors during the manual driver install?
Did the install itself proceed nicely
Did you do the media check

For another shot at the manual

Make sure you have
kernel-default-devel (assuming you are using default kernel)

place the downloaded driver in /home/username

Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3
At the login
Login with your username and password
Now switch to super user with su
and root password
*Now remember you can use the {TAB} key to auto complete
so type:
and the whole file name should auto complete
eg: sh NVIDIA-Linux-x86-185.18.36-pkg1.run
Follow the installer and let it compile the kernel module for you.
Say Yes to everything
Use TAB to move around

jemfisher wrote:
> On a clean install system

did you check the md5sum of the iso prior to burning install media?
which image did you choose?


2 Installs, on a clean install I am unable to startx or use sax2, on the clean install have not tried installing nvidia yet, but have run full update.

The other install was an update from 11.1, I have tried both ways of installing nvidia drivers, I do not get any errors after install, they seem to install fine, but don’t work (no splash screen), as I said I can reproduce error on updated sytstem by switching vmlinuz-default to desktop.

If I can remember how to mount USB drive I will go install nvidia on other drive.

Boot a live cd, you can use that to put the file in place.

Do you have this repository installed
p, li { white-space: pre-wrap; } ftp://download.nvidia.com/opensuse/11.2/
then install via yast package manager

Instead of startx in the cli login as your user then as su do the command init3 when your in init3 and still as su command init5 and take a look for the text errors. I’m suspecting this as a graphic card issue. Please post the errors. If it is a graphic card issue while still su go back to init3 and do the command sax2 -r -m 0=vesa (0 is zero not “o”) and while still su command init5 and see if it will give you the graphical login interface.

I dug a little deeper, stopped when ‘make’ had dependency issue’s, I went back downloaded new ISO burnt with different package via Puppy Linux, and are now were I want to be, have just finished restoring odds and sods from backup files, and are thanks to the fantastic quick response here a happy camper.

I’ve used SuSe since 6.8, and this really had me worried, but I guess ensuring the ISO is good will be checked from now on.

One of the first questions I asked was: Did you check the media
All is well now then:)

jemfisher wrote:
> I guess ensuring the ISO is good will be checked from now on.

good guess jemfisher, a LONG time ago (near the middle of the last
century) and IBM (mainframe) technician/teacher figured out

“Garbage in, garbage out.”


and, still today if you install junk you have junk.