11.2 RC2 - Strigi / NepoMuk can't be used?

Did something go wrong during my update process or doesn’t Strigi work in 11.2? (had a lot of items I had to skip, though I assumed those were fixed after running a second update/checking for dependency issues which YaST didn’t find)

Under Personal Settings > Advanced tab > Desktop Search there are 2 options.
Nepomuk and Strigi, I could enable Nepomuk but Strigi gave me the error

The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files

I fixed it by Googling around, and finding a page that said the error could be solved by installing a newer version of Soprano… and so I added Index of /repositories/KDE:/KDE4:/UNSTABLE:/Desktop/openSUSE_11.1
Which gave me some Qt dependency issues while trying to update Soprano, solved those by also adding Index of /repositories/KDE:/Qt46/openSUSE_11.1

Now I could enable Strigi but it wouldn’nt start and since it was dinner time I decided a reboot while I had dinner would take care of that, and it did.

All in all, I now have a working Search function in Dolphin… but is this possible by default, or does everyone need to jump trough these hoops (need to open a bug report then).

IIRC you need to install sesame backend and install java-1_6 -devel

java-1_6 openjdk-devel or sun-devel?

Whichever, that did not work. Strigi is not running, failed to initialize, mostly due to installation problem.

I have it running on a test Kubuntu 9.10 no problem. I installed soprano-backend-sesame.

I need strigi to run, cuz it’s the only way to display additional meta information in the information panel of Dolphin and I use that a lot. Mandatory.

So how can I troubleshoot a failing to initialize strigi?

Ok got it. You have to

sudo ln -s /usr/lib64/gcj-4.4-10/libjvm.so /usr/lib64/libjvm.so

What a badly compiled package…

For other distros the symbolic link is completely different.
For instance, on debian (kubuntu), you have to do the following:

sudo ln -s /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/server/libjvm.s /usr/lib64/libjvm.so

Also, the folders are different is you are 32-bits. My link was for 64-bits.

Bad package. Also bad cuz you need all that indexing to get picture dimensions (I have another post here about that and there is a huge bug on bugs.kde.org).

Weird because nepomuk works just fine on my systemwithout creating any simlinks.I got the Sun Java .

From what I read here, it’s again mixing packages from different repos. If something does not work, find out why first, or go here first. By now I would have to ask the versionnumber for almost every package related to nepomuk/strigi.

@Axeia: please stick to the couple of repos advised all over the forum. What you have done now, is one day or another bringing new trouble. As stated by some other posters, it does work out of the box. So, you must have changed something that came out of the box to make it ‘not working’.

Strigi is not running, failed to initialize, mostly due to installation problem.

Same problem, is there any resolution to this problem. I tried Franksuse code in Konsole and still the Strigi is not running.

Any advice?

Beta forums - Slow replies = Several milestone versions that make the difference :wink:

And I consider knowing a working work around to get something working a valuable addition to a bug report.

This fixed it for me - thanks! Strigi now running again.