11.2 RC2 NetworkManager and AR5007eg problems

Today I downloaded the 64-bit 11.2 RC2 and did a completely clean install of it on my main PC, first from the KDE4 LiveCD, and a second time using the DVD. I wanted to rearrange my partitions before 11.2 final came out, so I figured this would give me a good way of doing that.

Anyways, I had run milestone 6, 7 and 8 but I had skipped RC1 because of various complicated reasons. Nevertheless, I began the installation feeling confident that everything would work as well as it had in the past.

As you can probably tell by the title, this is not the case. My PC has a wireless NIC with an Atheros AR5007EG chipset. My wireless network is secured with WPA2-PSK AES encryption, and my router is broadcasting the SSID. After installing RC2 from the KDE4 liveCD, I opened knetworkmanager and entered my WPA2 key which then connected to my wireless network. However, when I tried connecting to the Internet, I was met with an error screen from Firefox saying the page could not be found. In addition, the update manager threw up errors that it too could not find the network. I double-checked that I was, indeed, connected and had an IP address (which I did), and I even had the name server WAN addresses from my ISP entered, however I still could not get out to the Internet.

I started troubleshooting by first attempting to disable IPv6, although I never did succeed doing this. It appears the /etc/modprobe.d config files have been changed for this release and my old method of doing it isn’t working. Moving on from that (b/c I didn’t think it had anything to do with it), I also tried bringing the interface down and up, turning the firewall off and on, disable/enabling NetworkManager, turning off encryption on my network, and I even installed the proprietary madwifi modules and blacklisted the ath5k module, but all of these resulted in the same thing: I could connect to my wireless network, but I could not connect to the Internet. I could get to my router’s management page and ping the router’s internal interface, so I know networking is somewhat working.

Even though I verified the md5 of the iso before I burned the CD, and then burned the CD at the slowest speed, I wondered if possibly the CD had become corrupted. I downloaded the DVD (so I would also have access to more packages), verified the md5 checksum, burned at the slowest speed, ran a media check of the DVD, and then reinstalled RC2 using the DVD. Unfortunately, the end result was also the same.

I started to think it may be a problem with my router, but this isn’t the case. My laptop also has RC2 installed, and it can connect to the Internet without any trouble. Coincidentally, it also has an atheros wireless card, although the chipset is different (ar5008x).

One thing I did notice is my PC isn’t identifying my the chipset model correctly. I know for a fact that the wireless chipset is AR5007EG, but lspci displays the chipset model as being AR5001. I don’t think this has any effect on it, since I recall previous milestone’s also did this, and 11.1 also misidentified the chipset without any adverse effects. Even so, it’s still worth mentioning.

After flirting with the idea of getting a 100ft ethernet cable to see if my wired interface would work any better, I remembered that NetworkManager has traditionally been a bug-ridden, stinking heap of code, so I installed wicd and completely disabled NetworkManager. Lo and behold, I can now connect to the Internet without any problem (I am posting this from my desktop as we speak).

So, in summary:

  • My desktop is using an Atheros AR5007EG wireless NIC.

  • The wireless chipset is being misidentified as AR5001 instead of AR5007EG

  • Milestones 6,7,8 could all connect to the Internet without any trouble.

  • A fresh install of RC2 from the KDE4 liveCD and DVD both result in an inability to connect to the Internet

  • The NIC is associating with my router, which I can ping and access the management page, but I cannot get past my router

  • Disabling NetworkManager and installing wicd allow me to connect to the Internet without any trouble

So from my experience, it appears that the version of NetworkManager shipped with the 64-bit version of RC2 does not work properly with wireless cards that use the ar5007eg chipset. I do not know if it also affects the 32-bit version, or any other chipsets in the same family (it certainly doesn’t affect the AR5008X card in my laptop). It may also be a specific problem related to may setup, and others with an AR5007eg card may not have any problems. If so, I’d like to hear from others.

If anyone has any other suggestions for me to try, I would be glad to give them a shot. This post was more informative, rather than inquisitive, and I just wanted to bring this to the community’s attention in case someone else experiences the same trouble. I’m also beginning to think I should file a bug report for this.

And on a related note, does anyone know how to disable IPv6 in 11.2 RC2? I used the methods outlined on the wiki page, but they were no dice.

Got the same problem. The routing table is not updated adequately. Was clean install 11.2RC2.

When I connect using DHCP, it’s fine.
route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface U 1 0 0 eth0 UG 0 0 0 eth0

When I connect using a static address, routing is incomplete:
oute -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface U 1 0 0 eth0

I do not have the problem on my laptop, where I upgraded from 11.1.

Will try to fill out a bug report.

Indeed this is a known problem with KDE4, where either using wicd or the “traditional ifup” works. I encountered this on an Intel wireless testing the liveCD, but I did not struggle on this, as I visit the forums so much, I knew to expect the problem before I ran the liveCD.

I have the same problem in openSUSE 11.2 Final and found a bug related: Bug 553908

Bug 550907 which is a duplicate of the one above, explains how to configure Network Manager for it to work.