11.2 RC1: no sound in firefox like in 11.1 but not fixable

I have the same sound problem as described in this thread, except that I have 11.2 RC1 and a Xonar-DX (snd_virtuoso): No Sound In Firefox - openSUSE Forums

I had this problem also with 11.1, but it was fixable by editing etc/modprobe.d/sound, like described in the last post.
Now in 11.2 this file seems to be replaced by a file called 50-sound.conf, but editing this file results in not fixing the issue.

Has anyone an idea how to fix this problem in 11.2?
Maybe I should write a bug report, since I’m not the only one having this problem.

I’ve lost count of the number of times users have stated they have the same problem , but in fact, its different.

Could you instead post what your problem is, and do not reference that thread? That thread gives all sorts of specifics which may not be relevant to your case.

I assume you have sound outside of firefox?

If you do , then editing the etc/modprobe.d/sound or the /etc/modprobe.d/50-sound.conf should NOT be done. Editing that file is for basic sound, not for application specific sound problems.

If this is simply a sound problem with firefox, then this could be a 64-bt problem, or it could be something as simple as your removing libflashsupport rpm but keeping flash-support rpm.

If you believe you have investigated this thoroughly enough to know what I noted above does not apply, then yes, maybe you could.

Okay, in fact it is the same problem, flash searches for card 0 but can not find it. because my card has the value 1.
Setting the value to 0 worked for me in 11.1, but the strange thing is that there is no card 0 by default and that’s a bug, because you need a card with id 0.

Here is the firefox output:

ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4154:(_snd_config_evaluate) function snd_func_card_driver returned error: Datei oder Verzeichnis nicht gefunden
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4154:(_snd_config_evaluate) function snd_func_concat returned error: Datei oder Verzeichnis nicht gefunden
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4154:(_snd_config_evaluate) function snd_func_refer returned error: Datei oder Verzeichnis nicht gefunden
ALSA lib conf.c:4633:(snd_config_expand) Evaluate error: Datei oder Verzeichnis nicht gefunden
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default
ALSA lib pcm_hw.c:1433:(_snd_pcm_hw_open) Invalid value for card

And here is the output of cat /proc/asound/modules:

1 snd_virtuoso

normaly it should be:

0 snd_virtuoso

For solving this problem I only need to set the card id to 0.

I just forgot the options before snd_virtuoso index=0. It works now.
I think this bug is worth adding it to bugtracker, I’ll do that tomorrow.

Can you run the following diagnostic script (with PC connected to the internet):


please select YES to share/upload the diagnostic information. Then when it is done it will give you a URL where the information is posted. Please post that URL here.

Note, if you post a bug report, the openSUSE / alsa dev/packager will ask you to run that script with the --no-upload option, and post the alsa-info.txt file generated as an attachment into the openSUSE bug report thread.

Since there’s no answer from the OP, I’ll pick it up. Installed RC1 on spare SSD in main system. I know where the problem lies, and yes it’s a bug. PCM is totally muted. And, opposed to 2.6.previous there’s no slider/checkbox for PCM to unmute it.
I already did this (it’s a testing system, set up in less than one hour):
compiled all alsa from scratch on both 2.6.31 and 2.6.32-rc5, no PCM.

Output of /usr/sbin/alsa-info.sh is at:


Any thoughts on this matter?

It’s getting weirder:

Replaced kernel-desktop-2.6.32-rc5 by kernel-default-2.6.32-rc5, problem partly gone: PCM not muted, so sound from FF and others.

Now we’re waiting for phonon to have the equalizer stuff ready and in upstream. I experimented with it, got amarok’s equalizer truely working, with the loss of usage of digikam and kaffeine (crashing on phonon).

Anyway, it’s working now. Problem remains on -desktop kernels…

Only that it should work. I noted this in the ALSA-Configuration.txt file:

Module snd-virtuoso

Module for sound cards based on the Asus AV100/AV200 chips,
i.e., Xonar D1, DX, D2, D2X, HDAV1.3 (Deluxe), Essence ST
(Deluxe) and Essence STX.

This module supports autoprobe and multiple cards.

I was thinking the previous user might have 2 sound devices which could possibly explain his problem. Only one is identified in the script output you provided.

No, I only have the Xonar DX, onboard sound is removed (yes thats possible on ASUS P5E) and disabled in bios (I’m using rampage bios instead of normal bios).

Here is my alsa file:

I note you have the kernel-desktop installed. Was that automatic, or did you have to select that? I’m wondering if you would have obtained the same behaviour with kernel-default (if a 32-bit or 64-bit user) or kernel-pae (if a 32-bit user) ?

If you believe this to be an 11.2 problem, then write a bug report on 11.2 RC1.

Yes, it was installed by default (I also noticed that it saves RAM). I think it is not an kernel-specific problem, as I had the same problem also in 11.1 with 2.6.27.

I’ll do that.

Interesting … when I installed 11.2 RC on my old 32-bit athlon-1100 with 1GB RAM, I was curious if the kernel-desktop would be installed, but it was not. Instead kernel-default was installed. … It left me wondering what sort of algorithm is in place to select the kernel version to be installed.

When you installed 11.2 RC1, did you have the same /home directory (with no reformat) as you had for your old 11.1 with 2.6.27 ?

Both on my laptop and my main machine, kernel-desktop is installed by default.
I don’t have much time now, but will install both kernels alongside eachother, boot into both and report what happens. Looks like one is allowing the system to use unmuted PCM, other doesn’t. But that’s merely a feeling. Have to dive deeper.

Yes, on my netbook I just converted it to ext4, I’ll do that also on my computer.

That makes me wonder then if the problem is in your /home/user/.Mozilla directory.

That sounds possible, but card id was still 1.

I had the same problem with flash not giving sound after installing 11.2 RC 2 (in another box I installed Milestone 7 and it worked). I solved the problem by chance after logging into KDE as root (for a short moment :slight_smile: ). But do not ask me the reason :slight_smile:

Could that be a pulseaudio issue?

I had to add these to ~/.asoundrc after updating to 11.2 RC1. It creates pulseaudio device for ALSA.

There is a file /etc/alsa-pulse.conf with similar settings, but my system seems to ignore it.

# PulseAudio plugin configuration                                                                

# Let's create a virtual device "pulse" for mixer and PCM

pcm.pulse {
    type pulse

ctl.pulse {
    type pulse

# Let's make it the default!

pcm.!default {
    type plug
    slave.pcm {
        type pulse

ctl.!default {
    type pulse

One point: in the sound mixers, do you have the PCM channel muted (or at the bottom level)? If so, try raising the level.