11.2: Problem during 'Check Installation Media'

Hello, everybody.

I’ve already searched through the forum’s previous threads and in the web, without being able to find any substantial information, so here I am. Sorry if this will end up in a duplication of some pre-existing thread :slight_smile:

Just for the record, I add that I am ABSOLUTELY NOT new to SuSE (my experience goes back to the 9.0 release, and has evolved through 9.1-9.2-9.3-10.2-10.3-11.0-11.1) and of course I have already read the information contained in the suitable FAQs and the like.

The problem: I’ve recently downloaded the new 11.2 release, in the form of the 4.2 GB DVD.ISO image, TWICE, first via a mirror near to my current location: and, the second time, directly via the central openSUSE/Novell server.

After the download, the GPG/MD5/SHA1 checks of the ISO file show (ALL OF THEM) that the file is undamaged: so everything seems to be alright at this point.

Then, I burn a DVD (for the record: a NEW Verbatim, just taken out of the plastic envelope) under Windows with the more recent release of CD Burner XP (this, because the only machine on which I’m currently able to burn a DVD is a Toshiba laptop operated by WinXP ^·^) at the LOWEST recording speed I can (that is: 2x). Here, everything goes fine too, and the recording process ends with a “success” notice.

Finally, of course, I reboot the pc, and as a first move I check the installation media. And EVERY time (I’ve completely repeated the whole process three times, and made the check under three different machines: the aforementioned Toshiba, a HP nx9105 laptop and an Acer Veriton 7600 tower) the check ends with a “Error reading sector 2195488 - This CD-ROM is broken” message: which is actually impossible, since every time the DVD is NEW (I’ve used a new one on every attempt, for safety). BTW: the number of the broken sector is always the same.

My question: isn’t this a sign of the presence of a bug in the installation program?

Else, I just can’t figure out what’s happening ^____^

A warm welcome to the forums.

I tend to think of degrading condition of the burning device, since I’ve never found this one before as a bug in the install media.
If you still have a running (open)SUSE, can you check the md5sum from the burned medium ? It should be the same as the downloaded iso’s.

Thank you for your quiiiiick answer and for your welcome :slight_smile:

…er… no, I don’t think so. In that very same way, I’ve very recently (last december) produced DVDs of the 11.0-11.1 releases, with absolutely no problem nor hassle. And the aforementioned Toshiba laptop is quite recent, too.

So, I tend to believe that the conjecture of the “hardware responsibility” can’t stand the empirical facts…

A quick update.

Just tried to after-check the DVD in three different ways:

  1. via the ‘dd + md5sum’ way (=> http://wiki.linuxquestions.org/wiki/Md5sum ). It reads:
/mnt/ark3 # dd if=/dev/cdrw | head --bytes=4497694720 | md5sum
dd: reading `/dev/cdrw': Input/output error
3a45419ddb75c68766f463841aa90df9  -
8781792+0 records in
8781792+0 records out
4496277504 bytes (4,5 GB) copied, 586,366 s, 7,7 MB/s

and as one can see, there is no dimensional correspondence between the original ISO file and what’s on the DVD.

  1. via the ‘dd + cmp’ way, which produces the same results:
/mnt/ark3 # dd if=/dev/cdrw | cmp openSUSE-11.2-DVD-i586.iso
dd: reading `/dev/cdrw': Input/output error
8781792+0 records in
8781792+0 records out
4496277504 bytes (4,5 GB) copied, 584,221 s, 7,7 MB/s
cmp: EOF in -

  1. finally, by means of the ‘Installation Support Checking’ utility in YaST (under 11.0): which, predictably, gives the same answer…

Just for the record :slight_smile:

No option to burn the disk in another machine? Just for fun!!!

Unfortunately, there isn’t. Currently, the only machine equipped with a DVD/RW unit is the Toshiba :slight_smile:

Here is what I would do.

Install Virtual Box in XP and use the so called faulty dvd as the install media for a suse VM
See what happens

Because I have installed from a so called faulty DVD before, without issue. (It’s not recommended mind you)
But doing it in a VM will let you test it;)

It may be an option to instead burn a live CD,on another machine and install from there,the OS can be configured as needed afterwards.

My question: isn’t this a sign of the presence of a bug in the installation program?

I have not come across this problem on these forums previously,

11.2 has been out for a while now, I would have thought I may have seen it.If it is not specific to your hardware, someone else may find more cases.

One more option would be a bug in the version of CD Burner XP being used, Perhaps a different version or program is worth a try?

Don’t worry… follow the md5 it’s correct…

I had the same problem and not just with the dvd…(only with the 11.2 disks however)
I’m guessing some last minute updates were made but the md5 sums in the dvd’s were not.

Anyway… if you are using the dvd simply note down any packages which fail (if any) and install them separately;)…

SOLVED! :smiley:

Believe it or not, it was quite trivial. As usual: your car stops in the middle of a street, all of a sudden, and you begin thinking about every possible technical issue… until you realize your gasoline tank is dry :wink:

So, the trivial problem was that CD Burner XP [P.S.: yes, as somebody has correctly guessed, I see], which btw usually works absolutely well, this time has decided to break the burning well before the due time: I don’t know why. The result was a DVD which only apparently was correctly burnt, and instead was actually “incomplete”.

To fix this, it has been sufficient to burn the DVD under SuSE 10.2 (yes: the aforementioned Toshiba can double-boot WinXP + SuSE 10.2: but I’ve never used its K3B to burn CDs/DVDs, because I had had some bad experiences with the program’s previous releases).

Now, every check (pre- and post-, so to speak) works as it should.

So, for the record: either my version of CDBXP (which is a 4.2.x.something… right now, I’m not able to be more specific) has suddenly stopped working: or, the installation itself has become corrupted somehow…

Anyway: could there be a more direct proof that, the sooner one trashes Windows, the better it is? :smiley: