11.2 Nvidia video problem

I’m having a real fight with an Nvidia 6100 video under 11.2. I cannot get
anything besides 1024x768 or 800x600 resolution with any technique besides
doing an upgrade installation over an existing 11.1 system. I want
1440x900 for this wide screen LCD and that works with the upgrade install
but that gets me into other problems with versions and other stuff - not a
desireable choice.

OK. I know that the Nvidia driver (190.53) works as all is well under the
upgrade. When I do a totally clean installation or a clean install with
the existing /home I get a default 1024x768. If I use sax2 to try and
change it one of two things happens: the change is ignored or I drop to
800x600 and the ball game is over: I’m stuck there, period. Other than a
couple of commented-out lines, xorg.conf is the same as it was for 11.1
(and back to 10.1 after allowing for version changes) after running sax2
but even nvidia-settings won’t give anything beyond 1024x768 if I try and
use that.

I’ve been through the how-to stuff and back messages here but I’ll be darned
if I can force the desired 1440x900. I had a similar issue with 10.2 or so
where the only way to get it right the first time was to set the desired
resolution to 1440x900 during the hardware setup during the installation
but that seems to have disappeared along with xorg.conf which only appears
after running sax2. I can’t even use the manual editing tricks in xorg.conf
I’ve had to use with some cards - it seems to be completely ignored and I
can’t see any real problem with it anyway once sax2 builds it.

Where do I look now?

On a couple of machines with later version of the Nvidia video everything is
working as expected, at least with GF 6800 and higher video.


Will Honea

Not sure if it will help, but please take a read of this guide , looking at the nVidia post:
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

Note when trying to change resolution, I recommend booting direct to run level 3 (do not go from run level 5 to level 3 via init3) and then while in that text mode of run level 3 run the appropriate program to create an xorg.conf to configure the resolution.

oldcpu wrote:

>
> Not sure if it will help, but please take a read of this guide , looking
> at the nVidia post:
> ‘openSUSE Graphic Card Practical Theory Guide for Users - openSUSE
> Forums’ (http://tinyurl.com/ydggvdw)
>
> Note when trying to change resolution, I recommend booting direct to
> run level 3 (do not go from run level 5 to level 3 via init3) and then
> while in that text mode of run level 3 run the appropriate program to
> create an xorg.conf to configure the resolution.

DUH! I was omitting the -r option when calling sax2 from level 3! Chalk up
one for age-induced brain-farts.

That page has long been bookmarked, btw - good guide for all the ancient
equipment around here. Thanks.


Will Honea