11.2 network install CD no can has work


I’ve had a problem with wireless networking in 11.2 that has resurfaced. I have an x86-64 (AMD) e-machines desktop from ~ May 2006. I’ve used opensuse since getting it. The machine is far from the router, so I prefer to use wireless.

I downloaded the x86-64 net install CD. I can boot from it, but it can’t activate my wireless network card.

When 11.2 first came out, I connected with the wired ethernet jack, and net installed that way. Wireless wouldn’t work, until I deleted the wired connection. Then it works.

A week or so ago, I installed whatever the opensuse updater wanted to. Then, wireless stopped working! There’s no wired connection to delete. Eventually I plugged in wired, works fine, installed a few updates, disconnected wired, wireless still doesn’t work.

I then booted from the net install cd, and as before the wireless doesn’t work.

It’s rather frustrating that the install CD doesn’t work. I don’t want to re-download the net install CD unless something’s been fixed. Isn’t insanity doing the same thing N>1 times expecting a different result?

I realize figuring out wireless card drivers, settings, etc is a nightmare. FWIW the box the card came in says:

Linksys by cisco
wireless PCI adapter
model: WMP110
S/N: MTF10J204165

Any ideas?


Ok just as a check have you tried restarting your router. My Cisco router sometime is unreachable a reboot (unplug replug) brings it back.

Yeah, I tried that already, no luck.

I’m having similar issues with the same card. I can get the card up and running after hibernating by using:

rmmod ath9k
modprobe ath9k

That’s the only partial solution that I’ve found at the moment for the Linksys WMP110 and OpenSuse 11.2 X64.

Long shot #1:

It may be that the last kernel update made a related module incompatible. I am not sure which packages are involved but you could investigate under Yast and just reinstall them. That may re-run associated installation scripts. You may need your kernel headers installed if a re-compile on the fly is required.

Long shot #2:

Try ndiswrapper with the Windows driver. I have used ndiswrapper for a couple of wifi cards under DSL a couple of years back. Seemed to work quite well.

Here is link How to install your Linksys WMP110 wireless card on linux « My Blog

which looks interesting.