11.2 milestone 3 desktop test

I’m testing milestone 3 for about a week now on this machine,
had a spare hard drive for this install and I must say it turned out very well.

I used network install iso, installed it with minimal X window option and added KDE4 factory repos when it was done.
Using 185.18.14 nvidia driver and wine-1.1.25 to run some games in my spare time, amarok for radio and smplayer for videos.
I sometimes plug in a 300gb ntfs drive to copy some movies or other stuff, need to mount and umount as root but it works fine,
although I haven’t tried to write anything on it.

I don’t use too many applications but the ones I do work nicely.
For example there’s gimp, kwrite, ark, k3b (packman version), firefox 3.5, dolphin, kmix and yast.
Kwin desktop effects work fine and I can’t find any performance issues with compositing like in the past.
Glxgears report 485.130 FPS in fullscreen and 5079.995 FPS windowed.
CD burning and ripping works, sound works, flash player in firefox works, NTP configuration works.

These are the repos set up in yast at the moment:

Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_Factory
Index of /repositories/KDE:/Qt/openSUSE_Factory
Index of /pub/packman/suse/11.1
Index of /update/11.2
Index of /factory/repo/oss

Hardware info doesn’t seem to recognize some of the components but it’s not crashing and I haven’t noticed any problems.
“AMD Processor model unknown” is listed, that should be AMD Phenom II X2 550 3,1GHz AM3
“USB Reciever” and “USB-compliant keyboard” are supposed to be my Logitech MX1100 mouse.
Other hardware is properly listed like the geforce 9500GT, syncmaster and realtek ethernet card.

I’m very happy with this milestone 3 OS and I’ll use it for my home multimedia system unless it starts crashing.
I’ll also try to report the bugs if I find any, but so far it’s been great. Cheers

Hi @finders
I’m sure you are having fun with that and the feedback is interesting, but it’s not really milestone 3 as distributed (kde4 beta2), nor is it the current state of the milestone factory (kde4 rc1). Is it kde4 rc2?

What are the widehat repos for? They could be the original distribution repos I suppose. I came upon one by accident recently and wondered what.

I updated my M3 from factory at w/end. I don’t think you mentioned VirtualBox. I had VirtualBox 3.0.2 (11.1 version) working perfectly on M3, but after the kernel update from factory, I can’t recompile the VBox kernel module. You might consider that point, if you plan to use that sytem for daily work.

The KDE version is 4.2.96 (KDE 4.3 RC2) “release 142”
/distribution/11.2/ repos were there by default, must be the location of future oss and non-oss repos.
Updated the base packages twice already, all from /factory/repo/oss/ and I haven’t seen any issues after the update.
I don’t have virtualbox on this machine yet, got it on another one (11.1 kde 3.5)
Will try to install it here just to see if it works.

Just did this and it’s working as far as I can tell.

VirtualBox-3.0.2_49928_openSUSE111-1.i586.rpm from virtualbox.org
Kernel version here is kernel-default 2.6.30-10.3

Still need to install some random os in it, but the module compiled with no problem.

Thanks for previous replies and doing VBox - same release as mine - installed ok but not the module recompile so it failed to start a VM.

I think I need to check my 11.2 kernel, I know its 2.6.30-10 something, but need to switch from 11.1 to do that. Anyway M4 is coming out this week or next. :slight_smile:

Just did an upgrade with yast and am now in milestone 4

That was quick. Is that the total M4 system as per release, or could there be more updates between now and the weekend, I wonder?

I find that doing a update Yast or zypper one gets releases a bit earlier than the announced releases. I suspect that not all packages are on the updaae stack yet tho. there is a updated kernel and new thunderbird kde 4.3 is still in rc1

My update last weekend gave me kernel 2.6.30-10.1. Hopefully that is the problem with the VBox 3.0.2 kernel module compile error. :wink: I think an update is on the cards.

Updated this morning. MC says I am on M4. Kernel updated to, but kde 4.3 rc1 still there.

Update was held up early on by bad language (en) package. It never completed, kept retrying and eventually asked abort/retry/ignore, ignored it, and update continued to end. Retried that package at the end, but it said wasn’t there, so hopefully it was pulled and you won’t get the issue.

Did a zypper verify to check, it picked up and solved a couple of dependency problems. After re-boot (no issues), experienced a couple of application problems, but I don’t think the repos are fully at M4 just yet.

Recompiled VBox 3.0.2 kernel module. No problem this time, and it worked through to VM with guest and shutdown. :slight_smile:

Switched from the default kernel to kernel-desktop few minutes ago,
just fixed the nvidia driver and logged in, everything seems to be normal.
I think abort/retry/ignore turns up when the files on the server change while you’re doing the update. Happened to me a lot in the past, never had any serious issues because of that.

Glad you solved your VirtualBox problem. Cheers