11.2 M4 install initrd issue

I have just installed 11.2 M4 a couple of times. I discovered the last time around that the issue is actually initrd not being created during the install.

I installed the x86 version.

Has anyone else run into this issue?


I ran into a problem where milestone4 install failed, where I suspected grub at fault because of many grub errors (with my having a large 1.2 TB partition which I speculated as being possibly responsible for my problem). I did not check to see if it was initrd not being created which impacted grub creation ( ? ) … and in hindsight I should have checked for that possibility. … in my case it was the x86_64 version: Grub error installing second openSUSE on Hard Drive - openSUSE Forums

What were the symptoms that made you believe it was initrd that was not created?

I have stopped looking at this for now (other priorities came up, and I’m waiting for a backup PC to be returned, before I experiment too much).

I have successfully installed the 32-bit milestone4 on a sandbox PC, so I know it works some of the time.

This is a second partition that had a previous install of 11.1 x64. The partition is only 30G.

During the boot process I noticed that Grub was not overwritten as expected. So, I booted my stable version looked at the other partition and found a properly built menu.lst. So, I edited the menu.lst and rebooted.

After selecting M4 in Grub I get a File Not Found. I thought maybe the link wasn’t setup correctly to vmlinuz or the root= statement was incorrect. I found both to be fine. Then I found the initrd link to initrd-2.6… but that file didn’t exist.

So far I have been unable to create an initrd for the new install.

Installing 11.2 M4 x64 from the live CD worked correctly.

Going to ding a bit deeper in this version and try x86 again.

I also had an initial problem where initrd wasn’t built when i had root partition on LVM which was on a software RAID 0 stripe (has been reported but i wonder if they will even think about fixing this since that is such an unusual way to install). Though i don’t have any problems with a bootloader since i have only one /boot partition for both 11.1 and 11.2 M4 and chainloading Windows 7 RTM.