11.2 KDE sound & no sound

I have recently installed 11.2 with KDE

I have problems regarding sound:
systemsounds and Amarok have sound.
VLC has NO sound
Firefox (for instance YouTube) has No sound.

I find it all very confusing, why isn’t theire a systemwide configuration for sound. (well it looks their is, but it is not working in all apps)

Before Oldcpu gets here, did you check the PCM levels in Kmix? :smiley:

Yeh, i played around with all settings in Kmix…but that did not solve the issue why some apps have sound and others don’t

Some apps have sound and some do not … hmm … what can you tell us about these apps ?

My advise is for users to stick with only 4 software package manager repositories: OSS, Non-OSS, Update and Packman and add no others. None. None at all. Guidance for adding packman is here: Repositories/11.2 - openSUSE-Community

What is the output of:
zypper lr -d
do you by chance have more than 4 repositories ?

Have you attempted to replace the crippled Novell/SuSE-GmbH packaged applications with the non-crippled Packman packaged versions ? You can tell packman packaged versions by the “pm” in the version number.

If you go to YaST > Software > Software Management, you can change the “filter” to “search” and find various applications.

Note one can get codecs from packman by installing the Packman packaged versinis of libffmpeg0/ffmpeg (which pick up codecs in their dependencies) , w32codec-all, libquicktime0, libxvidcore4 , … etc …

Note the versions of those apps on videolan repository have the codecs stored in different locations and typically break the audio on packman packaged applications, hence stick with OSS, Non-OSS, Update and Packman and don’t use apps from the videolan repository (with exception of application “libdvdcss” ) .

If you have already added more than those 4 and did not realize the risks you were opening up yourself to, you can try to repair any “damage” / "unwanted crippled sound " side effects by following RedDwarf’s guide here: Check your multimedia problem in ten steps - openSUSE Forums

Well I followed your advice and did a step-t0-step check with:
RedDwarf’s guide here: Check your multimedia problem in ten steps - openSUSE Forums

I noticed I missed those gstreamer packages, which I now have added.

But conclusion is: I still have the same problems with sound:
I have systemsounds and Amarok and Kafeine has sound.
VLC has NO sound
Mplayer has NO sound
Firefox (YouTube) has NO sound.

I have a 64 bits system, so as adviced I did not add w32-codecs all, because It would not make a differents

Ensure you have the Packman packaged libffmpeg0/ffmpeg0 and their packman packaged dependencies. If you have videolan packaged apps it will break your sound for some Packman packaged applications. Install smplayer to get more control over mplayer. Note in both vlc and mplayer you can select the sound output module. Try the different modules. Try MORE than just .mp3. Try also .wav and .wma and other formats.

Please only try ONE multimedia application at a time. So close completely any other multimedia application when testing.

Ensure you check PCM volume levels.

For youtube in firefox, ensure NO other multimedia application is running, ensure you have flash-player installed. You may need to remove libflashsupport application, in which case you need to reboot. Is your openSUSE a 32-bit or 64-bit ? That makes a difference with flash-player.

I had the same problem,
I solved it. After many install, I found something that worked.
Install alsa-plugins-pulse-32bits , alsa-firmware, alsa-tools.
I use a 64bits system too, but i didn’t find another solution.
I’ve got sound with flashplayer and VLC.

I had the same sound problem, ie. :

  • sound working fine with amarok 2.1.1 (ogg, mp3, wma)
  • no sound but video with kaffeine playing DIVX

I followed your instructions by removing all the repositories but OSS, NON-OSS, openSUSE update, NVIDIA, and Packman.
Then I deleted and re-installed these packages only from Packman and NON-OSS :

  • amarok from NON-OSS:
    amarok-lang-2.1.1-7.6.noarch
    amarok-2.1.1-7.6.x86_64

  • libxine from Packman :
    libxine1-1.1.16.3-3.pm.26.2.x86_64
    libxine1-pulse-1.1.16.3-3.pm.26.2.x86_64
    libxine1-codecs-1.1.16.3-3.pm.26.2.x86_64
    libxine1-gnome-vfs-1.1.16.3-3.pm.26.2.x86_64

  • Kaffeine from Packman (older release, but a working one)
    kde3-kaffeine-lang-0.8.8-1.pm.4.14.noarch
    kde3-kaffeine-0.8.8-1.pm.4.15.x86_64

  • lame from Packman
    lame-3.98.2-1.pm.4.9.x86_64
    twolame-0.3.12-0.pm.3.1.x86_64
    libmp3lame0-3.98.2-1.pm.4.9.x86_64
    libtwolame0-0.3.12-0.pm.3.1.x86_64

  • ffmpeg from Packman
    ffmpeg-0.5.20592svn-0.pm.1.1.x86_64

  • w32codec-all from Packman
    w32codec-all-20071007-0.pm.1.1.i586


Thanks for your advice oldcpu, openSUSE rox so much!

Did.
OpenSUSE 11.2 x86_64 / KDE4.3.1

Does that help at all ?

If it were me, I would also install libffmpeg0, libquicktime0, and libxvidcore4 from packman. I’m also a big smplayer fan, so I also tend to install that

Yes that help me so much, it works.
And I also installed libffmpeg0, libquicktime0, and libxvidcore4 from packman.

I have installed VLC 1.0.3 from Packman and NOT from VideoLAN repos. It works fine too.

Fine, fine, fine. So perfect! :slight_smile:

Hi there, i will use this title for my own issue. KDE notification sounds, like the login / logout chimes, are not playing for me! I have codecs installed. I also have sound on amarok, and checked the volume levels.

Any ideas?

Do you have login sound when you login as root?
I have trouble with no sound in YouTube, but when I start Firefox from terminal I have sound. Maybe it’s permission trouble.
(I know this is not a solution…:))

Nope, not even in root it will play notifications. (Like, kopete ones. Even when i manually play them to sample at the notifications dialog, nothing.)