11.2 installs, 3 out of 3

I’ve installed 11.2 on 3 machines so far and it’s looking good. One is a white box AMD64 tower, the others i686 notebooks, a Toshiba Satellite and a Dell 700m. In all case I opted for a new install but preserving /home.

Sound just worked on the notebook computers. The tower has no sound device. I also installed restricted formats software via one-click on the Dell and MP3s and MP4s play fine.

The only tweak I needed was to change the hostnames to my liking after automatic configuration.

A few glitches:

On the Toshiba which uses an external USB HD (the internal one is broken), it failed to import the fstab from 11.1 automatically and so suggested formatting /home. A click on the manual import fixed that and it then suggested formatting only /.

YaST failed to start from the menu in one session. It just bounced the cursor for a while and did nothing. I could see that kdesu /sbin/yast2 processes were left around. Probably something to do with authorisation caching. A restart fixed that.

YaST also failed to save my DNS domain on one notebook so local FQDNs would work but not short names. /etc/resolv.conf was missing a search line. Entering YaST network devices, and saving again fixed that. Who knows what glitch caused that.

No more permission problem on CD/DVD like in 11.1. Good.

Quite zippy (though these machines all have 1GB RAM). Good.

Not bad for a start. The real test is when I upgrade my workhorse over the holidays. It has many services running so I’m debating new install vs upgrade. Moving to ext4 is an attraction I must say.

11.2 has been good to me thus far.

I installed 11.2 on 4 Desktops , with a 4 out of 4:

  • 64-bit Intel Core i7 920 w/6GB (Asus P6T Deluxe V2 motherboard) w/ PCI-e nVidia GeForce GTX260 graphics [age-6 months]
  • 32-bit AMD Sempon-2600 w/1GB (Epox EP-8K7A motherboard) w/AGP ATI RV280 (Radeon-9200Pro) graphics [age-4 years]
  • 32-bit AMD Athlon-2800 w/2GB (Asus A7N8X Deluxe motherboard) w/ PCI nVidia GeForce 8400GS graphics [age-5 years]
  • 32-bit AMD Athlon-1100 w/1GB (MSI KT3 Ultra motherboard) w/AGP nVidia GeForce FX5200 graphics [age 9-years]

I still have 2 laptops where I could put 11.2 on (they are both running 11.1), but I am going to wait a bit:

  • 64-bit Dell Studio 1537, Intel P8400 w/4GB, w/ATI Radeon 3450HD graphics [age-1 year]
  • 32-bit Fujitsu-Siemens Amilo 7400M w/1.256 GB w/Intel 1.5 celeron, and Intel i855 graphics (?) [age-5 years]

My wife’s PC (the sempron-2600 with the ATI RV280) is running under the radeon openGL driver with special desktop effects disabled. Enabling them causes artifacts in 11.2. This is in contrast to 11.1 where the radeon driver worked for special desktop effects on that hardware.

Thus far, one week after the 11.2 release the only 11.2 aspects that I am still sorting and trying decide an approach for my specific (non-common) applications, which is if I should wait for applications to show up on the 3rd party repositories, or if when there are no rpms if I should:
(a) install binary/.run files where available (such as virtual box)
(b) rebuild from an 11.1 rpm src file
(c) custom compile from source

Fonts were great for me. Best I’ve had yet. But I note fonts are subjective. I’ll look at the fonts of some one else who hates their fonts and I’ll love them, and then after they finally configure their fonts the way they like and proudly post them, I’ll end up shaking my head with disgust at the horrible fonts they rave about. Subjectivity has to be the word.

Sound works great. Flash works great. vnc works great (the way I use it). Network printing and scanning works great with openSUSE-11.2 on both our old HP-Deskjet-5652 and now also on our new (arrived today) HP-Photosmart-Premium-C309a wireless All-in-one printer. Hot plug automount of USB external ntfs formatted hard drives works great. I still have some firewire testing to do.

I had some minor hiccups due to our subLAN router firewall, that I had to spend some time checking, to see if might be an 11.2 issue. It was not.

And I do have a very subjective sense that the KDE-4.3.1 desktops (on all 4 PCs) is slightly snappier. But that IS subjective.

For my hardware, and for the software that I use, thus far this is shaping up to be the best openSUSE yet (but the jury is not out, as I have 2 more PCs to install this on, and more 3rd party software yet to install).

For VBox, generally a RPM for the previous openSUSE version will work fine, but you will have to install kernel sources and rebuild the driver. Or wait a bit and there will be a VBox release for 11.2.

For vbox I used the generic Linux version install and runs fine.

The only problem I have is a wheel scroll in both Firefox and Thunderbird.

In FF if I scroll up with mouse wheel the page changes. I have tried about everything I can think of or find on the web tried shutting off any thing related to gestures in about:config. nothing works. it is odd but if I scroll up the previous page comes up but if I hold the mouse steady and that page will scroll up but if I move the mouse at all or scroll down then a scroll up changes the page. The mouse works fine in all other apps except TB there the focus jumps all over the place with a up scroll. Maybe because I copied the data from the old 10.2 partition or maybe the TB beta???

Any how over all I like 11.2 and other then the FF/TB mouse irritation have seen no major problems.

A note: I had some problems with Samba but it turned out that Suse ships with the firewall totally locked down. This is good but a note in the samba setup screens that you need to turn on the local net in firewall would have saved me a couple of hours :sarcastic: I was cursing Suse about getting Samba right because of all the problems I had in 10.1 and 10.2.But it actually worked out of the box once I had the Firewall configured right.

A note on Virtualbox be sure to set the network adapter to bridged not NAT if you want to see the VM from other devices on the net.

Fortunately for me 11.2 has been almost trouble free. My only issue, which I sorted in RC1 was the kernel defaulted to Desktop. This kernel was causing issues with power management for me, switching to default kernel solved it. Otherwise it’s perfect.

One reason for preferring the openSUSE specific RPM is that it correctly sets up the init script for loading vboxdrv at boot. I think the generic .bin may require some manual configuration.

So I successfully installed openSUSE-11.2 on my 64-bit Dell Studio 1537, Intel P8400 w/4GB, w/ATI Radeon 3450HD graphics earlier this evening at our Linux User’s group.

OK, all was not perfectly smooth during the install. I did a clean install, but kept the old /home, and foolishly I left 3D graphics enabled. I previously had KDE-4.3.4 (running openSUSE-11.1) on that desktop. Well openSUSE-11.2 on the very first boot to user oldcpu frooze. It required a hard shutdown. User oldcpu would not boot KDE-4.3.1 with the radeon driver (with the previous KDE-4.3.4 settings). At first I speculated going back from KDE-4.3.4 (on 11.1) to KDE-4.3.1 (on 11.2) may have caused the freeze.

So I booted to run level 3, logged in, created with YaST a new user “joe” , logged out and back in as user “joe”, and ran startx and 11.2 with KDE-4.3.1 booted fine. Then one of the users of our Linux group quickly switched on 3D (before I could say “stop”) and KDE-4.3.1 froze with the radeon driver. Again, a hard shutdown was needed.

So I again booted to run level 3, and this time I installed the proprietary (catalyst 10.2) ATI driver “the hardway” (which is NOT hard). Then I booted as user “joe” and as user “oldcpu” and everything worked fine with KDE-4.3.1. So the problem was the radeon driver before. I then deleted user “joe” and I’m happy with openSUSE-11.2 running very nicely on this laptop.

So thats now 5 successful 11.2 installs, and one old laptop still on 11.1. :slight_smile: